Signaler

Url étrange ! [Résolu/Fermé]

Posez votre question bg62 22664Messages postés samedi 22 octobre 2005Date d'inscription ContributeurStatut 21 septembre 2017 Dernière intervention - Dernière réponse le 18 janv. 2010 à 11:51 par bg62
Bonjour,
je me retrouve suite à un clic sur :
http://www.mariagemovies.com/...
au lieu de:
http://www.mariagemovies.com/thierry-sarraute-videaste-professionnel.php
avez-vous une idée de où cela peut venir ?
et comment corriger pour empêcher cela ???
merci de ne répondre que si vous savez !
@+
Utile
+1
plus moins
Essaye en mettant "SetEnv SESSION_USE_TRANS_SID 0" dans ton .htaccess
Je suis aussi chez OVH et je n'ai pas ce problème avec Wordpress.
Cette réponse vous a-t-elle aidé ?  
Utile
+0
plus moins
Le PHPSESSID se transmet par l'url quand les cookies sont désactivés sur le navigateur.
J'ai été sur le site en question et cliqué sur le lien "Thierry Sarraute" en haut à droite et je n'ai pas ça.
Utile
+0
plus moins
pense pas ... ça ne le fait pas à tous les coups ... doit y avoir autre chose ! mais ????
cela peut arriver sur d'autres pages aussi mais pas toujours ça me paraît plus qu'étrange ce truc ...
et ... peut-on éviter ça à partir du codage du site ou avec un fichier à ajouter ????
Utile
+0
plus moins
C'est bien un problème de cookies de session. Il y a sûrement un paramétrage du CMS à faire quelque part.
Belle daube d'ailleurs ce CMS, le code généré est épouvantable.
Utile
+0
plus moins
rien à voir avec le CMS, là c'est testé approuvé et garanti ... et c'est justement ce qui me pose problème !
certes le code généré n'est pas au dernier 'top', mais pour une 'daube' ... (merci :-) ) faut voir ce que ça donne au niveau pratique et possibilité de référencement .... mais sans savoir pourquoi en parler ?
et encore une fois ce problème vient bien de qq part ... mais d'où ?
il reste l'ancien site (celui-là plus que mal codé ! ) en ligne et c'est chez ovh ... je ne vois que ces deux pistes là ...
Utile
+0
plus moins
Approuvé et garanti ?!!
http://validator.w3.org/...

72 erreurs.
sans commentaires...
Utile
+0
plus moins
pour l'instant il y a ceci :
# Pages d'erreur
ErrorDocument 401 /errors/401.html
ErrorDocument 402 /errors/402.html
ErrorDocument 403 /errors/403.html
ErrorDocument 404 /errors/404.html
ErrorDocument 500 /errors/500.html
ErrorDocument 404 /errors/404.php

        RewriteEngine on
        RewriteCond %{HTTP_USER_AGENT} "BackWeb" [OR]
        RewriteCond %{HTTP_USER_AGENT} "eCatch" [OR]
        RewriteCond %{HTTP_USER_AGENT} "HTTrack" [NC,OR]
        RewriteCond %{HTTP_USER_AGENT} "teleport" [NC,OR]
        RewriteCond %{HTTP_USER_AGENT} "webcopier"
        RewriteRule !^avertissement.*$ /avertissement.php [L]

je mets quoi et où ???
Utile
+0
plus moins
http://forum.webrankinfo.com/supprimer-phpsessid-dans-url-t80897.html
bg62 22664Messages postés samedi 22 octobre 2005Date d'inscription ContributeurStatut 21 septembre 2017 Dernière intervention - 16 janv. 2010 à 20:52
pas mal là mais faut mettre dans le codage php alors que ça ne vient pas de là ... j'aimerais bien trouver la cause avant d'essayer un remède de ce genre :-)
bg62 22664Messages postés samedi 22 octobre 2005Date d'inscription ContributeurStatut 21 septembre 2017 Dernière intervention - 16 janv. 2010 à 21:10
regarde la fin de ce post :
http://forum.ovh.com/archive/index.php/t-19520.html
la même chose chez ... ovh !?!
( http://www.google.fr/... )
Utile
+0
plus moins
Tu mets n'importe où.
Si tu ne sais vraiment pas choisir : tout en haut
bg62 22664Messages postés samedi 22 octobre 2005Date d'inscription ContributeurStatut 21 septembre 2017 Dernière intervention - 16 janv. 2010 à 20:50
ok on va essayer mais :
SetEnv SESSION_USE_TRANS_SID 0
ou
"SetEnv SESSION_USE_TRANS_SID 0"
?
avion-f16 18236Messages postés dimanche 17 février 2008Date d'inscription ContributeurStatut 15 septembre 2017 Dernière intervention - 16 janv. 2010 à 20:56
Sans les guillemets :)
On y est presque, en espérant que ça fonctionne ;)
bg62 22664Messages postés samedi 22 octobre 2005Date d'inscription ContributeurStatut 21 septembre 2017 Dernière intervention - 16 janv. 2010 à 20:59
c'est en ligne ... maintenant pour tester ... comme ça ne le fait pas à tous les coups ???
avion-f16 18236Messages postés dimanche 17 février 2008Date d'inscription ContributeurStatut 15 septembre 2017 Dernière intervention - 16 janv. 2010 à 21:07
Il faut essayer plusieurs fois.
Si par exemple tu vois le phpsessid une fois sur trois que et pendant toute la soirée tu ne vois rien, alors le sujet est résolu.
bg62 22664Messages postés samedi 22 octobre 2005Date d'inscription ContributeurStatut 21 septembre 2017 Dernière intervention - 16 janv. 2010 à 21:11
j'essaie demain en ayant nettoyé tout le cache ...
@+ bg
Utile
+0
plus moins
C'est quand même bizarre, je suis chez OVH et je n'ai jamais eu ce problème.
Tu verras bien si ça le fait encore ou pas après avoir modifier le .htaccess
bg62 22664Messages postés samedi 22 octobre 2005Date d'inscription ContributeurStatut 21 septembre 2017 Dernière intervention - 17 janv. 2010 à 00:33
ben il en ont un ou deux gros par an (dont certains avec google même ...) j'espère que c'est pas de nouveau ça !!! je te tiens au courant ...
bg62 22664Messages postés samedi 22 octobre 2005Date d'inscription ContributeurStatut 21 septembre 2017 Dernière intervention - 18 janv. 2010 à 11:51
ça commence à venir ... pour l'instant apparemment plus de problème d'url, maintenant il faut que je vois pour supprimer les fichiers (anciens) leurs traces dans google & C° et gérer les redirections ...
@+

Les membres obtiennent plus de réponses que les utilisateurs anonymes.

Le fait d'être membre vous permet d'avoir un suivi détaillé de vos demandes.

Le fait d'être membre vous permet d'avoir des options supplémentaires.

Vous n'êtes pas encore membre ?

inscrivez-vous, c'est gratuit et ça prend moins d'une minute !