Recherche
Posez votre question Signaler

Monter un serveur ssh [Résolu]

g2r - Dernière réponse le 4 oct. 2009 à 08:27
Bonjour,
Je voudrais savoir comment faire pour monter un serveur ssh sous windows. J'ai trouvé plusieurs logiciels clients ssh, mais pas de serveur.
Mon but est de pouvoir recevoir des fichiers de manière sécurisée, l'expéditeur utilisant un logiciel sftp.
Merci.
Lire la suite 
Réponse
+0
moins plus
Les serveurs ssh gratuits sous Windows ne courrent pas les rues.

Peut-être chez cygwin ?
http://cygwin.com/cgi-bin2/package-grep.cgi?grep=sshd
Ajouter un commentaire
Réponse
+3
moins plus
ça m'intéresse aussi.
Je commence à essayer d'installer le biniou sous Windows.

Dans cygwin, il faut installer le package suivant:
openssh-3.7.1p2-1 (ou plus récent)

Il contient le client et le serveur.

Une fois installé, il faut générer le fichier de configuration:
ssh-host-config

Et pour démarrer le serveur ssh:
/usr/sbin/sshd

Avec un netstat -an, tu devrais voir ton port 22 ouvert en écoute (LISTENING), et tu devrais voir sshd.exe dans la liste des process.

Mon serveur ssh démarre bien, mais j'ai une merdouille au niveau du login (login/mot de passe refusé). Il faudra que je regarde quand j'aurai le temps...
Ajouter un commentaire
Réponse
+0
moins plus
Ne connaissant rien à cygwin, j'ai trouvé un package (OpenSSH for Windows) qui se charge d'installer cygwin et de presque tout configurer.
http://lexa.mckenna.edu/sshwindows/
Il me reste juste à remplir \etc\group et \etc\passwd, mais c'est là que j'ai des problèmes... Je ne comprends pas comment faire...
sebsauvage 33290Messages postés mercredi 29 août 2001Date d'inscription ModérateurStatut 26 mars 2015Dernière intervention - 30 oct. 2003 à 16:07
Pas mal !
Merci !

Je vais essayer ça.
Répondre
Ajouter un commentaire
Réponse
+0
moins plus
Pour la création des groupes et users, c'est dans la doc:
( C:\Program Files\OpenSSH\docs\quickstart.txt )

1) Ouvrir une fenêtre Dos dans C:\Program Files\OpenSSH\bin
2) Taper: mkgroup -l >> ..\etc\group
3) Taper: mkpasswd -l >> ..\etc\passwd
4) démarrer le serveur ssh: net start opensshd

Et ça marche !

La différence avec le serveur sshd standard de cygwin est que sous cygwin, on a un shell Unix, alors qu'avec ce OpenSSH on a un shell Windows.

Mais bon c'est nickel.

Merci pour l'URL, je la garde bien au chaud !
fredono 1Messages postés dimanche 16 octobre 2005Date d'inscription 16 octobre 2005Dernière intervention - 16 oct. 2005 à 01:40
quel qu un peu maider jai installer openssh mais c pour créer les compte et password merci
Répondre
sebsauvage 33290Messages postés mercredi 29 août 2001Date d'inscription ModérateurStatut 26 mars 2015Dernière intervention - 17 oct. 2005 à 09:15
OpenSSH reprend les comptes de Windows.
Il suffit donc de créer des comptes utilisateur Windows et de taper les lignes de commande que j'ai indiquées au dessus pour recopier les utilisateurs dans la configuration d'Openssh.
Répondre
timoi 6Messages postés samedi 1 août 2009Date d'inscription 4 octobre 2009Dernière intervention fredono - 4 oct. 2009 à 08:27


Bonjour a toi

moi j'ai trouvé cela


http://doc.ubuntu-fr.org/putty


http://mozilla.tlk.fr/doc07.php

http://www.ragax.com/telecharger/putty

http://facilinux.fr/...
Répondre
Ajouter un commentaire
Réponse
+0
moins plus
mais quand je tape "net start opensshd", on me dit que le nom de service n'est pas valide.....
et puis comment faire pour éditer le fichier \etc\passwd ? il suffit juste de rajouter les logins de ceux qui sont autorisés à se connecter ?
enfin, concernant la gestion des clés, chaque utilisateur doit créer sa paire de clés et donenr au serveur la clé publique ? et pour celui qui gère le serveur aussi ?
Merci.
sebsauvage 33290Messages postés mercredi 29 août 2001Date d'inscription ModérateurStatut 26 mars 2015Dernière intervention - 30 oct. 2003 à 17:51
net start > je pense que le service doit être mal installé. Essai de réinstaller le package complet.
Tu es sous quelle version de Windows ?

passwd : il est possible de l'éditer à la main (voir http://minilien.com/?ZL5LcfMeXp ) ou bien en utilisant useradd ou adduser (si c'est installé dans ton cygwin).

mais le programme mkpasswd va automatiquement lire les users de Windows et crééer les lignes correspondantes dans passwd. Bien pratique.
Donc tu peux très bien créé le user que tu veux dans Windows, puis lancer mkpasswd avec l'option -u pour ne créer que ce user dans le passwd.


chaque utilisateur doit créer sa paire de clés>
Non.
Il y a 2 modes de fonctionnement pour le client.
Soit:
A) Le client génère automatiquement des clés aléatoires, mais utilisées uniquement pour le chiffrement. L'authentification se fait avec login/mot de passe.
ou
B) Le client génère des clés fixes qui sont utilisés pour l'authenficiation. Le client n'a plus besoin de taper login/mot de passe.

La solution A est la plus courante et c'est l'option par défaut de la majorité des client ssh.
Pour la solution B, les opérations à effectuer sont décrites dans l'aide d'OpenSSH:
C:\Program Files\OpenSSH\docs\key_authentication.txt
Répondre
Ajouter un commentaire
Réponse
+0
moins plus
je viens de réinstaller le package mais "net start opensshd" me renvoie toujours la même erreur. J'ai regardé dans la liste des services avec la commande msconfig, est-ce que opensshd doit apparaître ? (j'ai windows xp familiale)
sebsauvage 33290Messages postés mercredi 29 août 2001Date d'inscription ModérateurStatut 26 mars 2015Dernière intervention - 30 oct. 2003 à 18:24
Je ne connais pas XP.
Je suis sous 2000.

Le service 'OpenSSHd' doit apparaître dans la MMC (panneau de configuration > services).
Répondre
sebsauvage 33290Messages postés mercredi 29 août 2001Date d'inscription ModérateurStatut 26 mars 2015Dernière intervention - 30 oct. 2003 à 18:29
Est-ce que tu as bien installé OpenSSH en tant qu'administrateur ?
Répondre
Ajouter un commentaire
Réponse
-1
moins plus
J'ai essayé d'installer le service opensshd comme indiqué sur le site de l'auteur mais ça ne fonctionne toujours pas... je crois que je vais donc abandonner...
En tous cas merci pour votre aide.
Ajouter un commentaire
Réponse
+0
moins plus
>> Est-ce que tu as bien installé OpenSSH en tant qu'administrateur ?
on ne m'a pas posé la question. de toute façon je n'ai qu'un compte qur mon pc, et je suis administrateur.
Ajouter un commentaire
Réponse
+0
moins plus
Bon... dommage.
Ajouter un commentaire
Réponse
+0
moins plus
Je remonte le thread.

J'ai trouvé un lien qui explique diverses solutions pour installer gratuitement un serveur ssh sous Windows:

http://www.jfitz.com/tips/ssh_for_windows.html#SSH_Servers

Ils donne en particulier 3 liens:
- comment configurer sshd dans cygwin: http://tech.erdelynet.com/cygwin-sshd.asp
- (lien déjà donné) serveur openssh autonome: http://www.networksimplicity.com/openssh/
- installation minimale pour un serveur ssh/cygwin: http://www.certaintysolutions.com/tech-advice/ssh_on_nt.html
Ajouter un commentaire
Réponse
+0
moins plus
il ya aussi putty ssh : http://www.commentcamarche.net/download/telecharger-90-putty

tafiscobar
sebsauvage 33290Messages postés mercredi 29 août 2001Date d'inscription ModérateurStatut 26 mars 2015Dernière intervention - 7 nov. 2003 à 10:03
oui oui, je connais.
Mais là on parlait des serveurs shh. :-)
Répondre
arca- 30 déc. 2003 à 13:02
slt,

J'ai installe ssh server avec cygwin, par contre, j'ai du mal avec la creation des clefs, je ne vois pas ou elles se situent (je veux generer une clef par user) et je ne sais pas si sous windows il y a aussi la notion de authorized_key à remplir ?

Merci
Répondre
blaise sebsauvage - 11 déc. 2004 à 16:09
je vien d'installer openssh sur mon poste win 2000 server
j'aimerai utiliser putty comme client pour accéder à mon serveur à distance
mais je ne comprend pas grad chose à la notion de groupr et de clé
j'aimerai donc savoir comment configurer openssh sur mon poste et putty sur le poste client
merci
Répondre
Laurent sebsauvage - 23 févr. 2005 à 15:09
Comment fait on pour ajouter des utilisateurs ?

Merci
Répondre
sebsauvage 33290Messages postés mercredi 29 août 2001Date d'inscription ModérateurStatut 26 mars 2015Dernière intervention - 23 févr. 2005 à 16:00
http://www.commentcamarche.net/forum/affich-613511#8
Répondre
Ajouter un commentaire
Réponse
+0
moins plus
Salut

j'ai installé le serveur ssh de cygwin sur un XP pro sp2.
le service est installé, et démarre correctement à chaque demarrage de windows.
Par contre la commande net start sshd ou net stop sshd ne fonctionne pas: le service mets 3 plombres à répondre.

de plus si j'essaye de me connecter il me renvoi "ssh: connection refused" ou un truc comme ca.

netstat -an ne monbtre aucun port 22 ouvert en Listening. bizarre, le servbice tourne et le firewall est correctement reglé.

une idée serait trop bienvenue
mxp- 18 avril 2005 à 17:02
Salut,

J'avais le même problème que toi mais j'ai trouvé la solution:
Il faut se rendre dans
Démarrer/Panneau de Config/Comptes d'utilisateurs
là tu repères tes utilisateurs, ensuite tu vas dans :
Onglet "option avancé" et tu selectionne le bouton "Avancé"
Tu te rends dans la partie "Utilisateurs" et tu selectionne l'utilisateur que tu voudras entrer en ssh, petit click droit et "Définir un mot de passe".
Ensuite tu saisi un mot de passe.
Et tu retentes de te connecter en ssh sur ton cygwin avec ce login et le nouveau mot de passe saisi, et normalement ça passe.

Bon courage.
Répondre
Ajouter un commentaire
Réponse
+0
moins plus
Pour tous ceux qui veulent installer un serveur ssh sous windows sans se prendre la tête, je vous conseille l'adresse suivante: http://www.buzzsurf.com/surfatwork/

Ca utilise putty et OpenSSH sous Windows et c'est très bien expliqué. Même moi j'ai réussi à tout comprenre ^^
Ajouter un commentaire
Réponse
+0
moins plus
Bonjour,
j'ai suivi à la lettre les indications du site dont le lien viens d'être donné.(très bon site ).
j'ai crée un serveur ssh chez moi avec openssh, j'ai crée un compte windows avec mot de passe, j'ai entré les commandes indiquées pour qu'il repere les users et les passords
et j'ai installé sur un autre pc le client (putty.exe + shunnel.bat)
cependant je rencontre deux problèmes:
-lorsque je lance le client de mon pc pour voir si ça marche, putty me dit "fatal error,connexion refused"
mais c'est peut etre juste que l'on ne peut pas se connecter au serveur quand on est le serveur (ce qui peut paraitre normal)!!!
-par contre ce qui n'est pas normal c'est qu'à partir d'un autre ordinateur(derriere un firewall) il met :
"network error, connexion time out". Quelqu'un a-t-il déjà eu cette erreur ? pour info j'ai windows xp sp2 et celui qui essaye d'etre client ssh
se connecte à internet par VPN...

Merci...
jj- 18 déc. 2005 à 14:35
salut,

j'avais ce probleme la, alors j'ai utilisé le port 22 et apres ca a marché...

par contre j'aimerai savoir comment on change le repertoire sur lequel on tombe juste apres la connection...

merci a plus
Répondre
jj- 18 déc. 2005 à 14:42
par contre pour acceder a partir de l'autre pc, il faut verifié que ton adresse ip n'est pas changé entre le moment où tu la note pour aller sur l'autre pc et le moment ou tu essaie de te connecter.

si comme moi ton ip n'est pas fixe, il exite un truc no-ip qui "remplace" ton ip par une adresse fixe.


bye
Répondre
Ajouter un commentaire
Réponse
+0
moins plus
Au fait, j'ai créé une entrée dans la FAQ qui explique de A à Z comment installer un serveur ssh sousWindows, pour ceux que ça intéresse:

http://www.commentcamarche.net/faq/sujet-2132-Installation-dun-serveur-ssh-sous-Windows
Ajouter un commentaire
Réponse
+0
moins plus
Bonjour à tous,

J'ai voulu suivre la doc de sebsauvage mais j'arrive à un problème, quand je tape la commande ssh-host-config -y j'ai le message suivant :

bash: ssh-host-config command not found

Je ne sais pas quoi faire ?

merci de votre aide
deauvhyl- 12 sept. 2007 à 20:10
j obtient ce message
bash: ssh-host-config command not found
J' ai lu votre reponse à propos du PATH a changer mais g ne vois pas de quoi vous parlez. Soyez plus clair svp. De quel path, il s'agit ?
Répondre
Ajouter un commentaire
Réponse
+0
moins plus
Bonjour à tous,

J'ai voulu suivre la doc de sebsauvage mais j'arrive à un problème, quand je tape la commande ssh-host-config -y j'ai le message suivant :

bash: ssh-host-config command not found

Je ne sais pas quoi faire ?

merci de votre aide
Ajouter un commentaire
Réponse
+0
moins plus
Vérifie que ton PATH est correctement réglé.
ça doit être la source du problème.
Ajouter un commentaire
Réponse
+0
moins plus
Merci sebsauvage,

Effectivemement, j'avais mis dans le PATH cywin au lieu de cygwin,

super ça fonctionne

Merci encore
Ajouter un commentaire
Réponse
+0
moins plus
G tenté d'installé tout ça mais je n'arrive pas à lancer le service....

$ net start sshd
Le service CYGWIN sshd d'marre.
Le service CYGWIN sshd n'a pas pu ^tre lanc'.

Le service n'a pas signal' d'erreur.

Vous obtiendrez une aide suppl'mentaire en entrant NET HELPMSG 3534.


Une idée ?
Ajouter un commentaire
Ce document intitulé «  monter un serveur ssh  » issu de CommentCaMarche (www.commentcamarche.net) est mis à disposition sous les termes de la licence Creative Commons. Vous pouvez copier, modifier des copies de cette page, dans les conditions fixées par la licence, tant que cette note apparaît clairement.

Vous n'êtes pas encore membre ?

inscrivez-vous, c'est gratuit et ça prend moins d'une minute !

Les membres obtiennent plus de réponses que les utilisateurs anonymes.

Le fait d'être membre vous permet d'avoir un suivi détaillé de vos demandes.

Le fait d'être membre vous permet d'avoir des options supplémentaires.