Menu

Patrice33740 1 684

Membre
A propos

.

Inscription
13 juin 2010
Dernière intervention
23 avril 2019
Interventions
7 592
Sexe
Homme
Localisation
Arès, FRANCE

Aide formule SI et ET imbriqués

Bonsoir, Je rencontre un petit problème pour analyser des résultats dans le cadre de mon mémoire… J’ai un fichier avec les résultats de participants à un test. Ils ont chacun obtenu un score à ce test et j’aimerais en fonction de deux autres valeurs obtenir un profil pour ces individus. Par exemple mon participant en case A1 a un score... Lire la suite

Addition 2 cellules (incompatibilité de type)

Bonjour, Dans le code j'écris cette ligne : ActiveCell.Offset(0, 4).Value = CDbl(ActiveCell.Offset(0, 4).Value) + CDbl(ActiveCell.Offset(1, 4).Value) Celle-ci (ActiveCell.Offset(0, 4).Value (sa valeur est "")) est en texte ce qui me donne un Incompatibilité de type car CDbl(ActiveCell.Offset(1, 4).Value) = 3. Comment corriger l... Lire la suite

1
Merci

Bonjour, Utilises Val()

Macro avec résultat non pertinent [Résolu]

Bonjour, J'ai construit une macro VBA excel comme plus bas: Le range "a1" est en chiffre dur c'est à dire sans formule. Le range "C1" est le produit d'une formule : =somme(c2:c8000)-2600 Lors de la comparaison des deux cellules soit avec un résultat identique ou non le msgbox reste "Procédez à la réconciliation des soldes " I... Lire la suite

Instruction incorrecte à l'extérieure d'un bloc de type

Bonjour, Débutante en VBA je voudrais dans une feuille excel à l'aide de l'instruction select case (car j'ai beaucoup de case à écrire,j'ai simplifié le nombre pour la compréhension).Je voudrais colorer les cellules suivant leur valeur. Je n'arrive pas à démarrer la macro ,je butte au départ pour déclarer les variables je suppose . S... Lire la suite

Formule excel

Bonjour, Bonjour alors petite question un peu complexe. Je vais essayé d'être le plus clair possible. Alors j'ai deux onglets. Dans le premier onglet il y a des noms d'entreprises avec une liste déroulante dans la colonne B pour décrire l'activité de l'entreprise. Dans le deuxième onglet en colonne A j'ai le nom de diffé... Lire la suite

lier des colonnes au code VBA [Résolu]

Bonjour, J'ai environ 80 colonnes qui envoient leurs contenus dans différentes feuilles, parfois tel quel, parfois via un calcul ou une condition, et j'aimerai que ces codes soient "liées" à leur colonne de manière à pouvoir bouger une colonne dans ma feuille SOdr (de la colonne 5 à colonne 10 par exemple, parce que j'insère une nouve... Lire la suite

Fonction SI poussée [Résolu]

Bonjour, J'ai un tableau avec les références à produire et leurs quantités (Colonne A et B). A coté de ses deux colonnes, j'ai 4 magasins (A, B, C, et D) avec la quantité présente en stock pour chaque référence. Je souhaiterais avoir en dernière colonne, le magasin qui permet de répondre à la quantité à produire. Jusqu'ici tout va bie... Lire la suite

fonction sierreur sous excel 2003

dans une facture j'ai un résultat #na et je veux avoir une cellule vide lorsque j'enregistre ma facture.... avec cette formule =RECHERCHEV(C21;liste_produit;2;0) ça ne fonctionne pas si j'inscris =SIERREUR(RECHERCHEV(C21;liste_produit;2;0);"") aidez-moi svp....

Insérer une formule dans une cellule VBA [Résolu]

Bonjour, Je suis relativement novice en VBA. Je tente d'inclure une formule dans une cellule mais j'ai l'erreur suivante: "Erreur d'execution 1004", "Erreur définie par l'application ou par l’objet" Mon code ressemble à ceci: (Notez que la variable text contient le nom d'une worksheet) Dim recherche As String recherche = "=... Lire la suite

Retranscrire automatiquement dans un onglet les données de 2 autres onglets

Bonjour, Mon problème est le suivant, j'aimerais que dans mon onglet plan consolidé je puisse retranscrire les données provenant des onglets "data" et "data formation" pour les colonnes telles que : Matricule, Nom, Prénom, Manager, ancienneté, âge, CSP, sexe, plan, formation etc. L'utilisation d'une macro est elle adaptée ? Car je n... Lire la suite

VBA saut de page [Résolu]

Bonjour, J'ai déjà un code qui effectue divers opération sur une de mes feuille. et j'aimerai que lorsque la ligne 25 de ma feuille est hidden =true qu'un saut de page s'ajoute sur la ligne 26. Je n'y arrive pas est-ce que quelqu'un peux m'aider? Merci