La dll manquante. [Fermé]

Signaler
Messages postés
2866
Date d'inscription
dimanche 18 mai 2008
Statut
Membre
Dernière intervention
9 mai 2011
-
hossame
Messages postés
13
Date d'inscription
dimanche 21 septembre 2008
Statut
Membre
Dernière intervention
2 juin 2011
-
Bonjour,
après de multiple essaie pour tenter de démarrer mon pc sous windows en mode sans échec, avec la console de récupération avec les derniers paramètres rien a faire le logo de windows charge puis sa redémarre puis le logo puis sa redé...
il se trouve que j'ai installé ubuntu 8.04 avec wubi sur ce même pc et que j'ai avg dessus, et il se trouve aussi que avg a mis en quarantaine sur certains ordi : user32.dll et je me demande si de linux il ne l'a pas fait sur windows puis qu'il a accès au fichier. et je pourrais depuis ubuntu remettre la dll manquante, mais pb je ne suis pas sur qu'il manque une dll et secundo je ne sais pas qu'elle dll il manque --'

j'attends votre aide avec impatience :)

12 réponses

Messages postés
307
Date d'inscription
mardi 7 octobre 2008
Statut
Membre
Dernière intervention
22 novembre 2008
25
bonjour

avec linux , il y'a de grandes chances (!!!) que le MBR soit modifié
Messages postés
6353
Date d'inscription
jeudi 11 septembre 2008
Statut
Membre
Dernière intervention
28 octobre 2014
1 238
Bonsoir

J'ai eu le même problème avec un PC en dépannage, la faute à AVG.

Le meilleur moyen de remettre le pc en route :

S'assurer que le BIOS est bien réglé pour booter sur le lecteur de CDrom

Insérer le disque original de Windows XP dans le lecteur

Démarrer à partir du CD.

Lorsque l'invitation d'installation s'affiche, choisir "Installer" en enfonçant la touche "Entrée"

à la deuxième fenêtre enfoncer la touche R pour effectuer une réparation de Windows XP.

La réparation va s'effectuer, puis l'installation va se faire normalement (sans effacer les données du disque dur ) à la fin le numéro de licence sera demandé, et il faudra réactiver windows XP.

Tutos en images ici >http://www.pcentraide.com/index.php?showtopic=101668

et ici > http://www.pcentraide.com/index.php?showtopic=1559

Bon courage
Messages postés
2866
Date d'inscription
dimanche 18 mai 2008
Statut
Membre
Dernière intervention
9 mai 2011
29
enfaite je n'ai plus de fichier dans config c'est la le pb?
Messages postés
6353
Date d'inscription
jeudi 11 septembre 2008
Statut
Membre
Dernière intervention
28 octobre 2014
1 238
je ne sais pas si ça vient de là, dans tous les cas, le coup du PC qui redémarre en permanence sous XP :

affichage de la fenêtre du BIOS > Logo XP avec la barre d'attente > écran noir et redémarrage

Je suis à peu près certain que le fichier USER.32.DLL est absent ou corrompu.

Maintenant s'il en manque d'autres, la réparation comme expliquée plus haut remettra tout en place.
lunastix275
Messages postés
2866
Date d'inscription
dimanche 18 mai 2008
Statut
Membre
Dernière intervention
9 mai 2011
29
je viens de faire une recherche user32.dll est bien la, il y a même plusieurs exemplaire.
Messages postés
6353
Date d'inscription
jeudi 11 septembre 2008
Statut
Membre
Dernière intervention
28 octobre 2014
1 238
elle est peut être corrompue.

la seule qui nous intéresse c'est celle qui se trouve dans Windows\System32
lunastix275
Messages postés
2866
Date d'inscription
dimanche 18 mai 2008
Statut
Membre
Dernière intervention
9 mai 2011
29
dans system32 il y en a 2
Messages postés
6353
Date d'inscription
jeudi 11 septembre 2008
Statut
Membre
Dernière intervention
28 octobre 2014
1 238
pas normal
lunastix275
Messages postés
2866
Date d'inscription
dimanche 18 mai 2008
Statut
Membre
Dernière intervention
9 mai 2011
29
et pour le dossier config vide c'est normal ou pas?
Messages postés
6353
Date d'inscription
jeudi 11 septembre 2008
Statut
Membre
Dernière intervention
28 octobre 2014
1 238
oui tout à fait normal

par contre deux dll portant le même nom dans le même dossier c'est impossible.

est tu certains qu'il s'agit bien de deux fois user32.dll ?
lunastix275
Messages postés
2866
Date d'inscription
dimanche 18 mai 2008
Statut
Membre
Dernière intervention
9 mai 2011
29
Messages postés
6353
Date d'inscription
jeudi 11 septembre 2008
Statut
Membre
Dernière intervention
28 octobre 2014
1 238
première fois que je vois ça

est ce que tu peux aller fouiller le dossier system32 pour voir si c'est vraiment le cas et que ce n'est pas l'outil de recherche qui a une faiblesse, et par la même occasion regarde le poids de chaque fichier

normalement le fichier user32.dll pèse environ 565Ko
lunastix275
Messages postés
2866
Date d'inscription
dimanche 18 mai 2008
Statut
Membre
Dernière intervention
9 mai 2011
29
yen a un dans le dllcache et l'autre directement dans system32
Messages postés
6353
Date d'inscription
jeudi 11 septembre 2008
Statut
Membre
Dernière intervention
28 octobre 2014
1 238
je préfère.

le tout c'est de savoir si le fichier n'a pas été corrompu par avg.

maintenant il y a peut être un autre problème. mais quoi.

si tu as le CD original de windows xp tu peux toujours tenter une réparation, ça ne prends qu'une heure environs.
lunastix275
Messages postés
2866
Date d'inscription
dimanche 18 mai 2008
Statut
Membre
Dernière intervention
9 mai 2011
29
mais j'ai pas le cd --'
c'est la mon problème.
Messages postés
6353
Date d'inscription
jeudi 11 septembre 2008
Statut
Membre
Dernière intervention
28 octobre 2014
1 238
tu ne connais personne qui pourrai t'en prêter un ?

sinon tu peux le faire faire chez un dépanneur, mais ça coute dans les 50 euros si ce n'est pas un arnaqueur.
lunastix275
Messages postés
2866
Date d'inscription
dimanche 18 mai 2008
Statut
Membre
Dernière intervention
9 mai 2011
29
je vais voir si y a pas qqn.
le dépanneur je l'en****e surtout l'enforé que je suis aller voir tout a l'heure.
Messages postés
6353
Date d'inscription
jeudi 11 septembre 2008
Statut
Membre
Dernière intervention
28 octobre 2014
1 238
mouai, il ne sont pas toujours très sympas
lunastix275
Messages postés
2866
Date d'inscription
dimanche 18 mai 2008
Statut
Membre
Dernière intervention
9 mai 2011
29
ouais malheuresment.
Messages postés
13
Date d'inscription
dimanche 21 septembre 2008
Statut
Membre
Dernière intervention
2 juin 2011
1
bonjour,
j'ai un problème et je sais pas quoi fair.
lorsque je démare mon pc portable il m'affiche un message que le systéme ne peut pas démarer il a besoinde DLL pour le noyau.
si vous pouvier m'aider je vous enpriis.

j'ai windows xp.