Excel change tout seul le format de cellule [Résolu/Fermé]

Messages postés
189
Date d'inscription
vendredi 25 avril 2008
Statut
Membre
Dernière intervention
8 mai 2012
- - Dernière réponse : zorroestarrivé
Messages postés
1853
Date d'inscription
mercredi 2 juillet 2008
Statut
Membre
Dernière intervention
27 juin 2015
- 5 nov. 2008 à 17:01
Bonjour à tous,

J'adore Excel 2007 et ses fonctionnalités, mais il y a une chose que je ne comprends pas:

Je lui dis que toute la colonne A est au format "Numéro de téléphone".
Pourtant lorsque je 'copie' depuis Word un numéro de téléphone, et le 'colle' dans une cellule de la colonne A, Excel change automatiquement le format de cellule au format "Standard".

Je me retrouve donc avec un numéro de téléphone sans le "0", et je dois à chaque fois changer individuellement le format de cellule.

Savez-vous comment faire pour éviter ce problème?

Merci d'avance pour votre participation,

Jeylo.
Afficher la suite 

6 réponses

Meilleure réponse
Messages postés
1853
Date d'inscription
mercredi 2 juillet 2008
Statut
Membre
Dernière intervention
27 juin 2015
468
1
Merci
Salut,

Essaie avec un collage spécial (Edition...collage spécial) plusieurs options sont proposées alors et tu devrais t'en sortir.

A+

Dire « Merci » 1

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 59201 internautes nous ont dit merci ce mois-ci

Messages postés
189
Date d'inscription
vendredi 25 avril 2008
Statut
Membre
Dernière intervention
8 mai 2012
25
0
Merci
Bonjour ALGERIEN,

Déclarer la colonne au format "Texte" n'y change rien, Excel change quand même le format de la cellule au collage et enlève le '0'.

Bonjour zorroestarrivé,

Le collage spécial fonctionne, le format de cellule est conservé, mais pas la police de caractères.
Du coup je suis obligé de rechanger la police à chaque collage...

L'idéal serait un "copier-coller" sans rien changer! Rien de plus classique!
C'est énervant d'être obligé de changer à chaque fois toutes les cellules.. Excel de *x!?@*

Quelqu'un aurait-il LA solution ?

Merci d'avance pour votre participation.
zorroestarrivé
Messages postés
1853
Date d'inscription
mercredi 2 juillet 2008
Statut
Membre
Dernière intervention
27 juin 2015
468 -
Merci pour ta réponse Jeylo,

Quand je te conseillais ceci:
"avec un collage spécial (Edition...collage spécial) plusieurs options sont proposées"
j'imagine que tu as essayé toutes les options:
HTML
Texte
Texte unicode

Je te dis cela car de mon côté, j'ai fait l'essai avec "texte" et la police n'est pas modifiée et le format non plus.
Messages postés
189
Date d'inscription
vendredi 25 avril 2008
Statut
Membre
Dernière intervention
8 mai 2012
25
0
Merci
Tu as raison, au temps pour moi..!

Merci pour l'astuce du collage spécial, je n'avais pas l'habitude de m'en servir.

Mais il n'empêche que c'est plus agréable de faire un simple "CTRL+V" quand on veut travailler vite, plutôt que de faire les 4 ou 5 clics pour utiliser le collage spécial.

N'y aurait-il pas une option dans Excel qui interdit le changement automatique du format de cellule lors d'un collage simple ??

Ça fait un moment que je cherche, mais sans succès..

Merci,
Jeylo.
zorroestarrivé
Messages postés
1853
Date d'inscription
mercredi 2 juillet 2008
Statut
Membre
Dernière intervention
27 juin 2015
468 -
Jeylo,

L'essentiel est que cela marche par un collage spécial.

Je ne pense pas que tu puisses faire + simple, tu passes d'un format WORD à un format EXCEL qui font certes partie d'Office mais qui sont des utilitaires distincts.

Peut-être qu'Algerien aura une solution alternative...

A+
0
Merci
declmare les cellules en format "TEXTE" ensuite ajout le zero "0" a chauqe champ.
je vien de faire le teste
Messages postés
189
Date d'inscription
vendredi 25 avril 2008
Statut
Membre
Dernière intervention
8 mai 2012
25
0
Merci
Merci de votre aide les gars.

Problème résolu.
zorroestarrivé
Messages postés
1853
Date d'inscription
mercredi 2 juillet 2008
Statut
Membre
Dernière intervention
27 juin 2015
468 -
De rien et à bientôt peut être.

Bye
-1
Merci
Bonjour;
comme par defaut les colone sur excel sont déclaré comme champ numérique et puisque 0 ne change rien a gauche de chiffre; vous n'avez qu' a déclarer le format "text"
salam