Menu

Calcul heures supplementaires sur excel [Résolu/Fermé]

- - Dernière réponse : Raymond PENTIER
Messages postés
49325
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
14 juillet 2019
- 27 janv. 2011 à 18:26
Bonjour,


J ai besoin de votre aide de toute urgence

Je dois construire (de toute urgence aussi) un tableau contabilisant des heures supplementaires

Ca se presente comme ca:

B1 on a heure d entree :03:00
B2 on a heure de sortie :10:00

En gros toute heure comprise entre 22:00 et 06:00 seront comptés en heures supp
J'ai besoin de calculer d'abord combien il y a d heures sup, ca parait simple mais pourtant je bloque.

Merci merci merci d'avance pour votre aide


PS: mon excel est en anglais !
Afficher la suite 

8 réponses

Meilleure réponse
Messages postés
49325
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
14 juillet 2019
10242
9
Merci
Pour t'aider : http://cjoint.com/?knfHQLjtDR

Dire « Merci » 9

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 53708 internautes nous ont dit merci ce mois-ci

8
Merci
merci beaucoup

derniere question:

mes heures supp seront calculer comme cela:
les 2 premieres heures supp seront calculer a 125%
et des lors que j'effectue plus de deux heures supp les heures au dessus de ces 2h seront calculés a 150%

donc par exemple si j'effectue 5 h supp j aurai 2h a 125% et 3h a 150%

de plus les heures effectues apres 20h seront par ex a 175%

quelles sont alors les differentes formules pour calculer tous cela en ayant une colonne pour les h a 125%, une pour celles a 150 et une pour 175

j espere etre assez claire car moi meme je m embrouille un peu

merci merci merci
3
Merci
Merci beaucoup, ca bien aidé

Seulement j ai un soucis lorsque j'ai en B1 00:00 et B2 00:00 (jour de repos), mon resultat est de 06:00,
et je ne peux pas suprimer ces jours du tableau

Est ce que tu peux egalement m'aider la dessus,
j'ai essayé avec des IF imbriqués et des AND mais je n'y arrive pas (pas très douée)

Merci encore d'avance
1
Merci
Bonjour Lyly,

Si je vous envoie un tableau de mes heures sup, pouvez me faire un tableau avec le total de mes heures supplémentaires, avec les heures à 25% et les horaires à 50%. L'heures hebdomadaire est 37h50, sachant que 25% les 8 premières heures (de la 36ème à la 43ème heures) et 50% au-delà de la 43ème heures.

Je vous serais très reconnaissant.
Merci.

P.S : je dois l'envoyer à mes services le 14 Décembre 2010
Messages postés
49325
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
14 juillet 2019
10242
0
Merci
En B5 (dans mon exemple) remplace =SI(B1<K2;K2-B1;0) par =SI(B1=B2;0;SI(B1<K2;K2-B1;0))
Messages postés
49325
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
14 juillet 2019
10242
0
Merci
Salut.

Ce sont deux opérations distinctes, exprimées dans le fichier http://cjoint.com/?ksglkva5Im

Pour les heures sup hebdomadaires, il faut :
* rappeler l'horaire légal (35 en principe) en cellule J9
* inscrire l'horaire effectué dans la semaine (par exemple 38) en cellule J11
* calculer le dépassement éventuel en cellule J13 avec la formule =SI(J11-J9>0;J11-J9;0)
* déterminer le nombre d'HS à 125% éventuelles en cellule M13 avec la formule =SI(J13>2;2;J13)
* idem pour les HS à 150% en N13 avec =SI(J13-2>0;J13-2;0)

Pour les heures "de nuit", il faut :
* rappeler à quelle heure (20) on commence à les compter, en cellule K4
* déterminer combien d'heures "de nuit" ont été faites ce jour-là, en cellule K5, formule =SI(B2>K4;B2-K4;0)

Bon travail.
Bonsoir,
Je ne sais pas si cette boite et encore valide, mais j'aimerais récupérer le tableau que vous aviez mis en lien. il ne passe plus; je me vois confronter au même problème de calcul d'heure. Une semaine normale devrait faire 25 heures, mais je me retrouve plus souvent à 50 heures hebdo... les heures sups. non payées sont récupérables. J'aimerai avoir un tableau permettant aussi de faire état des récup en jours. mail pour contact : sojko@hotmail.fr
Raymond PENTIER
Messages postés
49325
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
14 juillet 2019
10242 -
Effectivement, les liens ne restent stockés que 21 jours chez Cjoint.com

Alors, 2 ans après !!!

Et dans l'intervalle, mon ordinateur m'a laissé tomber, et je n'ai plus les fichier de 2008 ...

Espérons que sophsoph pourra re dépanner !
Bonjoursi quelqu'un a encore ce fichier, il m'intéresse également. Actuellement je calcule les heures sup/heures primes pour +/-30 éducateurs.. donc ça prend pas mal de temps et bientôt ils seront plus... si quelqu'un peut m'aider! merci d'avance
Messages postés
49325
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
14 juillet 2019
10242
0
Merci
Ce n'est pas un problème d'informatique, mais une réglementation du Droit du Travail.

Prière consulter l'Inspecteur du Travail, ou interroger la rubrique "Droit-Finances" (parmi les onglets tout en haut de l'écran).
-1
Merci
Étapes de réalisation
1. Les heures supplémentaires se comptent par semaine et non par mois. Chaque semaine qui a plus de 35 heures a donc des heures supplémentaires. Définissez le nombre d'heures supplémentaires par semaine et totalisez les pour le mois entier.
2. Définissez votre taux horaire auquel vous êtes payé. Si vous êtes mensualisé, relevez sur votre bulletin de salaire le nombre d'heures en face de la mention salaire mensualisé. En général, ce total est 151,67 heures.

Le montant en euros qui est en face du nombre 151,67 correspond à votre salaire brut. pour avoir le taux horaire brut, il faut donc diviser votre salaire brut par 151,67. Vous obtenez un montant minimum de 8,71 euros (montant actuel du SMIC).
3. Pour définir le taux horaire de vos heures supplémentaires (à 25%) , vous faites votre montant m + (m x 0,25).Si l'on prend l'exemple de 8,71, cela fait 8,71+ (8,71 x 025) soit 10,88.

Multiplier le résultat obtenu par le nombre d'heures supplémentaires travaillées. Le montant final est ce que vous devrez toucher en plus sur votre salaire.
bonjour,
j'ai besoin de comprendre par rapport aux heures supplémentaires par semaine.
En effet, j'ai un salarié qui est mensuel de 169 h. ( il perçoit 151,67 à 9 € et 17h33 à 25%)
sur le contrat de travail il est indiqué : au-delà de 169 h les 8 premières heures à 25% et 50 % pour les heures supplémentaires)
il est employé d'immeuble cc3144, il est payé à l'heure, il travaille le jour et fait des perm. la nuit 12H.
Alors comment calculer ses heures sup. sur le mois de décembre 2010 il a fait 192h, alors 186-169h= 17h dont 6h férié,
mais si on décompose par semaine y-a-t'il une différence ?
(il travaille du lundi au dimanche)

1er semaine : le mois commence un mercredi jusqu'à dimanche 30 H
(la semaine de 7 jours est de 39h, là il y a 5 jours de travail, comment calculer le nombre d'heures normales et supplémentaires ?
2e semaine : 42h-39h=3H à 25%
3e semaine : 46h-39h=6h à 25%
4e semaine : 32h et+ 6h férié noël
5e semaine lundi au vendredi soit 5jours : 30 h (de même comment calculer les heures supplémentaires ?)
si c'est par semaine quand elle passe à 50% ?
merci pour ta réponse,
c'est pas 192 h mais 186 h par mois.