Compter des cellules non vides malgré formule [Fermé]

- - Dernière réponse :  Strellio - 4 oct. 2008 à 15:58
Bonjour,

J'ai une série de cellules qui peuvent soit
- être remplies automatiquement à partir d'une autre feuille,
- être remplies grâce à une liste
- rester vides.

Je voudrais compter les cellules non vides (possibilités 1 et 2), mais la formule NBVAL me renvoie le nombre total de cellules, vides ou pleines) et si je teste avec ESTTEXTE, j'ai toujours la valeur VRAI.

Y aurait-il une solution ?

Merci !
Afficher la suite 

4 réponses

Meilleure réponse
Messages postés
22853
Date d'inscription
mardi 11 septembre 2007
Statut
Contributeur
Dernière intervention
24 août 2019
5600
5
Merci
Bonjour,

Quand tu dis vide il y a une formule dedans je pense, donc elle n'est pas vide...
Essaie avec :
=SOMMEPROD((NBCAR(A1:A4)>0)*1)
qui te comptera les cellules avec texte ou nombre

eric

Dire « Merci » 5

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 59066 internautes nous ont dit merci ce mois-ci

Messages postés
15906
Date d'inscription
lundi 12 septembre 2005
Statut
Contributeur
Dernière intervention
24 août 2019
2781
1
Merci
Bonjour

colonne testée C1:C13 (nota: sommeprod n'admet pas une colonne entière comme par exemple c:c)
=SOMMEPROD(NON(ESTVIDE(C1:C13))*1)
0
Merci
Je viens de tester la réponse d'eriiic et ça marche ! Je vais essayer aussi celle de Michel M... et c'est beaucoup plus simple que les aménagements que j'avais tentés.

Merci de votre aide et de votre réactivité !
0
Merci
Pour la formule de Michel, elle me renvoie le nombre de cellules qui n'ont pas été complétée grâce à l'option 1, mais ne compte pas celle remplies par l'option 2. Je la garde quand même sous le coude.

Encore merci à tous deux.