Conditions multiples sous Excel [Résolu/Fermé]

- - Dernière réponse :  Cha - 28 févr. 2019 à 12:36
Bonjour,

Je rencontre un problème sur Excel..
Je voudrais mettre dans une cellule des conditions multiples et je n'y arrive pas pour une donnée...

Voici mon cas:

3 cas de figure - Si I4 est plus petit que 6 alors L4 doit être 0
- Si I4 est plus grand que 15 alors L4 doit être 30
- Si I4 est compris entre 6 et 15 alros L4 doit être 15

La formule que j'ai noté est: =SI(I4<6;0;SI(I4=6;15;SI(I4>9;30;"")))

En gros je suis bloqué sur la 3ème condition...

Il y a bien la solution de faire une suite de SI(I4=6;15;SI(I4=7;15;SI(I4=8;15;SI...
Mais je préférerais une solution plus "clean"

Merci d'avance à vous
Afficher la suite 

3 réponses

Meilleure réponse
Messages postés
16951
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
13 octobre 2019
3628
10
Merci
Salut,

Regarde cette formule
si I4 est < ou = à 6 affiche 0
si I4 est <ou = à 15 affiche 15
et au dessus de 15 affiche 30

=SI(I4<=6;0;SI(I4<=15;15;SI(I4>15;30)))

A+

Dire « Merci » 10

Heureux de vous avoir aidé ! Vous nous appréciez ? Donnez votre avis sur nous ! Evaluez CommentCaMarche

CCM 62597 internautes nous ont dit merci ce mois-ci

au top merci
Merci!!! Juste quand j'allais abandonner!
Messages postés
1
Date d'inscription
lundi 19 novembre 2012
Statut
Membre
Dernière intervention
19 novembre 2012
4
4
Merci
salut,

Tu peux aussi te servir de la formule "ET"

La formule que j'ai noté est:
=SI(I4<6;0;SI(I4<6;15;SI(I4<6;30;"")))


Peux être remplacée par:
=si(et(I4<6;I4<6;I4<6);VRAI;FAUX)
0
Merci
Merci Mike-31

Tout à fait la solution que je cherchais.
Merci aussi !

Et oui ! :)