Excel Formule SI avec du format texte [Résolu/Fermé]

-
Bonjour,
J'ai crée un fichier excel et j'aimerai que des données se remplissent automatiquement en fonction de ce qui a été inscrit précédemment. Pour cela j'ai pensé à la formule logique SI mais je n'arrive pas à l'appliquer à des cellules contenant du texte.
Formule du genre =SI(A1=congé;"1")

Pour mieux vous expliquer voici mon fichier et ma formule à l'endroit ou se situe actuellement le NOM?:
http://www.cijoint.fr/cjlink.php?file=cj200808%2FcijEDVLnYh.xls

Merci pour votre aide.
Afficher la suite 

3 réponses

Meilleure réponse
approuvée par Jean-François Pillou le 14 déc. 2018
Messages postés
4984
Date d'inscription
samedi 8 mars 2008
Statut
Membre
Dernière intervention
31 octobre 2019
905
21
Merci
en fait il faut mettre :
=SI(A1="congé";1;0) 

avec des " " autours des mots et non autours des valeurs numériques. Pour utiliser SI : il faut mettre le test : A1="Congé" puis la valeur a mettre si le test est vrai : donc 1 et aussi la valeur a mettre si le test est faux : 0.

Dire « Merci » 21

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 69516 internautes nous ont dit merci ce mois-ci

MERCIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIII

C'est trop génial !
Et tellement réactif.

Je te remercie mille fois (et je m'abstiendrai de dire que j'ai passé ma journée dessus à m'arracher les cheveux ! ...)
le hollandais volant
Messages postés
4984
Date d'inscription
samedi 8 mars 2008
Statut
Membre
Dernière intervention
31 octobre 2019
905 -
mais derien!
merci beaucoup de ton aide

nickel
Enfin 2 très bons éclaircissements pour l'utilisation de la fonction "SI" appliquée aux textes.

Grand merci à " le hollandais " et à " gbinforme "


MM91
Messages postés
15079
Date d'inscription
lundi 18 octobre 2004
Statut
Contributeur
Dernière intervention
23 juin 2018
3714
6
Merci
bonjour

si(cellule "commençant" par 08h00 , alors "ok" , sinon "pb")

=SI(GAUCHE(A1;5)="08h00";"ok"; "pb")

si(cellule "terminant" par 18h00 , alors "ok" , sinon "pb")
=SI(DROITE(A1;5)="18h00";"ok"; "pb")


Toujours zen
Messages postés
88
Date d'inscription
vendredi 16 janvier 2004
Statut
Membre
Dernière intervention
22 février 2017
1
0
Merci
Bonsoir,

Et comment faire s'il vous plait dans mon cas :

J'ai, dans une cellule A1, une formule qui renvoie du texte
=SI(B25>SOMME(Calculs!$Y$3:$Y$96);"";"  "&RECHERCHE(B25;Calculs!$Z$3:$Z$96;Calculs!$R$3:$R$97))

-> "TOTAL BRUT" (par exemple)

Mais quand je fais un test avec la valeur de cette cellule, cela me renvoit "FAUX" alors que je devrais avoir "VRAI"
SI(A1="TOTAL BRUT";"VRAI";"FAUX")
Raymond PENTIER
Messages postés
50199
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
31 octobre 2019
11049 > Scoubi7
Messages postés
88
Date d'inscription
vendredi 16 janvier 2004
Statut
Membre
Dernière intervention
22 février 2017
-
Pour que ta formule fonctionne, il te faudrait :
soit remplacer "TOTAL BRUT" par " TOTAL BRUT"
Soit supprimer le " "& devant RECHERCHE... dans la formule =SI(B25>SOMME(Calculs!$Y$3:$Y$96);"";" "&RECHERCHE(B25;Calculs!$Z$3:$Z$96;Calculs!$R$3:$R$97)) ...
Scoubi7
Messages postés
88
Date d'inscription
vendredi 16 janvier 2004
Statut
Membre
Dernière intervention
22 février 2017
1 > Raymond PENTIER
Messages postés
50199
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
31 octobre 2019
-
Oui autant pour moi je l'ai oublié sur le fichier exemple, mais pas sur le fichier original sur lequel étrangement ça ne marche pas...

Par contre, je viens de voir que sur le fichier original je suis en "mode compatibilité" et pas sur l'autre... cela viendrait-il de ça ?
Raymond PENTIER
Messages postés
50199
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
31 octobre 2019
11049 > Scoubi7
Messages postés
88
Date d'inscription
vendredi 16 janvier 2004
Statut
Membre
Dernière intervention
22 février 2017
-
Non, ce n'est pas lié.
Envoie un exemple sans erreur, pour qu'on puisse trouver la cause de ce résultat.
Scoubi7
Messages postés
88
Date d'inscription
vendredi 16 janvier 2004
Statut
Membre
Dernière intervention
22 février 2017
1 > Scoubi7
Messages postés
88
Date d'inscription
vendredi 16 janvier 2004
Statut
Membre
Dernière intervention
22 février 2017
-
Merci ça m'a mis sur la voie, j'ai mis 2 espaces et pas 1... le boulet !
S'il vous plaît aidez moi sur cette formule ci
Si Lieu Agence = "Tunis" alors Affectation Voiture = "NON"
Si Lieu Agence# "Tunis" alors Affectation Voiture="OUI"
On cherche la valeur du Affectation Voiture
Et merciiiii