[php] probleme pour envoyer un mail [Résolu/Fermé]

Signaler
Messages postés
528
Date d'inscription
samedi 10 février 2007
Statut
Membre
Dernière intervention
9 août 2017
-
Messages postés
528
Date d'inscription
samedi 10 février 2007
Statut
Membre
Dernière intervention
9 août 2017
-
Bonjour,
svp j'ai un site que j'heberge gratuitement. j'ai une page ou je dois envoyer un mail.
j'ai l'impresssion que ça se passe correcte mais je reçois jamis le mail dans ma boite.
une partie du code: mail("brudao@yahoo.fr",$_POST['objet'],$_POST['message']).
$_POST['objet']: c'est un champ de mon formulaire que je poste
$_POST['objet']: //

2 réponses

Messages postés
55
Date d'inscription
samedi 31 mai 2008
Statut
Membre
Dernière intervention
22 août 2008
11
Va voir du côté des indésirables.
Messages postés
528
Date d'inscription
samedi 10 février 2007
Statut
Membre
Dernière intervention
9 août 2017
13
d'abord on salut quand on s'adresse a quelq'un, ensuite si tu n'as pas mieux casse toi
Messages postés
899
Date d'inscription
dimanche 25 mai 2008
Statut
Membre
Dernière intervention
30 juillet 2018
168 >
Messages postés
528
Date d'inscription
samedi 10 février 2007
Statut
Membre
Dernière intervention
9 août 2017

Quand il disait indésirables, il parlait des mails indésirables...

Car la fonction mail envoie des mails de manière 'sale' et est très largement utilisée pour envoyer du SPAM, donc les mails qu'elle envoie sont souvent classés comme tels...

>_<'
Messages postés
242
Date d'inscription
mercredi 31 octobre 2007
Statut
Membre
Dernière intervention
23 juin 2013
78
Bonjour brudao,
Tu as tester comme ceci ?:
$destinataire = "email du destinataire";
$objet="$_POST['objet']";
$message= $_POST['message'];
$from="From: ton email\r\n";
mail($destinataire,$objet,$message,$from);
Et comme l'a signalé Chris-vip, tu devrais regarder que le message ne tombe pas dans les courriers indésirables. C'est le cas dans 90 % des cas alors... ;)
Voila,
J'espère que ça va marcher.
Maad
Messages postés
528
Date d'inscription
samedi 10 février 2007
Statut
Membre
Dernière intervention
9 août 2017
13
merci pour ta reponse, je teste et je te fai signe
Messages postés
528
Date d'inscription
samedi 10 février 2007
Statut
Membre
Dernière intervention
9 août 2017
13 >
Messages postés
528
Date d'inscription
samedi 10 février 2007
Statut
Membre
Dernière intervention
9 août 2017

resalut, tout d'abord mes excuses à Chris-vip je ne t'avais pas compris! j'ai toujours le meme
problème, j'ai tout éssayé mais ça ne marche toujours pas. je regarde du coté des courriers indésirables
mais toujours rien. je ne sais plus quoi faire. pourtant dans mon code je teste voir si le message part et ça
se passe correctement. help me
Messages postés
899
Date d'inscription
dimanche 25 mai 2008
Statut
Membre
Dernière intervention
30 juillet 2018
168 >
Messages postés
528
Date d'inscription
samedi 10 février 2007
Statut
Membre
Dernière intervention
9 août 2017

Certains hébergeurs bloquent cette fonction pour éviter les abus...

Car tu peux spammer sans problème avec elle...
Messages postés
528
Date d'inscription
samedi 10 février 2007
Statut
Membre
Dernière intervention
9 août 2017
13 >
Messages postés
899
Date d'inscription
dimanche 25 mai 2008
Statut
Membre
Dernière intervention
30 juillet 2018

c'est surement ça. parceque mon code est correcte. j'heberge mon site gratuitement sur ifrance.
Messages postés
528
Date d'inscription
samedi 10 février 2007
Statut
Membre
Dernière intervention
9 août 2017
13 >
Messages postés
528
Date d'inscription
samedi 10 février 2007
Statut
Membre
Dernière intervention
9 août 2017

zzer tu as raison j'ai lu dans beaucoup de forum, et d'autres personne ont le meme probleme.
en fait la fonction mail() ne marche pas avec ifrance en mode d'hebergement gratuit. il faut passer
a la version payante pour que ça marche. merci