Menu

Wamp =>mail [Résolu/Fermé]

darkchristophetd 1102 Messages postés mardi 26 février 2008Date d'inscriptionContributeurStatut 14 novembre 2010 Dernière intervention - 27 juin 2008 à 20:28 - Dernière réponse :  isNotHere
- 8 janv. 2016 à 15:58
Bonjour,
Est-ce possible d'utiliser la fonction mail de php en local avec wamp ?
merci
Afficher la suite 

36 réponses

Meilleure réponse
26
Merci
SMTP = localhost est une erreur
à la place de localhost, il faut mettre le serveur SMTP de ton fournisseur d'accès, par exemple pour wanadoo :
SMTP = smtp.wanadoo.fr

une liste ici :
http://www.commentcamarche.net/faq/sujet 893 adresses des serveurs pop et smtp des principaux fai

Merci toto 26

Avec quelques mots c'est encore mieux Ajouter un commentaire

CCM a aidé 27000 internautes ce mois-ci

Bravo pour l'info, ça marche super maintenant. J'ai fait un reboot de mon PC pour que les changements dans le fichier .init soient pris en compte.
isNotHere > toto - 8 janv. 2016 à 15:58
mdr
djflexlive 557 Messages postés mercredi 26 mars 2008Date d'inscription 23 avril 2015 Dernière intervention - 11 nov. 2011 à 01:08
Pour info, pas besoin de redémarrer le pc à chaque modif du php.ini mais juste du serveur wamp (click gauche sur l'icone de wamp, redémarrer les services)
fenixdeamiens 28 Messages postés jeudi 3 janvier 2008Date d'inscription 20 octobre 2013 Dernière intervention - 11 nov. 2011 à 03:39
mettre smtp.wanadoo.fr sa marche pas mais pas du tout alors que si ta acheté un domaine et que tu claque le méme nom que ton domaine sa fonctionnera orange refuse se type de connection
/!\ Note pour le FAI SFR (à titre d'exemple) :
En plus de configurer les php.ini avec smtp.sfr.fr
Il vous faudra aller désactiver le filtrage pour utiliser un serveur email SMTP autre que le SMTP SFR ( en vous connectant à l'adresse de votre NeufBox 192.168.1.1 > Réseau > Filtrage ).
16
Merci
Envoie de mail en local via wamp

-clique gauche sur l'icône de wamp
-php----->php ini
le fichier ini s'ouvre dans le bloc-note
modifier :

[mail function]
; For Win32 only.
----->SMTP = smtp.orange.fr<--------
smtp_port = 25

; For Win32 only.
-----> sendmail_from = ton adresse mail<------

et voila
bye
fenixdeamiens 28 Messages postés jeudi 3 janvier 2008Date d'inscription 20 octobre 2013 Dernière intervention - 11 nov. 2011 à 03:37
Mettre wanadoo sa marche pas mais pas du tout

alors que si ta acheté un domaine et que tu mets le même nom que ton domaine sa fonctionnera orange refuse se type de connections
6
Merci
et ne pas oublier de metre son adresse email dans dommain name...
2
Merci
Salut à tous ce post est vieux mais j'espere que vous pourrai me répondre ^^

J'ai tout modifier comme vous le dites plus haut je sauvegarde mon php.ini tout est nickel

Mais quand je test mon formulaire le message d'erreur suivant continue d'apparaitre


Warning: mail() [function.mail]: Failed to connect to mailserver at "localhost" port 25, verify your "SMTP" and "smtp_port" setting in php.ini or use ini_set() in C:\wamp\www\site\italien\cible_formulaire.php on line 114
L'envoi du mail a échoué, veuillez réessayer SVP.

Je ne comprend pas : normalement il devrai pas me dire que la connection à localhost échoue mais plutôt que la connection au smtp demandé échoue non ?
Rom190686 445 Messages postés mardi 29 avril 2008Date d'inscription 20 novembre 2015 Dernière intervention - 14 avril 2010 à 18:32
Peux-tu nous montrer ton code stp, tu dois avoir une erreur dans ton code php
Rom190686 445 Messages postés mardi 29 avril 2008Date d'inscription 20 novembre 2015 Dernière intervention - 16 janv. 2010 à 23:35
1
Merci
Bonjour,
Grâce à vos post, j'utilise la fonction mail avec wamp.
Cependant juste pour enrichir ma curiosité , je me demande comment est-ce possible d'utiliser le smtp d'un FAI gratuitement pour envoyer des mails.
Moi je suis abonné orange adsl. J'ai donc mis le smtp de orange.
Est-ce totalement gratuit?
Est-ce que si j'utilise le smtp de sfr (par exemple) ça fonctionne aussi?
Merci d'avance ....
1
Merci
bonjour a tous
j'ai également un problème pour l'envoie d'un mail via wamp pourtant j'ai bien mis
[mail function]
; For Win32 only.
; http://php.net/smtp
SMTP =smtp.live.com
; http://php.net/smtp-port
smtp_port = 25

; For Win32 only.
; http://php.net/sendmail-from
sendmail_from =...........@live.fr
quelqu'un pourrai t-il m'aider ???
darkchristophetd 1102 Messages postés mardi 26 février 2008Date d'inscriptionContributeurStatut 14 novembre 2010 Dernière intervention - 28 juin 2008 à 11:38
0
Merci
ok c'est ce que je pensais aussi
Utilisateur anonyme - 28 juin 2008 à 11:41
Salut!!
Si, tu peux envoyer des mails en local en paramétrant le fichier php.ini de wamp.
^^
tokaido6 85 Messages postés mardi 20 mai 2008Date d'inscription 15 juillet 2012 Dernière intervention > Utilisateur anonyme - 28 juin 2008 à 11:43
Salut,
oui là aussi, je pense que c'est trop compliqué
Utilisateur anonyme > tokaido6 85 Messages postés mardi 20 mai 2008Date d'inscription 15 juillet 2012 Dernière intervention - 28 juin 2008 à 11:54
Dans la barre des taches a droite, fait un clic gauche sur l'icone de wamp.
Puis va sur PHP/php.ini puis change ceci:

[mail function]
; For Win32 only.
SMTP = localhost
smtp_port = 25

; For Win32 only.
;sendmail_from = me@example.com

Par ceci:
[mail function]
; For Win32 only.
SMTP = localhost
smtp_port = 25

; For Win32 only.
sendmail_from = tonmail@tondomaine.xxx

Noublie pas d'enlever le point virgule a gauche de sendmail.

Enregistre et ferme le fichier et rédemarre wamp.
StrasGus > Utilisateur anonyme - 6 janv. 2009 à 15:14
Perso ça ne marche pas !

J'ai voulu édité le .ini et il est déja bon de plus je remarque le petit "w32"...

Je suis sous windows en 64 bits, est ce le problème ?

Si oui, comment faire ???
Rom190686 445 Messages postés mardi 29 avril 2008Date d'inscription 20 novembre 2015 Dernière intervention - 25 févr. 2010 à 20:03
0
Merci
Le port smtp de live n'est pas le port 25 par défaut.
Essaie le port 587.
Sinon, tu peux utiliser le serveur smtp de orange qui fonctionne très bien pour wamp. (c'est celui que j'utilise)
smtp.orange.fr
smt_port = 25
...@orange.fr
Bonne chance
0
Merci
merci de ton aide Rom190686 mais sa ne marche toujours pas même si j'utilise le port 587 pour live. et avec easyphp tu ne connaiterai pas un smtp qui marche bien??
Rom190686 445 Messages postés mardi 29 avril 2008Date d'inscription 20 novembre 2015 Dernière intervention - 5 mars 2010 à 21:20
0
Merci
Désolé, je ne peux rien faire pour toi
Holdem Chris - 25 août 2010 à 11:55
0
Merci
Bonjour,

Mon formulaire m'indique que le mail est envoyé, je suppose donc qu'il fonctionne.
Cependant, je ne reçois pas le mail !
------------------------------------------------------------
PHP.INI :

[mail function]
; For Win32 only.
SMTP = smtp.orange.fr
smtp_port = 25

; For Win32 only.
sendmail_from = christophe-frignet@orange.fr

--------------------------------------------------------------

FORMULAIRE :

<?php
/*
********************************************************************************************
CONFIGURATION
********************************************************************************************
*/
// destinataire est votre adresse mail. Pour envoyer à plusieurs à la fois, séparez-les par une virgule
$destinataire = 'christophe.frignet@hotmail.fr';

// copie ? (envoie une copie au visiteur)
$copie = 'oui'; // 'oui' ou 'non'



// Messages de confirmation du mail
$message_envoye = file_get_contents('messageok.html');
$message_non_envoye = "L'envoi du mail a échoué, veuillez réessayer SVP.";

// Messages d'erreur du formulaire
$message_erreur_formulaire = "Vous devez d'abord <a href=\"contact.html\">envoyer le formulaire</a>.";
$message_formulaire_invalide = "Vérifiez que tous les champs soient bien remplis et que l'email soit sans erreur.";

/*
********************************************************************************************
FIN DE LA CONFIGURATION
********************************************************************************************
*/

// on teste si le formulaire a été soumis
if (!isset($_POST['envoi']))
{
// formulaire non envoyé
echo '<p>'.$message_erreur_formulaire.'</p>'."\n";
}
else
{
/*
* cette fonction sert à nettoyer et enregistrer un texte
*/
function Rec($text)
{
$text = trim($text); // delete white spaces after & before text
if (1 === get_magic_quotes_gpc())
{
$stripslashes = create_function('$txt', 'return stripslashes($txt);');
}
else
{
$stripslashes = create_function('$txt', 'return $txt;');
}

// magic quotes ?
$text = $stripslashes($text);
$text = htmlspecialchars($text, ENT_QUOTES); // converts to string with " and ' as well
$text = nl2br($text);
return $text;
};

/*
* Cette fonction sert à vérifier la syntaxe d'un email
*/
function IsEmail($email)
{
$pattern = "^([a-z0-9_]|\\-|\\.)+@(([a-z0-9_]|\\-)+\\.)+[a-z]{2,7}$";
return (eregi($pattern,$email)) ? true : false;
};

// formulaire envoyé, on récupère tous les champs.
$nom = (isset($_POST['nom'])) ? Rec($_POST['nom']) : '';
$email = (isset($_POST['email'])) ? Rec($_POST['email']) : '';
$objet = (isset($_POST['objet'])) ? Rec($_POST['objet']) : '';
$message = (isset($_POST['message'])) ? Rec($_POST['message']) : '';

// On va vérifier les variables et l'email ...
$email = (IsEmail($email)) ? $email : ''; // soit l'email est vide si erroné, soit il vaut l'email entré

if (($nom != '') && ($email != '') && ($objet != '') && ($message != ''))
{
// les 4 variables sont remplies, on génère puis envoie le mail
$headers = 'From: '.$nom.' <'.$email.'>' . "\r\n";

// envoyer une copie au visiteur ?
if ($copie == 'oui')
{
$cible = $destinataire.','.$email;
}
else
{
$cible = $destinataire;
};

// Remplacement de certains caractères spéciaux
$message = str_replace("'","'",$message);
$message = str_replace("’","'",$message);
$message = str_replace(""",'"',$message);
$message = str_replace('<br>','',$message);
$message = str_replace('<br />','',$message);
$message = str_replace("<","<",$message);
$message = str_replace(">",">",$message);
$message = str_replace("&","&",$message);

// Envoi du mail
if (mail($cible, $objet, $message, $headers))
{
echo '<p>'.$message_envoye.'</p>'."\n";
}
else
{
echo '<p>'.$message_non_envoye.'</p>'."\n";
};
}
else
{
// une des 3 variables (ou plus) est vide ...
echo '<p>'.$message_formulaire_invalide.' <a href="contact.html">Retour au formulaire</a></p>'."\n";
};
}; // fin du if (!isset($_POST['envoi']))
?>
0
Merci
bonjours je sais pas si quelqu'un va pourvoir me répondre mais mon serveur me répond authentification requise mais ou dois-je indiquer nom utilisateur et mots de passe pour orange

voici la page d'accès au formulaire
' target='_blank'>http://www.emule-ed2k.html/test.html</code> pour que vous pussiez voir communication tel de ma part possible si une personne veut bien m'aider car c'est galère 


je commence depuis pas longtemps je serais même prés a payer si une entreprise pourrez s'en occuper a ma place pas des mille mais sinon donner moi une adresse internet comme les module de support du web

de manière que je face un formulaire et que je le face envoyer a une adresse précise car la c'est galère merci d'avance de votre aide
fenixdeamiens 28 Messages postés jeudi 3 janvier 2008Date d'inscription 20 octobre 2013 Dernière intervention - 31 mars 2011 à 21:44
j'utilise easy php comme serveur mon site et heberger chez moi contact moi ici (emule-ed2k@emule-ed2k.be) c'est une adresse dinutile comme sa si tu veu je peut te faite des capture des ecrant en gros mon souci c'est l'envoi de mail j'ai un message wwarning de easy php qui m'indique que mon serveur requere une authentification
message

"Warning: mail() [function.mail]: SMTP server response: 550 5.1.0 Authentification requise. Authentication Required. OFR102_402 [402] in C:\Program Files\EasyPHP-5.3.5.0\www\formmail.php on line 12"
fenixdeamiens - 15 avril 2011 à 15:24
bonjours j'ai resolu tout seul mon probleme en fin du compte il me fallais debloquer le port smtp (25) de ma box maintenant tout marche
salut fenixdeamiens
peut tu me dire comment tu a fais pour débloquer le port (25) de ta box s'il te plais ?
fenixdeamiens 28 Messages postés jeudi 3 janvier 2008Date d'inscription 20 octobre 2013 Dernière intervention - 15 nov. 2011 à 18:24
a ben c'est comme n'importe quel que tu ouvre dans ta box aprés n'utilise surtout pas ton fournisseur internet sa marchera pas il sécurise trop a cause du spam si tu veux je peux t'aider mais j'ai besoin de plus d'info sur ta connexion adsl pour tenter de voir pour ta box car chaque box est differente cependant si tu désire me contacté envoi un email emule-ed2@emule-ed2k.fr
fenixdeamiens j avait le meme erreure que vous "authentification required " est ce que vous pouver m'aider et mersi
fenixdeamiens 28 Messages postés jeudi 3 janvier 2008Date d'inscription 20 octobre 2013 Dernière intervention - 31 mars 2011 à 21:56
0
Merci
a ok donc la fonction a modifier php.ini c'est pas pour moi
leromantiqueroma - 15 août 2015 à 05:40
0
Merci
le problème était que sendmail ne s'exécutait pas en tant qu'administrateur, maintenant j'envoie mes messages tranquillement sans problème

- un clic droit sur sendmail.exe
- Propriétés
-Compatibilité
- Modifiez la configuration pour tous les utilisateurs
- Exécuter en tant que Windows XP SP 3
- cocher Exécuté en tant qu'administrateur
-cliquer avec joie sur OK :)

voici mon fichier php.ini
[mail function]
; For Win32 only.
; http://php.net/smtp
SMTP = smtp.gmail.com
; http://php.net/smtp-port
smtp_port = 587
; For Win32 only.
; http://php.net/sendmail-from
sendmail_from = ********@gmail.com
; For Unix only. You may supply arguments as well (default: "sendmail -t -i").
; http://php.net/sendmail-path
sendmail_path = "C:\Wamp\sendmail\sendmail.exe"
et voici le fichier sendmail.ini
; configuration for fake sendmail
; if this file doesn't exist, sendmail.exe will look for the settings in
; the registry, under HKLM\Software\Sendmail
[sendmail]
; you must change mail.mydomain.com to your smtp server,
; or to IIS's "pickup" directory. (generally C:\Inetpub\mailroot\Pickup)
; emails delivered via IIS's pickup directory cause sendmail to
; run quicker, but you won't get error messages back to the calling
; application.
smtp_server=smtp.gmail.com
; smtp port (normally 25)
smtp_port=587
; SMTPS (SSL) support
; auto = use SSL for port 465, otherwise try to use TLS
; ssl = alway use SSL
; tls = always use TLS
; none = never try to use SSL
smtp_ssl=587
; the default domain for this server will be read from the registry
; this will be appended to email addresses when one isn't provided
; if you want to override the value in the registry, uncomment and modify
;default_domain=gmail.com
; log smtp errors to error.log (defaults to same directory as sendmail.exe)
; uncomment to enable logging
error_logfile=error.log
; create debug log as debug.log (defaults to same directory as sendmail.exe)
; uncomment to enable debugging
;debug_logfile=debug.log
; if your smtp server requires authentication, modify the following two lines
auth_username= ***********@gmail.com
auth_password= ***********
; if your smtp server uses pop3 before smtp authentication, modify the
; following three lines. do not enable unless it is required.
pop3_server=
pop3_username=
pop3_password=
; force the sender to always be the following email address
; this will only affect the "MAIL FROM" command, it won't modify
; the "From: " header of the message content
force_sender=*******@gmail.com
; force the sender to always be the following email address
; this will only affect the "RCTP TO" command, it won't modify
; the "To: " header of the message content
force_recipient=
; sendmail will use your hostname and your default_domain in the ehlo/helo
; smtp greeting. you can manually set the ehlo/helo name if required
hostname=
darkchristophetd 1102 Messages postés mardi 26 février 2008Date d'inscriptionContributeurStatut 14 novembre 2010 Dernière intervention - 28 juin 2008 à 11:50
-1
Merci
Moorscop : et on fait comment pour le paramétrer ?
tokaido6 85 Messages postés mardi 20 mai 2008Date d'inscription 15 juillet 2012 Dernière intervention - 28 juin 2008 à 10:12
-2
Merci
Salut,
A mon avis je ne pense pas, puisqu'il te faut être hébergé pour envoyer les mails.
merci beaucoup toto et JMP ca marche nickel avec mon fournisseur sfr et avec mon @ perso:
en local si SMTP = localhost -----> alors c'est une erreur
SMTP = smtp.sfr.fr pour fournisseur sfr
sendmail_from = votre adresse mail perso .
good luck