Recherche dans différente feuille excel [Résolu/Fermé]

Messages postés
19
Date d'inscription
mardi 20 novembre 2007
Statut
Membre
Dernière intervention
11 octobre 2010
- - Dernière réponse : Raymond PENTIER
Messages postés
50047
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
13 octobre 2019
- 5 mai 2008 à 16:25
Bonjour,
je souhaiterais que ma feuille excel recherche des donnés dans dautre feuille du classeur préalablement remplis? ( ex: j'ai remplis un tableau avec un code produit, un nom de produit et un prix de vente et dans un second tableau je souhaite qu'en ne rentrant juste le code produit, l'ordinateur m'affiche le nom du produit et le prix de vente). Comment dois je faire?
Merci d'avance
Afficher la suite 

3 réponses

Meilleure réponse
Messages postés
22965
Date d'inscription
mardi 11 septembre 2007
Statut
Contributeur
Dernière intervention
15 octobre 2019
5704
4
Merci
Bonjour,

peut-être pas besoin de vba dans ce cas, recherchev() devrait suffire.
Sur feuil1 :
  A    B    C
code  nom  prix
123   p1    12
124   p2    15
....   ....    ....

sur feuil2 avec un code produit en A1 :
B1: =RECHERCHEV(Feuil2!$A1;Feuil1!$A$1:$C$8;2;FAUX) te ramène le nom (2ème colonne de la plage)
C1: =RECHERCHEV(Feuil2!$A1;Feuil1!$A$1:$C$8;3;FAUX) te ramène le prix (3ème colonne de la plage)

ces formules peuvent être recopiées vers le bas
eric

Dire « Merci » 4

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 62955 internautes nous ont dit merci ce mois-ci

Messages postés
50047
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
13 octobre 2019
10904
2
Merci
De multiples discussions ont déjà traité le sujet, dans ce forum.
Il faut que tu fasses l'effort de lire l'Aide d'Excel (touche F1) qui explique le mécanisme et donne des exemples des fonctions de RECHERCHE.
Ceci fait, tu pourras mieux profiter des conseils supplémentaires que nous pouvons t'apporter.
Messages postés
8713
Date d'inscription
dimanche 8 avril 2007
Statut
Contributeur
Dernière intervention
27 janvier 2014
1001
1
Merci
Bonjour,
1: créer une connection dans la sub Change de la feuille des codes.
2: Créer un UserForme pour l'affichage des détails.
3: Faire un transfer dans l'Userform et l'afficher.
A+
marjo59
Messages postés
19
Date d'inscription
mardi 20 novembre 2007
Statut
Membre
Dernière intervention
11 octobre 2010
-
??????????????????????????????????????????????????????????????????????????????????????????????????????
Peux tu m'expliquer cela en français?
Merci
lermite222
Messages postés
8713
Date d'inscription
dimanche 8 avril 2007
Statut
Contributeur
Dernière intervention
27 janvier 2014
1001 > marjo59
Messages postés
19
Date d'inscription
mardi 20 novembre 2007
Statut
Membre
Dernière intervention
11 octobre 2010
-
Tu connais quelque chose en VBA ?
apparement non, alors cela va t'être difficile d'arriver à ce que tu veux faire sans commencer par apprendre un peu, voir ton l'aide, et les tuto et code sur les forums.
Te créer ton appli de A à Z ne serrait pas te rendre service, tu n'apprendrais rien.
A+