MAX de RECHERCHEV Excel [Résolu/Fermé]

- - Dernière réponse :  Zeratz - 23 mars 2018 à 16:04
Bonjour,

J'ai un tableau de deux colonnes.
La premiere contient des valeurs dont certaines sont identiques et la deuxieme des chiffres correspondants.
en utilisant RECHERCHEV je trouve le chiffre correspondant a ma valeur de la premiere colonne.
Mon probleme et que je cherche le maximum de ces valeurs:
Si j ai deux fois la valeure "PIERE" dans ma premiere colone et que les chiffres correspondant sont 11 et 15, j aimerai que ma fonction me renvoi le 15.
Malheureusement RECHERCHEV s'arrete des qu'elle a trouvée un element dans la premiere colonne...
Comment trouver le maximum des chifres correspondant, je n'arrive pas a combiner avec une fonction MAX.

Merci d'avance,

Antoine
Afficher la suite 

2 réponses

Meilleure réponse
Messages postés
250
Date d'inscription
samedi 8 mars 2008
Statut
Membre
Dernière intervention
2 août 2012
298
14
Merci
bonjour

soit tes valeurs en A2:B21
inscrit en F1 la valeur à chercher dans la colonne 1
inscrit en F2 la formule : =MAX(SI($F$1=A2:A21;B2:B21;""))
à valider en appuyant sur Ctrl Shift et Enter
car c'est une formule matricielle
et tu aurs le maxi recherché
à plus

Dire « Merci » 14

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 64690 internautes nous ont dit merci ce mois-ci

> LePierre
Messages postés
250
Date d'inscription
samedi 8 mars 2008
Statut
Membre
Dernière intervention
2 août 2012
-
excellent ca marche oui
je connaissais pas les }
merci!!!
> LePierre
Messages postés
250
Date d'inscription
samedi 8 mars 2008
Statut
Membre
Dernière intervention
2 août 2012
-
excellent ca marche oui
je connaissais pas les }
merci!!!
> LePierre
Messages postés
250
Date d'inscription
samedi 8 mars 2008
Statut
Membre
Dernière intervention
2 août 2012
-
excellent ca marche oui
je connaissais pas les }
merci!!!
simple et efficace. Merci
Bravo, nickel !
Messages postés
15549
Date d'inscription
mardi 12 juin 2007
Statut
Contributeur
Dernière intervention
19 octobre 2019
8740
2
Merci
Bonjour,

Avec le rechercheV, tu ne pourras pas, mais il y a d'autres solutions. EN voici deux :

Avec BDMax (qui nécessite une zone de critère) :

=BDMAX($A$1:$B$11;2;$D$1:$D$2)

Avec SOMMEPROD :

=SOMMEPROD(MAX((nom=D2)*(montant)))

Pour ces deux exemples, la base est en A1:B11
Pour le premier exemple, la zone de critère est en D1:D2

Pour le deuxième exemple, j'ai nommé les données de la première colonne "nom" et celles de la seconde colonne "montant".

m@rina
salut marina
c'est parfait...
un peu de mal avec la premiere formule mais la deuxieme marche nikel
tu viens de m eviter 29 colonnes de calcules stupides
merci

antoine