Menu

Probleme Base de Donnée Joomla ... [Résolu/Fermé]

- - Dernière réponse :  Style90 - 21 sept. 2015 à 15:55
Bonjour,
Je suis en train d'installer Joomla , et la j'ai un nouveau problème :

http://i49.servimg.com/u/f49/11/99/59/87/sans_t16.png

j'ai remplie cela (je sis chez free) je met suivant et il me dise sa :

Une erreur s'est produite:

Impossible de se connecter à la base de données. Le connecteur a renvoyé le numéro : Unable to connect to the database:Could not connect to MySQL


Je me suis tromper quelque part ? j'ai oublier quelque chose ? on peux m'aider ?? svp
merci
Afficher la suite 

20/24 réponses

Meilleure réponse
79
Merci
Les zamis,
si vous êtes en local, la solution c'est qu'après avoir inséré localhost, root, il faut laisser le champ mot de passe vide, car par défaut, la base de donnée n'a pas de mot de passe.

c'est tt

Dire « Merci » 79

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 41551 internautes nous ont dit merci ce mois-ci

merci ça march bien
> noir -
moi aussi j'avais le même pb et ça marche avec cette solution
Bonjour
mon problème est vraiment bizard. je vous explique.
a chaque fois mon site fait avec joomla crash .voici l erreur que sa met :Database connection error (2): Could not connect to MySQL.
quand sa arrive je suis a chaque fois obligé de changer les paramètre de connexion a la base de donnée pour rétablir sa mais quelque jours après la même problème revient . je ne sais plus quoi faire.
Merciiiiiiii
-
Oui, il est possible que cela fonctionne, mais ce n'est pas suffisant du tout.
Il ne faut pas oublier que si l'on met un mot de passe, c'est pour se protéger; hors que se passe-t-il si l'on fait ensuite ce même type d'installation à distance, avec un password? Comment résoudrez-vous ce problème?
11
Merci
la solution est simple mette 127.0.0.1 a la place de localhost ca va marché
-
merciiiiiiiiii sami :)
Merci enormement .
j'ai vraiement galeré
salut je suis de retour le site recommence sa série de crash et je sais franchement pas quoi faire.
+ 1 :)
Merci Sami, c'est uniquement en mettant 127.0.0.1 que ca a marché chez moi ^^
11
Merci
Bonjour à tous, je sais que le topic à été posté il y a longtemps mais jai eut du mal à trouvé la solution, mais je l'ai trouvé, pour ceux qui auront ce problème.

voici ce que j'ai mis:

http://pix.toile-libre.org/?img=1248316777.jpg

j'ai fait un petit mix de ce que j'ai trouvé:

type de base de donnée: mysql
nom du serveur: 127.0.0.1
nom d'utilisateur:root
mot de passe: mysql
nom de la base:joomla_db


attention vous devez d'abord créer votre base de données dans phpmyadmin ou mysql au même nom que celui que vous entrez dans l'install de joomla.
pour cela (j'utilise easyPHP 2.0) clique-droit sur l'icône de easyPHP, administration ==> phpmyadmin et créer un base.
si il vous répond que la connexion est impossible, c'est parceque dans la fichier conf de apache, la ligne concernant l'accés au 127.0.0.1 n'est pas actif, pour l'activer, clique droit sur easyphp, configuration, apache et vers le début, chercher la ligne "listen xxx.xxx.xxx.xxx" vers la ligne 50, celle où il y a écrit listen 127.0.0.1:80, enlevez le # devant et c'est bon.

et normalement tout est bon.
je decouvre aussi le monde des serveur et du web, et comme le dit le proverbe de mon site, "c'est en forgeant que l'on devient forgeron" accrochez vous et bon courage à tous

j'espere que je n'ai rien oublié...

@+

Eagle5

winXP pro ultimate 7.1 sp3, easyphp 2.0, joomla 1.5
nForce2 Ultra400 A7N8X, ahtlon 2800+ @1.83GHz, 1Go de ram DDR1 400
Messages postés
17
Date d'inscription
vendredi 25 mars 2011
Statut
Membre
Dernière intervention
21 novembre 2011
53
10
Merci
utilise le navigateur Opera ou Safari et ca va marcher comme il faut

Bonne chance
6
Merci
si si ammi toufik mon mysql marche bel et bien
bonjour pourquoi je suis sur livret A et que je ne peut pas avoir un mot de passe pour pouvoir alle sur mon compte
5
Merci
J'ai eu le même problème à l'installation de Joomla 1.5 Bêta...

Ça s'est résolu après avoir fait ceci:

==> Dans un autre onglet de l'explorateur Internet:
--> http://localhost/phpmyadmin/
--> créer base de données
-> exemple de nom: joomlabeta (reprendre alors ce même nom dans l'installation de Joomla1.5)
-> Interclassement : sélectionner utf8_bin
-> créer

==>revenir dans l'onglet où se trouve l'installation de Joomla 1.5 Bêta:
--> J'ai laissé la plage "Mot de passe" vide
--> Suivant... et pas de problème...

Je ne sais pas si c'est la solution pour d'autres?
merciiiiiiiiiiiiiiiiiiiiiiiiiiiiiiiiiiiiiiiiiiiiiiiiiiiiiiiiiiiiiiiiii c'est bien reponduuuuuu !!!!!!!!!! :)
C facile de relier une base aen local mais pour une base chez ovh? et joomla instalé sur son ftp distant...
2
Merci
erf , quand je clique sur : Accéder et gérer votre base de données MySQL
sur le panneau de free , il me mette sa :

phpMyAdmin - Erreur

#2005 - Unknown MySQL server host 'phpMyAdmin.sql.free.fr' (1)

pourquoi ?
2
Merci
bonjour tout le monde je ne suis qu'en local...et j'ai toujours ce message Impossible de se connecter à la base de données. Le connecteur a renvoyé le numéro : Unable to connect to the database:Could not connect to MySQL
comment faire s'il vous plait ca fait plus dume semaine que je suis entrain d'aprendre qqchose mais je n'ai meme pas pu avancer, j'utilise easyphp et la derniere version de joomla
paar avance merci
myoussef
Messages postés
17
Date d'inscription
vendredi 25 mars 2011
Statut
Membre
Dernière intervention
21 novembre 2011
53 -
Utilise le navigateur Opera ou Safari.
j'ai formaté le disque dur de machine en copiant juste la partie base de donnée de mon projet après avoir refais le système de ma machine je ne paviens plus a voir mon projet par ce que la partie base de donnée a été supprimé. comment faire pour avoir le nom de ma base de donnée
2
Merci
Hello,
Pour moi, le problème s'est résolu du moment où j'ai entré le mot de passe (easyphp 3.0) mysql..
Et voilà, j'espère que ça marchera pour vous
c'est la bonne solution pour moi aussi
uszer : root
pass : mysql
merci beacoup
1
Merci
Je suis désolé mais je vais rester le moins moqueur possible ^^


Mais dans base de donné toi tu mes ton serveur FTP tu trouve pas ça bizarre, non ^^.

Met "sql.free.fr" au lieu de "ftpfree.fr" (et en plus c'est normalement "ftp.free.fr")
1
Merci
oui ca marche j'avais le même brob et c'est résolu
1
Merci
bonjour a tous

j'ai bien lu les conseil que vous avez donne plus haut mais quand je vais sur l'adresse url qui est marquée mon serveur ne trouve pas le site... alors j'ai essayé de creer une base de donnée en passant par le web local avec l'extension mentionnée plus haut, et j'ai toujours le meme problème... pouvez vous m'aidez svp???
Si tu as installé la dernière version d'Easyphp, il y a un mot de passe par défaut qui est mysql. Je résume donc:

userid = root
pwd = mysql
> Profil bloqué -
C'est en effet la solution! Merci
> Profil bloqué -
super ça marche !
> Profil bloqué -
je possède easyphp3.0 t meme avec le mot de passe mysql ça fonctionne pas. c'est toujours le même problème
Faut pas oublier d installer wamp si tu bosses en local. T as tout pour commencer gratos chez toi. y a tout dans wamp server
Messages postés
16
Date d'inscription
jeudi 29 mars 2007
Statut
Membre
Dernière intervention
1 octobre 2009
1
1
Merci
salam aimad,
est ce que tu peut me donner la solution exactement, car je suis vraiment bloqué
merci d'avance
Moi,j'ai ajouté le mot de pass
localhoste
user : root
pass : mysql
1
Merci
Je sais que ce sujet daaate mais voilà une info qui va vous intéresser. La liste des variables de joomla comme les login mot de passe de la db est juste situé dans le fichier configuration.php ! Il suffit de changer la variable approprié pour résoudre son problème d'accès !

En espérant avoir aidé.

Guillaume Hullin
— Futur-Tech Entr.
0
Merci
salut,
quand tu mettra root: NE MET PAS DE MOT DE PASE CAR LE ROOT N'a PAS DE MOT D PSS
0
Merci
dans le champ nom utilisateur tu vas mettre ("Root") et mot de paase laisse le vide nom de basse donnee parexemple "joomla" ca marche et repond moi svp
0
Merci
salut ;
jé crée un dossier joomla_ab dans le dossier www qui se trouve en easyphp apres jé crée une base de donnéé avec le mm nom joomla_ab et puis jé passé en localhost ==> qu'on j'arrive a l'etape base de donné jé saisi les donné avec le mot de passe que jé deja créé avec le compt d'utilisateur ensuite je tape suivant c la, que la page suivante devienne tt blanche et elle se bloque
0
Merci
Salut, je sais que ce topic date vraiment mais je viens de commencer a utiliser joomla et j'ai un probleme, quand je rentre tout ca va mais apres ca m'affiche :
"
Objet non trouvé!

L'URL demandée n'a pas pu être trouvée sur ce serveur. La référence sur la page citée semble être erronée ou perimée. Nous vous prions d'informer l'auteur de cette page de cette erreur.

Si vous pensez qu'il s'agit d'une erreur du serveur, veuillez contacter le webmestre.
Error 404
localhost
02/06/12 22:01:19
Apache/2.2.21 (Win32) PHP/5.3.9
"
Je ne sais vraiment pas comment faire, aidez moi !!! s'il vous plait !!!