Probleme hamachi avec age of empire 2 [Résolu/Fermé]

Signaler
-
 Balt009 -
Bonjour,
Depuis un certain temps je tente de jouer en réseau avec des amis à age of empire 2.Mais j'ai un problème:quand je lance le jeu et clique sur multijoueur,puis sur connexion internet TCP/IP pour direct play et que j'entre l'adresse IP de mon ami (celle fournie par hamachi) soit il ne trouve aucune partie soit il trouve la partie, mais je ne paux pas la rejoindre au bout de quelques secondes de chargement (avant d'arriver à l'écran ou l'on choisit la civilisation etc..) le message suivant s'affiche"impossible de participer à la partie".Quand c'est moi qui crée la partie mes amis rencontrent le même problème.C'est bizarre car deux de mes amis(plus doués que moi en informatique) ont réussi à jouer ensemble (l'un a windows xp, comme moi l'autre windows 98 ou 2000 je ne me rappelle plus et ils ont tous les deux le patch 2.0b).J'avais déjà essayer de jouer par gamespy,j'avais aussi rencontré un problème.Je soupçonne un problème de pare feu de port à ouvrir ou de routeur, j'ai la freebox.Mais même quand je désactive le pare feu windows cela ne marche pas. J'ai le patch 2.0b.

Ce serait très gentil de m'aider(je galère depuis longtemps:)).Merci de répondre vite.

26 réponses


Voici la synthese de mes recherches concernant ce sujet apres plusieurs heures pour resoudres toutes les variantes possibles de ces emmerdes .

Vous allez devoir verifier un certains nombre de paramettres pour faire marcher le jeu.

1 - Lancez hamachi, verifier que vous etes dans le meme sallon que vos amis, et que vous etes tous reciproquement en statuts "etoiles vertes" les uns les autres. Faire clic-droit sur chaque pseudo et verifier que vous pourvez mutuellement tous vous pinger.

2 - desactivez tous anti virus et pare feux de quelques sorte que ce soit.

3 - verifiez le pare feu windows : dans connection reseau, faire clic droit sur la connection hamachi > propriétés > onglet avancé > parametres du pare feu > verifier qu'il est desactivé > puis dans l'onglet avancé de cette fenetre concernant le pare feu verifier que toutes vos connections son décochées.

4 - verifiez que vous possedez la meme version de Age of empires que vos contacts, meme langue, meme patch, meme 'origine'.

5 - dans la fenetre connection reseaux de windows, dans l'onglet "Avancé" en haut entre "?" et "Outils" , allez dans "Parametres avancé " - on avance toujours beaucoup avec XP - dans cartes et liaisons sont listées vos connections. Selectionnez la connection hamachi et faites la remonter en tete de liste a l'aide de la fleche verte a droite.

6 - Toujours dans connections reseaux, clic-droit sur la connection Hamachi > propriétés > selectionner dans la liste le protocole TCP IP > cliquez sur propriétés > cliquez sur avancé > décochez "metrique de l'interface automatique" et entrez " 1 " dans le cadre metrique de l'interface .

7 - Entrez dans les parametres de votre rooteur, live box, free box ou autre. par exemple pour une live box entrez " \\192.168.1.1 " ( de mémoire ) dans votre fenetre firefox , pour free allez sur free.fr et connectez vous a votre compte et entrez dans les parametres de la freebox . Une fois dedans ,
* vérifiez que l'UPNP est désactivé
* entrez les redirections de ports suivantes :
port 4662 tcp et udp
port 47624 tcp et udp
plage de port de 2300 à 2400 tcp et udp.


Ensuite vous devriez etre en mesure de voir les parties de vos amis et de vous y connecter sans problemes, si je n'ai rien oublié. ^^



RUMEURS ALTERNATIVES n'ayant cependant rien donné chez moi :
- La piste des soit disant noms de profils qu'il faudrait changer pour que ca marche.
- faire tourner le jeu en protocole IPX ( installer le protocole sur votre connection reseau )
56
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 79761 internautes nous ont dit merci ce mois-ci

Pour ceux qui cherchent un reseau rejoingner moi sur :

login : COLI1
mdp : COL

Salut,

Je crois que je pourrait connaître le problème. Au fait, mois, j'ai déjà un tel problème quand je joue au AoE 2 et 3 avec mes amis via LAN et via Hamachi. Et quand il ne marche pas, c'est toujours à cause des logiciels de sécurité (antivirus, Window defender, antispyware, internet security software, etc...).

Donc, s'il ne marche pas, essayer de quitter tous les dits programmes. Mais attention: Quelques fois, vous ne pouvez pas trouver sur le bureau. Donc, essais de faire comme suivant:

- Ouvrier "Executer" (Window + R)
- taper: msconfig => OK
- Clique sur "Démarrage"
- Désactiver (décocher) les logiciciels de sécurité comme ci-desus indiqués;
- Rédémarrer l'ordinateur.

Et voilà, chaque fois que je fais comme ça, ça marche toujours ^^

Bonne chance!

P/S: Si vous voulez jouer au AoE 2 via Hamachi avec moi: vous pouvez joindre mon réseau:

ID Réseau: theendofbyzantins (The End of Byzantins)
Mot de pass: theendofbyzantins
moi je trouve même pas de personne pour joué
Bonjour je cherche des gens pour jouer avec moi
1 - clic connexion internet TCP/IP pour direct play
2 - create
3 - clic bouton IP
4 - send your host name to your friend *host name only exempe sweet- 87d4d89d* dont send ip exemple 129.186.x.x
5 - and aske your friend to Copy your *host name* and paste her in show game
6 - we will see you in the list and will clic join
Desolé qwertz, tu as pas bien comprendre la question.

TEST R2ALIS2 SOUS AOE 2 et 3
Si tu en IP fixe exp: 82.197.245.478 si tu donnes ton ip et que crée la partie en local la personne ne te voit pas, idem en ip direct, même parefeu désactivé que ce soit de windows ou antivirus. Ses tests j'ai deja fait dans tout les sens meme fait la mise a jour de AOE rien ne change.

Parcontre si tu prends hamachi tu donnes IP de hamachi a la personne elle voit la partie mais ne peut pas la rejoindre.

Maintenant reste a savoir pourquoi.

J'ai ajouté "C:\Program Files\Microsoft Games\Age of Empires III\age3.exe" + OverrideAddress="5.210.86.252" +directIPConnectivity

aussi

"C:\Program Files\Microsoft Games\Age of Empires III\age3.exe" + OverrideAddress="5.210.86.252"

Probleme idem rien ne change.

Depuis que AOE 3 existe les soucis sont tres dur et a resoudre.
C'est bien devenu merdique se jeu pour faire du reseau, moi qui a fait faire l'achat a différent de ma famille au loin pour faire de bonnes parties et qu'ont a toujours pas su faire.
Messages postés
8
Date d'inscription
mercredi 15 septembre 2010
Statut
Membre
Dernière intervention
21 avril 2013
2
Ce pourreit-il qu'il y ait un probleme de comptabilité avec AoE2 avec les XP et les Seven7 ?
Moi Idem pourtant sur chaque Pc on a Hamachi et lui est bien dans ma liste de hamachi mais quand je lui donne ip de hamachi il a toujours temps mort......

je comprend plus rien, pourtant hamachi lui fonctionne bien car on se parle via le chat.

Lui sous XP et moi sous vista nous sommes dans 2 villes différentes sous Free et les parferu desactivé, on a ajouté aussi sous la freebox les ports a ouvrir et rien ne fonctionne, meme que nous avons mit a jour AOE 3 et sa reste sans resultat.

Je sais plus quoi faire.
Salut,

j'ai eu le même problême et j'ai trouvé la solution sur internet.
Tu vas sur les propriétés de ta connexion réseau et tu ajoutes le protocole IPX à la liste existante.

Quand tu veux rejoindre la partie de l'autre ordinateur, tu choisis le protocole IPX au lieu deTCP/IP et voilà!
C'est aussi simple que ça.

Bonne partie!
Je sais pas si ca t'interesse tjrs, mais j'ai la solution à ton probleme sur aoe2.
J'ai eu ca aussi, on a tout essayé avec mes potes, et en fait (ne me demande pas pk^^), il suffit juste de creer un nouveau profil!tu vas ds option, creer nouveau profil, et le tour est joué.
Normalement, le chargement ne devrait plus durer aussi longtemps, et surtout, il ne te renverra plus sur la page d'acceuil avec le message d'erreur "impossible de rejoindre la partie".
Voilà, jte souhaite un bon noel (meme si ca vien de passer) etsurtout une bonne année 2009!
Voila pour ceux qui seraient encore interrésés des amis et moi nous jouons a aoe en multi donc si vous voulez faire des war contre nous voila notre serveur hamachi :
nom du réseau : Fummer
mdp : azerty
Voila a bientot j'espere :)
Sinn la solution de Quintin est bonne.Le fait d'avoir changer mon pseudo mavait empecher de rejoindre les partie multi
rejoignez mon reseaux :salonrouge
mot de passe: lamaj
Bah moi j'ai tout essayé, j'ai fais faire les manip' a mes camarades, mais que neni ca marche pas :( ! quelqu'un a une idée... ?
mem pblm pour nous
premier jour ou l'on a instaler hamachi pour faire un AoE2conqueror ca a marcher du 1er coup
(avec mem jeu, version et mem patch)
le lendemain impossible de rejoindre la partie
le lan fonctionne car l'on peu voir les parties crées mais l'attente pour rejoindre la partie se termine par "impossible de rejoindre blablabla"
on a changer les ip
tester le IPX
mem changer le psuedo du jeu
ouvert les port UPN
autoriser les prog hamachi et aoe2 dans le firewall
...
RIEN A FAIRE

pas possible de rejoindre cette pu***n de partie

ya t'il d'autre solutions car le pblm devient rageant
Après avoir moi-même pas mal galérer, je vous fais un bref résumé des points essentiels pour pouvoir jouer à aoe2 en réseau:

- désactiver tout parefeu (sous vista il semblerait que créer une exception suffit)
- ouvrir dans le routeur les ports suivants : 2300-2400 et 47624 (en les redirigeant sur l'IP de votre pc) et surtout ne pas oublier de désactiver UPNP (ce point est souvent oublié dans les tutoriels)
- être sûr que tous les joueurs ont la même version (patchs)
- installer Hamashi (ou un autre utilitaire du même genre) et vérifier qu'il soit monter en première position dans le gestionnaire réseau (valable pour Win XP, pas pour Vista)
- lancer une partie sur Internet en TCP/IP et renseigner l'IP de celui qui héberge la partie (donné par Hamashi)

NB: Normalement, il est possible de se passer d'Hamashi. Il suffit alors d'utiliser l'adresse public du routeur (facile à obtenir sur Internet ou allant dans l'interface du routeur).

POUR CEUX QUI ONT PLUSIEURS JOUEURS/PC CHEZ EUX:
çà se complique quand vous avez plusieurs pc chez vous (par exemple vous et votre frère voulez jouer avec un pote). Dans ce cas, Hamashi est indispensable pour attribuer une adresse IP à chacun de vos pc derrière le routeur. Cependant, seul le pc hébergeant les parties se verra affecté le port 47624, et il faudra partager la plage 2300-2400 entre les autres pc connectés derrière le même routeur (par exemple: 2300-2350 pour 192.168.1.20 et 2351-2400 pour 192.168.1.21).

Bon jeu!
s.spark
Messages postés
2502
Date d'inscription
vendredi 29 octobre 2004
Statut
Contributeur
Dernière intervention
13 février 2018
558
et surtout ne pas oublier de désactiver UPNP (ce point est souvent oublié dans les tutoriels) 

Salut. Je ne vois pas le rapport avec le jeu, et c'est un service qui n'est pas installé par défaut o_O
j'ai le meme probleme

mes aparamment perssone na pus te repondre ???

merci si tu a trouvé une solution de me lindiquer !!!

a bientot rickinao
Messages postés
19
Date d'inscription
lundi 29 décembre 2003
Statut
Membre
Dernière intervention
21 janvier 2019

bonjour, si y'en a qui joue toujours a ce super jeu, ajoutez moi sur Gameranger, WWHeizenberg comme pseudo ;) et à bientôt pour croiser le fer!
Je viens de passer quelques heures à éplucher les forums et explicatifs à propos de Hamachi. J'ai compris le gros du sujet et j'ai installé le programme mais je cherche des partenaires de jeu sur "Age Of Empires II: The Conquerors" ou sur "Age of the Kings".... Y aurait'il parmi vous des nostalgiques comme moi de ce jeu mythique??

Nom du réseau: vikingsreturn
Mdp du réseau: vreturn

Je vous y attends avec impatience! Il reste des places, venez!

Je n'est pas la solution pour votre probléme, mais pose ta question sur le forum de ce site, ils pourront peu être d'aider.

www.ageofempire2.o-n.fr
1 2