Probleme de son sous mandriva 2007 [Résolu/Fermé]

Signaler
Messages postés
41
Date d'inscription
lundi 27 août 2007
Statut
Membre
Dernière intervention
4 août 2008
-
tree
Messages postés
41
Date d'inscription
lundi 27 août 2007
Statut
Membre
Dernière intervention
4 août 2008
-
Bonjour,
j'ai installe linux mandriva 2007 sur mon pc mais je n'ai pas de son j'ai installe alsaconf j'ai vérifié le volume
mais toujours pas de son
dans le centre de contrôle de mandriva pour la carte son j'ai trouver ça :

Identification
Vendeur: ‎Intel Corp.

Description: ‎I/O Controller Hub High Definition Audio

Classe de matériel: ‎NOT_DEFINED

Pilote
Module: ‎snd-hda-intel

Connexion
Bus: ‎PCI

Bus PCI n°: ‎0

Périphérique PCI n°: ‎27

Fonction PCI n°: ‎0

Identifiant du Vendeur: ‎0x8086

Identifiant du périphérique: ‎0x27d8

Identifiant secondaire du vendeur: ‎0x1025

Identifiant secondaire du périphérique: ‎0x012e


cordialement

30 réponses

Messages postés
8214
Date d'inscription
samedi 7 août 2004
Statut
Membre
Dernière intervention
1 septembre 2014
455
bonjour,

redfox@localhost ~ $ id
uid=1000(redfox) gid=100(users) groupes=7(lp),10(wheel),16(cron),18(audio),19(cdrom),80(cdrw),100(users),250(portage)
redfox@localhost ~ $
Messages postés
41
Date d'inscription
lundi 27 août 2007
Statut
Membre
Dernière intervention
4 août 2008

salut
merci mais je suis dans le group audio
Messages postés
8214
Date d'inscription
samedi 7 août 2004
Statut
Membre
Dernière intervention
1 septembre 2014
455
préciser "pas de son" ....sons système ? lecture CD audio ? si oui quel logiciel ?


localhost redfox # lspci | grep audio
00:02.7 Multimedia audio controller: Silicon Integrated Systems [SiS] AC'97 Sound Controller (rev a0)
localhost redfox #

localhost redfox # lsmod | grep snd_intel8x0
snd_intel8x0 31004 1
snd_ac97_codec 91936 1 snd_intel8x0
snd_pcm 71044 3 snd_pcm_oss,snd_intel8x0,snd_ac97_codec
snd 47204 11 snd_seq_oss,snd_seq_device,snd_seq,snd_pcm_oss,snd_mixer_oss,snd_intel8x0,snd_ac97_codec,snd_pcm,snd_timer
snd_page_alloc 11528 2 snd_intel8x0,snd_pcm
localhost redfox #
Messages postés
41
Date d'inscription
lundi 27 août 2007
Statut
Membre
Dernière intervention
4 août 2008

bonjour
quand je fais
[root@localhost home]# lspci | grep audio
[root@localhost home]#

il ne m'affiche rien
bob031
Messages postés
8214
Date d'inscription
samedi 7 août 2004
Statut
Membre
Dernière intervention
1 septembre 2014
455
fais lspci "tout court" (c'est peut-être Audio et non audio)

précise le "pas de son", stp ...

:-))
Messages postés
41
Date d'inscription
lundi 27 août 2007
Statut
Membre
Dernière intervention
4 août 2008

[root@localhost home]# lspci | grep Audio
00:1b.0 Audio device: Intel Corporation 82801G (ICH7 Family) High Definition Audio Controller (rev 02)

[root@localhost home]# lspci
00:00.0 Host bridge: Intel Corporation Mobile 945GM/PM/GMS/940GML and 945GT Express Memory Controller Hub (rev 03)
00:01.0 PCI bridge: Intel Corporation Mobile 945GM/PM/GMS/940GML and 945GT Express PCI Express Root Port (rev 03)
00:1b.0 Audio device: Intel Corporation 82801G (ICH7 Family) High Definition Audio Controller (rev 02)
00:1c.0 PCI bridge: Intel Corporation 82801G (ICH7 Family) PCI Express Port 1 (rev 02)
00:1c.2 PCI bridge: Intel Corporation 82801G (ICH7 Family) PCI Express Port 3 (rev 02)
00:1c.3 PCI bridge: Intel Corporation 82801G (ICH7 Family) PCI Express Port 4 (rev 02)
00:1d.0 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI #1 (rev 02)
00:1d.1 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI #2 (rev 02)
00:1d.2 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI #3 (rev 02)
00:1d.3 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI #4 (rev 02)
00:1d.7 USB Controller: Intel Corporation 82801G (ICH7 Family) USB2 EHCI Controller (rev 02)
00:1e.0 PCI bridge: Intel Corporation 82801 Mobile PCI Bridge (rev e2)
00:1f.0 ISA bridge: Intel Corporation 82801GBM (ICH7-M) LPC Interface Bridge (rev 02)
00:1f.1 IDE interface: Intel Corporation 82801G (ICH7 Family) IDE Controller (rev 02)
00:1f.2 SATA controller: Intel Corporation 82801GBM/GHM (ICH7 Family) Serial ATA Storage Controller AHCI (rev 02)
00:1f.3 SMBus: Intel Corporation 82801G (ICH7 Family) SMBus Controller (rev 02)
01:00.0 VGA compatible controller: ATI Technologies Inc Unknown device 7210 (rev ce)
04:00.0 Ethernet controller: Broadcom Corporation NetLink BCM5787M Gigabit Ethernet PCI Express (rev 02)
05:00.0 Network controller: Intel Corporation PRO/Wireless 3945ABG Network Connection (rev 02)
06:00.0 FLASH memory: ENE Technology Inc Unknown device 0730
06:00.1 Class 0805: ENE Technology Inc Unknown device 0750
06:00.2 FLASH memory: ENE Technology Inc Unknown device 0720
06:00.3 FLASH memory: ENE Technology Inc Unknown device 0751

mais pour le pas de son j'ai pas compris (je suis nouveau dans linux)
bob031
Messages postés
8214
Date d'inscription
samedi 7 août 2004
Statut
Membre
Dernière intervention
1 septembre 2014
455
mais pour le pas de son j'ai pas compris (je suis nouveau dans linux)
j'entends bien ! :-)
ce que je veux dire c'est quand tu dis "pas de son" ....c'est-à-dire : en lisant un CD audio ? sur le net ? ......


ça doit être ceci :
00:1b.0 Audio device: Intel Corporation 82801G (ICH7 Family) High Definition Audio Controller (rev 02)
tree
Messages postés
41
Date d'inscription
lundi 27 août 2007
Statut
Membre
Dernière intervention
4 août 2008
> bob031
Messages postés
8214
Date d'inscription
samedi 7 août 2004
Statut
Membre
Dernière intervention
1 septembre 2014

salut
pas de son du tout
ni pour le web ni pour les cd audio ni pour les jeux
bob031
Messages postés
8214
Date d'inscription
samedi 7 août 2004
Statut
Membre
Dernière intervention
1 septembre 2014
455 > tree
Messages postés
41
Date d'inscription
lundi 27 août 2007
Statut
Membre
Dernière intervention
4 août 2008

ok ! il faut taper en root, dans la console, la commande alsaconf, une interface graphique va te permettre de configurer ta carte-son : tu choisiras donc en référence au résultat de lspci
Messages postés
41
Date d'inscription
lundi 27 août 2007
Statut
Membre
Dernière intervention
4 août 2008

salut desole pour le retard j'ai fait alsaconf

Now ALSA is ready to use.
For adjustment of volumes, use your favorite mixer.

Have a lot of fun!


[root@localhost home]# amixer
Simple mixer control 'Master',0
Capabilities: pvolume
Playback channels: Front Left - Front Right
Limits: Playback 0 - 64
Mono:
Front Left: Playback 48 [75%] [-16.00dB]
Front Right: Playback 48 [75%] [-16.00dB]
Simple mixer control 'PCM',0
Capabilities: pvolume
Playback channels: Front Left - Front Right
Limits: Playback 0 - 255
Mono:
Front Left: Playback 230 [90%]
Front Right: Playback 230 [90%]
[root@localhost home]#

mais toujours rien :(
bob031
Messages postés
8214
Date d'inscription
samedi 7 août 2004
Statut
Membre
Dernière intervention
1 septembre 2014
455
il manque l'essentiel :

1) lorsque tu as configuré avec alsaconf : quels choix étaient proposés ? quel a été ton choix ?
2) moi j'aurai utilisé la commande alsamixer et non amixer (mais peut-être est-ce la même chose ....)
3) qu'indique ceci :
localhost redfox # ls -l /dev/dsp
lrwxrwxrwx 1 root root 9 mar 15 17:15 /dev/dsp -> sound/dsp
localhost redfox #
Messages postés
41
Date d'inscription
lundi 27 août 2007
Statut
Membre
Dernière intervention
4 août 2008

salut
1) lorsque j'ai configure alsaconf j'ai choisi exactement : Intel Corporation 82801G (ICH7 Family) High Definition Audio Controller
2) pour le volume il est a son maximum
3) [root@localhost home]# ls -l /dev/dsp
crw-rw---- 1 m audio 14, 3 mar 15 20:41 /dev/dsp

le nom de mon groupe c'est 'm'
bob031
Messages postés
8214
Date d'inscription
samedi 7 août 2004
Statut
Membre
Dernière intervention
1 septembre 2014
455
1) ok !
2) le volume à 80% est largement suffisant. Vérifier que les canaux soient bien activés !
3)
[root@localhost home]# ls -l /dev/dsp
crw-rw---- 1 m audio 14, 3 mar 15 20:41 /dev/dsp

le nom de mon groupe c'est 'm'


c'est marrant ! je m'attendais à ce que le propriétaire de /dev/dsp soit root .....regarde chez moi !
c'est peut-être ici que le bas blesse ....parce que /dev/dsp devrait appartenir à root (je l'ai toujours vu ainsi !).
Messages postés
41
Date d'inscription
lundi 27 août 2007
Statut
Membre
Dernière intervention
4 août 2008

pour alsamixer ça donne ça :


Card: HDA Intel │
│ Chip: Realtek ID 268 │
│ View: [Playback] Capture All │
│ Item: Master [dB gain=0.00, 0.00] │
│ │
│ ┌──┐ │
│ │▒▒│ │
│ │▒▒│ │
│ │▒▒│ │
│ │▒▒│ │
│ │▒▒│ │
│ │▒▒│ │
│ │▒▒│ │
│ │▒▒│ │
│ │▒▒│ │
│ │▒▒│ │
│ │▒▒│ │
│ └──┘ │
│ │
│ │
│ 100<>100 │
│ < Master >
bob031
Messages postés
8214
Date d'inscription
samedi 7 août 2004
Statut
Membre
Dernière intervention
1 septembre 2014
455
suite mon post précédent :

tu peux essayer en root:

chown root.root /dev/dsp

droits et permissions des fichiers :
http://www.math-linux.com/spip.php?article23

consulte d'autres docs (l'internet en regorge) car la console .....ça peut aider ! :-)
Messages postés
41
Date d'inscription
lundi 27 août 2007
Statut
Membre
Dernière intervention
4 août 2008

[root@localhost dev]# chown root.root /dev/dsp
[root@localhost dev]# ls -l dsp
crw-rw---- 1 root root 14, 3 mar 15 21:04 dsp
bob031
Messages postés
8214
Date d'inscription
samedi 7 août 2004
Statut
Membre
Dernière intervention
1 septembre 2014
455
désolé ! je reprends :
sur ma mandriva
[redfox@bob ~]$ ls -l /dev/dsp
crw-rw---- 1 redfox audio 14, 3 mar 15 20:21 /dev/dsp
[redfox@bob ~]$


tu peux remettre le proprétaire d'origine à /dev/dsp
Messages postés
41
Date d'inscription
lundi 27 août 2007
Statut
Membre
Dernière intervention
4 août 2008

j'ai maintenant :
[m@localhost ~]$ ls -l /dev/dsp
crw-rw---- 1 m root 14, 3 mar 15 21:04 /dev/dsp
donc rien n'a change ? :)
bob031
Messages postés
8214
Date d'inscription
samedi 7 août 2004
Statut
Membre
Dernière intervention
1 septembre 2014
455
ok ! on va récapituler :
tout semble correct ormis cet histoire de "m"
je comprends pas bien ce "m" ???

fais en root :
chown nom_utilsateur.audio /dev/dsp

nom_utilsateur = ton nom d'utilisateur
Messages postés
41
Date d'inscription
lundi 27 août 2007
Statut
Membre
Dernière intervention
4 août 2008

m est mon nom du groupe et nom d'utilisateur
bob031
Messages postés
8214
Date d'inscription
samedi 7 août 2004
Statut
Membre
Dernière intervention
1 septembre 2014
455
alors :
chown m.audio /dev/dsp

une fois remis ceci en place, le problème est semble-t-il ailleurs ....


...ha ! il manque toujours un résultat :

[redfox@bob ~]$ /sbin/lsmod | grep intel
snd_intel8x0 29372 0
snd_ac97_codec 96164 1 snd_intel8x0
snd_pcm 68612 3 snd_pcm_oss,snd_intel8x0,snd_ac97_codec
snd_page_alloc 8232 2 snd_intel8x0,snd_pcm
snd 44612 9 snd_seq_oss,snd_seq,snd_seq_device,snd_pcm_oss,snd_mixer_oss,snd_intel8x0,snd_ac97_codec,snd_pcm,snd_timer
[redfox@bob ~]$
Messages postés
41
Date d'inscription
lundi 27 août 2007
Statut
Membre
Dernière intervention
4 août 2008

[root@localhost home]# /sbin/lsmod |grep intel
snd_hda_intel 15828 2
snd_hda_codec 164544 1 snd_hda_intel
snd_pcm 70116 3 snd_pcm_oss,snd_hda_intel,snd_hda_codec
snd_page_alloc 8712 2 snd_hda_intel,snd_pcm
snd 46500 13 snd_seq_oss,snd_seq,snd_seq_device,snd_pcm_oss,snd_mixer_oss,snd_hda_intel,snd_hda_codec,snd_pcm,snd_timer
intel_agp 22812 1
agpgart 27240 1 intel_agp
bob031
Messages postés
8214
Date d'inscription
samedi 7 août 2004
Statut
Membre
Dernière intervention
1 septembre 2014
455
[redfox@bob ~]$ uname -r
2.6.22.6
[redfox@bob ~]$

[redfox@bob ~]$ cat /etc/modprobe.conf
alias eth0 sis900
remove snd-intel8x0 /sbin/modprobe -r snd-pcm-oss; /sbin/modprobe --first-time -r --ignore-remove snd-intel8x0
install snd-intel8x0 /sbin/modprobe --first-time --ignore-install snd-intel8x0 && { /sbin/modprobe snd-pcm-oss; /bin/true; }
install usb-interface /sbin/modprobe ohci-hcd; /sbin/modprobe ehci-hcd; /bin/true
alias net-pf-10 off
alias ipv6 off
[redfox@bob ~]$
Messages postés
41
Date d'inscription
lundi 27 août 2007
Statut
Membre
Dernière intervention
4 août 2008

[root@localhost home]# uname -r
2.6.17-5mdv
[root@localhost home]# cat /etc/modprobe.conf
alias eth0 tg3
install scsi_hostadapter /sbin/modprobe ahci; /sbin/modprobe ata_piix; /bin/true
remove snd-hda-intel /sbin/modprobe -r snd-pcm-oss; /sbin/modprobe --first-time -r --ignore-remove snd-hda-intel
install snd-hda-intel /sbin/modprobe --first-time --ignore-install snd-hda-intel && { /sbin/modprobe snd-pcm-oss; /bin/true; }
install usb-interface /sbin/modprobe uhci-hcd; /sbin/modprobe ehci-hcd; /bin/true
bob031
Messages postés
8214
Date d'inscription
samedi 7 août 2004
Statut
Membre
Dernière intervention
1 septembre 2014
455
[redfox@bob ~]$ cat /etc/modprobe.d/sound
alias snd-card-0 snd-intel8x0
alias sound-slot-0 snd-intel8x0
[redfox@bob ~]$
Messages postés
41
Date d'inscription
lundi 27 août 2007
Statut
Membre
Dernière intervention
4 août 2008

[root@localhost home]# cat /etc/modprobe.d/sound
alias snd-card-0 snd-hda-intel
alias sound-slot-0 snd-hda-intel
bob031
Messages postés
8214
Date d'inscription
samedi 7 août 2004
Statut
Membre
Dernière intervention
1 septembre 2014
455
j'ai usé toutes mes cartouches tout semble correct ! cela devrait normalement marcher !

c'est donc probablement ailleurs ...

les deux dernières commandes et ton problème de son me rappelle une histoire :
http://www.commentcamarche.net/forum/affich 3008260 mdv07 probleme de son apres update

bien que cela ne soit probablement pas la solution à ton problème de son ........si cela peut t'inspirer !

juste par curiosité c'est quoi comme pc ?

bon courage.

:-))
Messages postés
41
Date d'inscription
lundi 27 août 2007
Statut
Membre
Dernière intervention
4 août 2008

merci beaucoup pour ton aide :)
j'ai acer aspire 5710
Messages postés
41
Date d'inscription
lundi 27 août 2007
Statut
Membre
Dernière intervention
4 août 2008

et bien apres une longue recherche j'ai enfin trouve la solution qui est plus simple que je ne le pensais
aller a ccm (centre de control mandriva) => materiel => explorer et configurer le materiel => selectionner la carte son sur la gauche => cliquer sur specifier les options du pilote courant =>
ecrire dans la case MODEL le model de votre pc (dans mon cas c'est ACER) en laissant les autres vides puis faire un petit restart
et voila