Menu

EXCEL Comparer un texte dans deux cellules.. [Résolu/Fermé]

Messages postés
8
Date d'inscription
jeudi 14 février 2008
Statut
Membre
Dernière intervention
20 février 2008
- - Dernière réponse :  Xavier - 2 déc. 2008 à 21:37
Bonjour,

J'ai une cellule avec une phrase "le chaton est dans la machine" et le texte "machine" dans une autre cellule.
Comment valider le fait que la cellule 1 contient le texte de la cellule 2 ?

Merci
Afficher la suite 

4 réponses

Meilleure réponse
Messages postés
1227
Date d'inscription
jeudi 29 juillet 2004
Statut
Contributeur
Dernière intervention
25 novembre 2013
391
3
Merci
Salut,

tu peux faire un truc comme ça (avec A1 = "le chaton est dans la machine" et B1 = "machine") :
=SI(ESTERREUR(CHERCHE(B1;A1));"Absent";"Présent")
Si tu veux une formule sensible à la casse, utilise TROUVE à la place de CHERCHE

Voilà

Tom

Dire « Merci » 3

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 45860 internautes nous ont dit merci ce mois-ci

Messages postés
8
Date d'inscription
jeudi 14 février 2008
Statut
Membre
Dernière intervention
20 février 2008
1
1
Merci
Merci, ça MARCHE :-)
Messages postés
8
Date d'inscription
jeudi 14 février 2008
Statut
Membre
Dernière intervention
20 février 2008
1
0
Merci
J'ai encore une interrogation :

Comment faire la somme conditionnée a deux oui ?

ex:
A,B,C,D,E
chat, X, le chat est ... , X , 20
chat, Y, le chien est ... ,Z , 10
chat, Y, le chien est ... , F , 20
chien, X, le chat est ... , X , 30
chat, Y, le chat est ... , X , 40

comment trouver le total E si "chat" (A) est compris dans C est que X (B) correspond a X en D ?
Messages postés
1227
Date d'inscription
jeudi 29 juillet 2004
Statut
Contributeur
Dernière intervention
25 novembre 2013
391
-1
Merci
Re,

Alors un ptit sommeprod :
=SOMMEPROD((A1:A5="chat")*(B1:B5=D1:D5)*E1:E5)

Et j'ai meme fait une ptite explication (depuis le tps qu'on me le demande! :) ), ici :
http://www.cijoint.fr/cjlink.php?file=cj200803/cij5771944316430.xls

Tom
Bonjour,

Je voudrais savoir comment faire pour regarder si:
-on a le même nom,
+ la même adresse,
ET la même ville,
mais qu'on a un n° différent, comment faire pour changer le n°(sachant qu'on a 10000données(donc, on ne sait pas le faire manuellement...)

Exemple:

Nom Adresse ville N°
----------------------------------------------
Jean Rue Des chiens liège 120

Jean Rue Des chiens liège 52

Jean Rue Des chiens liège 5

Jean Rue Des chiens liège 0


Il faudrait qu'il mette à la place:


Jean Rue Des chiens liège 0(on met le n° le plus petit...)


Je vous en supplie aidez moi...