Paquet cassés [Fermé]

Signaler
Messages postés
655
Date d'inscription
vendredi 8 juin 2007
Statut
Membre
Dernière intervention
29 novembre 2009
-
 Yog -
Bonjour,


comment réparer un paquet cassés
(utilisation du filtre cassés comment????

4 réponses

Messages postés
655
Date d'inscription
vendredi 8 juin 2007
Statut
Membre
Dernière intervention
29 novembre 2009
21
solution pour unbuntu
1/reperer le paquet cassé aller ds système>administation>gestionnaire de paquets
activer le filtre cassé
2/ouvrir un terminal et taper:
sudo dpkg --force all --purge <paquet à supprimer>
12
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 87034 internautes nous ont dit merci ce mois-ci

marche aussi sous debian ;)
Bonjour, quand j'ouvre "Ubuntu tweak" à la section "Gestionnaire de mises à jour" il me propose une mise à jour (language-pack-gnome-fr), je la seleccionne et clique "installer la mise à jour" et j'obtiens une fenetre qui dit:"Impossible d'appliquer les changements.Réparez d'abord les paquets cassés" lorsque je vais dans le gestionnaire de paquets synaptic et que je choisis l'option décrite ici " Réparer les paquets cassés" rien ne se passe que faire ?
Merci d'avance
Non2
Messages postés
5109
Date d'inscription
mercredi 19 décembre 2007
Statut
Contributeur
Dernière intervention
15 juillet 2015
636
Bonjour,

Chez moi, language-pack-gnome-fr apparait dans les mises à jour, mais en grisé. J'ai déjà eu le coup avec un autre paquet il y a quelque temps. J'avais essayé la mise à jour en ligne de commande, mais rien à faire. Il a accepté de se mettre à jour quelques jours plus tard avec d'autres paquets.

Je suppose (ça peut demander confirmation) qu'il s'agit soit d'un paquet mal fini qui sera réactivé lorsque corrigé, soit d'un paquet qui demande la mise à jour de dépendances qui ne sont pas encore prêtes. Rien de grave toutefois si j'en juge par mon expérience précédente.

Edit : vérification faite, le paquet n'est pas cassé chez moi non plus.
salut, dèz si le post est vieux, mais le probleme lui est toujours d' actuealté !!

donc moi quand je fais ce que tu dis, rien ne se passe ou au mieux une fenetre s' affiche, on dirait un explrateur et il demande à ce que je choisisse un fichier !!!???
Non2
Messages postés
5109
Date d'inscription
mercredi 19 décembre 2007
Statut
Contributeur
Dernière intervention
15 juillet 2015
636
Bonjour,

S'il s'agit d'un système type Ubuntu, ou toute autre distribution utilisant Synaptic comme gestionnaire de paquets en graphique, il faut aller dans Système > Administration > Gestionnaire de paquets Synaptic, puis dans le menu Edition, choisir l'option "Réparer les paquets cassés".

Si c'est une distribution qui n'utilise pas Synaptic, il faut préciser de quelle distrib il s'agit pour obtenir une réponse appropriée.
lami20j
Messages postés
21511
Date d'inscription
jeudi 4 novembre 2004
Statut
Modérateur, Contributeur sécurité
Dernière intervention
30 octobre 2019
3 442
Salut,

S'il s'agit d'un système type Ubuntu,
Je dirais plutôt, "s'il s'agit d'un système type Debian" ;-)
Non2
Messages postés
5109
Date d'inscription
mercredi 19 décembre 2007
Statut
Contributeur
Dernière intervention
15 juillet 2015
636
Salut,

En effet, Ubuntu est un "descendant" de Debian. Mais comme ils s'éloignent de plus en plus de la ligne de Debian, je pense que les debianistes purs auraient du mal à y retrouver leur façon de penser l'OS ... qu'on apprécie ou non l'un ou/et l'autre.
lami20j
Messages postés
21511
Date d'inscription
jeudi 4 novembre 2004
Statut
Modérateur, Contributeur sécurité
Dernière intervention
30 octobre 2019
3 442
Salut,

Mais comme ils s'éloignent de plus en plus de la ligne de Debian,
Vu qu'une des caractéristiques principale c'est le gestionnaire de paquets alors Ubuntu restera une distribution basée Debian sinon sous le capot ça reste du Linux tant que le moteur utilisé est le même kernel. C'est plutôt Debian qui a une tendance de s'éloigner de la ligne Linux vu l'utilisation d'un kernel FreeBSD;-)

Maintenant que la mentalité est différente, c'est peut être une bonne chose, on a une panoplie de choix plus large.
Non2
Messages postés
5109
Date d'inscription
mercredi 19 décembre 2007
Statut
Contributeur
Dernière intervention
15 juillet 2015
636
Salut,

Je n'ai jamais dit que c'était un mal ... au contraire, je pense que ces différentes possibilités sont comme des marches d'escaliers vers ce que chacun cherche. ;-)

Par contre j'ignorais cette histoire de kernel BSD !
Messages postés
438
Date d'inscription
mardi 26 février 2013
Statut
Membre
Dernière intervention
4 mars 2019
20
Salut,
J'ai le même problème que zenneplet,et cela me marque la même chose que lui.quand je fais avec Synaptic "tout mettre à niveau" cela me mets:
E: Erreur, pkgProblemResolver::Resolve a généré des ruptures, ce qui a pu être causé par les paquets devant être gardés en l'état.
E: Impossible de corriger les dépendances
et j'aimerais bien pouvoir mettre la mise à niveau,mais impossible de le faire sans mise à jour!!
Merci de me répondre(même si je vois que les derniers messages ne dépassent pas le 23/06/11 :)
Ubuntunien
Messages postés
438
Date d'inscription
mardi 26 février 2013
Statut
Membre
Dernière intervention
4 mars 2019
20
au fait,impossible de réparer les paquets,et je ne sais même pas lesquels c'est