[Debian]Mysql acces distant [Résolu/Fermé]

Signaler
Messages postés
876
Date d'inscription
mercredi 17 août 2005
Statut
Membre
Dernière intervention
20 décembre 2012
-
 zeuros -
Bonsoir,

Sur Debian j'ai installer un serveur mysql (interface phpmyadin) et j'aimerai bien pouvoir avoir l'acces distant , a chaque fois que j'essaie de me connecter j'ai l'erreur 10061 et je ne sais que faire ! sur irc on m'a dit que l'on pouvait definir l'acces distant dans la base de donnée mais je ne vois pas ou ?dans quel colonne,dans quel champs.
Pouvez-vous m'aider ?

Merci d'avance .

A bientot

8 réponses

Bonjour,

dans ton my.cnf il faut commenter skip-networking
1
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 83272 internautes nous ont dit merci ce mois-ci

Messages postés
876
Date d'inscription
mercredi 17 août 2005
Statut
Membre
Dernière intervention
20 décembre 2012
172
re ,

en faite j'avais vu skip-networking mais il est commenté et comme je suis un peu (beaucoup en faite) nul en anglais je n'avais pas lu , et la si j'arrive a lire j'ai modifier :

# Instead of skip-networking the default is now to listen only on
# localhost which is more compatible and is not less secure.
bind-address = 127.0.0.1

en

# Instead of skip-networking the default is now to listen only on
# localhost which is more compatible and is not less secure.
#bind-address = 127.0.0.1
skip-networking


Est ce que c'est sa ? en tout cas j'ai essayer ce que j'ai mis en haut le serveur restart sans probleme mais je n'arrive toujours pas a me connecter en acces distant .

A bientot et merci de tes reponses .

1
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 83272 internautes nous ont dit merci ce mois-ci

pas tout à fait

enlève le skip-networking

il fallait en effet commenter bind-address = 127.0.0.1
Surtout pas...
il faut bien laisser bind-address, en revanche il faut changer l'IP.
Comme expliquer dans my.cnf :
bind-address = 127.0.0.1 -> c'est pour dire qu'on écoute que sur l'adresse ou la boucle locale de réseau. Bref le serveur est son propre client...

si on veut accéder depuis une machine d'IP 192.168.1.12 et que notre serveur est 192.168.1.1 : on met :
bind-address = 192.168.1.1
Rassurez vous : on accède toujours à mysql depuis localhost. on a juste rajouté l'écoute sur une carte réseau...

NOTA : pas la peine de multiplié les lignes bind-address... seule la dernière lue est prise en compte.
Messages postés
876
Date d'inscription
mercredi 17 août 2005
Statut
Membre
Dernière intervention
20 décembre 2012
172
Voila je l'ai fait !
mais sa me fait un autre probleme maintenant quand j'essai de me connecter sa me met :

Host 'julien-pc' is not allowed to connect to this Mysql server . ( erreur 1130 )

J'ai chercher sur google , sur des forums c'est ecrit qu'il faut envoyer ces requetes :

CREATE user root@'%' IDENTIFIED BY '' ;
GRANT ALL ON *.* TO root@'%' WITH GRANT OPTION ;


mais quand je tape mysql dans le terminal sa me met :

ERROR 1045 (28000): Access denied for user 'root'@'localhost' (using password: NO)
Donc je ne peux pas envoyer les requetes et je ne sais quoi faire :(

Que de problemes !

A bientôt .


PS : si il faut je peux réinstaller mysql-server ou alors si une ame charitable veut bien m'aider par ssh .
Ps2 : lien de la source (forum) : http://www.developpez.net/forums/showthread.php?t=387897
1
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 83272 internautes nous ont dit merci ce mois-ci

aaaaaaaaaaaargh :(

faut lire un peu la doc avant de commencer avec ce genre d'engin :(

tu te rends pas compte, c'est des milliers de pages, on peut pas tout t'apprendre ici

tiens c'est en français

http://dev.mysql.com/doc/refman/5.0/fr/
1
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 83272 internautes nous ont dit merci ce mois-ci

Messages postés
21511
Date d'inscription
jeudi 4 novembre 2004
Statut
Modérateur, Contributeur sécurité
Dernière intervention
30 octobre 2019
3 426
Salut,

et si tu tapes la commande
mysql -u root -p
il ne s'agit pas de mot de passe root du système mais celui du mysql
donc si tu n'as pas un mot de passe fait simplement ENTRER
si c'est bon tu dois voir ça
lami20j@debian:~/trash$ mysql -u root -p
Enter password:
Welcome to the MySQL monitor.  Commands end with ; or \g.
Your MySQL connection id is 7
Server version: 5.0.32-Debian_7etch1-log Debian etch distribution

Type 'help;' or '\h' for help. Type '\c' to clear the buffer.

mysql>
sinon affiche l'erreur
1
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 83272 internautes nous ont dit merci ce mois-ci

Messages postés
876
Date d'inscription
mercredi 17 août 2005
Statut
Membre
Dernière intervention
20 décembre 2012
172
Bonjour,

Voici le fichier my.cnf


#
# The MySQL database server configuration file.
#
# You can copy this to one of:
# - "/etc/mysql/my.cnf" to set global options,
# - "~/.my.cnf" to set user-specific options.
#
# One can use all long options that the program supports.
# Run program with --help to get a list of available options and with

# --print-defaults to see which it would actually understand and use.
#
# For explanations see
# http://dev.mysql.com/doc/mysql/en/server-system-variables.html

# This will be passed to all mysql clients
# It has been reported that passwords should be enclosed with ticks/quotes
# escpecially if they contain "#" chars...
# Remember to edit /etc/mysql/debian.cnf when changing the socket location.
[client]
port = 3306
socket = /var/run/mysqld/mysqld.sock

# Here is entries for some specific programs
# The following values assume you have at least 32M ram

# This was formally known as [safe_mysqld]. Both versions are currently parsed.
[mysqld_safe]
socket = /var/run/mysqld/mysqld.sock
nice = 0

[mysqld]
#
# * Basic Settings
#
user = mysql
pid-file = /var/run/mysqld/mysqld.pid
socket = /var/run/mysqld/mysqld.sock
port = 3306
basedir = /usr
datadir = /var/lib/mysql
tmpdir = /tmp
language = /usr/share/mysql/english
skip-external-locking
#
# Instead of skip-networking the default is now to listen only on
# localhost which is more compatible and is not less secure.
bind-address = 127.0.0.1
#
# * Fine Tuning
#
key_buffer = 16M
max_allowed_packet = 16M

thread_stack = 128K
thread_cache_size = 8
#max_connections = 100
#table_cache = 64
#thread_concurrency = 10
#
# * Query Cache Configuration
#
query_cache_limit = 1M
query_cache_size = 16M
#
# * Logging and Replication
#
# Both location gets rotated by the cronjob.
# Be aware that this log type is a performance killer.
#log = /var/log/mysql/mysql.log
#
# Error logging goes to syslog. This is a Debian improvement :)
#
# Here you can see queries with especially long duration
#log_slow_queries = /var/log/mysql/mysql-slow.log
#long_query_time = 2
#log-queries-not-using-indexes
#
# The following can be used as easy to replay backup logs or for replication.
#server-id = 1
log_bin = /var/log/mysql/mysql-bin.log
# WARNING: Using expire_logs_days without bin_log crashes the server! See README.Debian!
expire_logs_days = 10
max_binlog_size = 100M
#binlog_do_db = include_database_name
#binlog_ignore_db = include_database_name
#
# * BerkeleyDB
#
# Using BerkeleyDB is now discouraged as its support will cease in 5.1.12.
skip-bdb
#
# * InnoDB
#
# InnoDB is enabled by default with a 10MB datafile in /var/lib/mysql/.
# Read the manual for more InnoDB related options. There are many!
# You might want to disable InnoDB to shrink the mysqld process by circa 100MB.

#skip-innodb
#
# * Security Features
#
# Read the manual, too, if you want chroot!
# chroot = /var/lib/mysql/
#
# For generating SSL certificates I recommend the OpenSSL GUI "tinyca".
#
# ssl-ca=/etc/mysql/cacert.pem
# ssl-cert=/etc/mysql/server-cert.pem
# ssl-key=/etc/mysql/server-key.pem



[mysqldump]
quick
quote-names
max_allowed_packet = 16M

[mysql]
#no-auto-rehash # faster start of mysql but no tab completition

[isamchk]
key_buffer = 16M

#
# * NDB Cluster
#
# See /usr/share/doc/mysql-server-*/README.Debian for more information.
#
# The following configuration is read by the NDB Data Nodes (ndbd processes)
# not from the NDB Management Nodes (ndb_mgmd processes).
#
# [MYSQL_CLUSTER]
# ndb-connectstring=127.0.0.1


#
# * IMPORTANT: Additional settings that can override those from this file!
#
!includedir /etc/mysql/conf.d/



Je ne vois pas de skip-networking . Aidez moi . Merci d'avance .

A bientot
----------------
- [ Juck'n0 ]-
Je ne vois pas de skip-networking

relis

là où c'est écrit, c'est aussi écrit que c'est remplacé par autre chose. Je te laisse conclure.
Messages postés
876
Date d'inscription
mercredi 17 août 2005
Statut
Membre
Dernière intervention
20 décembre 2012
172
Je vais voir sa !
Merci de ton aide en tout cas ! A bientot !
Messages postés
876
Date d'inscription
mercredi 17 août 2005
Statut
Membre
Dernière intervention
20 décembre 2012
172
Sa marche !

Merci a vous !