Contrôler 2 feuilles excel et 1 fichier [Résolu]

Signaler
Messages postés
3
Date d'inscription
mercredi 25 mars 2020
Statut
Membre
Dernière intervention
26 mars 2020
-
PHILOU10120
Messages postés
5469
Date d'inscription
lundi 16 avril 2012
Statut
Contributeur
Dernière intervention
4 avril 2020
-
Bonjour,

Je souhaite automatiser le contrôle de certaines informations, pour le traitement de la paie.

Mon fichier principale (Export paie) est constitué de 2 feuilles :
La première feuille (Feuil1) est un tableau que j'exporte depuis le logiciel de paie, un tableau de base qui reprend les informations suivantes : matricule, salarié (nom et prénom), poste occupé, date début emploi, date fin d'emploi, les heures travaillées et la base horaire mensuel (Horaire mensuel).

La seconde feuille (Feuil2) est un tableau qui regroupe des heures, c'est un export depuis le logiciel d'heures (pointage).

Je souhaite ajouter une 3ème feuille (Feuil3) pour contrôler les éléments suivants :

- le matricule du salarié dans la Feuil1 doit correspondre au matricule indiquer dans la Feuil2 (cela peut arriver que le matricule change).

- la base horaire indiquer dans la Feuil1 doit coïncider avec celle dans le fichier "Suivi du personnel"

J'aimerais que, dans cette matrice (dans la Feuil3), les éléments se contrôlent automatiquement ou presque !
Pouvez-vous m'apporter vos connaissances pour cette mise en place ?

De plus, dans le fichier "Export paie", Feuil2, les noms des employés sont inversés par rapport à la Feuil1 -> il y a d'abord le prénom et ensuite le nom.
Croyez-vous qu'il faut changer la syntaxe pour les formules puissent fonctionner ?


Merci d'avance pour votre aide,

Bien à vous



Configuration: Windows / Chrome 80.0.3987.149

4 réponses

Messages postés
11975
Date d'inscription
mercredi 16 janvier 2013
Statut
Membre
Dernière intervention
5 avril 2020
1 759
Bonjour

Sans avoir un exemple de ton fichier je ne peux que te proposer un petit exemple pour te donner une piste de travail :
https://mon-partage.fr/f/hF8hK7TR/

Cdlmnt
Via
Raymond PENTIER
Messages postés
51466
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
5 avril 2020
12 616
... sans oublier de modifier le nom des gens avant : ils pourraient te poursuivre !
Messages postés
5469
Date d'inscription
lundi 16 avril 2012
Statut
Contributeur
Dernière intervention
4 avril 2020
414
Bonjour EvaK23

Mettre cette formule en colonne F feuil1 du classeur suivi personnel

=SI(SIERREUR(RECHERCHEV(A2;'[Export paie.xlsx]Feuil1'!$B$2:$G$8;6;0);"Nok")=E2;"Ok";"Nok")

Puis adapter
EvaK23
Messages postés
3
Date d'inscription
mercredi 25 mars 2020
Statut
Membre
Dernière intervention
26 mars 2020

Bonjour Philou10120,

Super, merci pour l'aide et cela fonctionne :)


Toutefois, en préparant l'exemple, j'ai oublié de mettre une indication dans le tableau "Suivi du personnel", colonne "Heures / mensuelles", j'ai oublié de mettre la formule de calcul.
C'est une formule toute simple qui est la (base horaire hebdomadaire*52/12) -> exemple : (10*52)/12 = 43.3333h menseulles.

Lorsque j'ai paramétré le formule, il y a l'indication "NOK" pour certains salariés, alors que c'est juste, car la base horaire dans le tableau "Suivi du personnel" a des chiffres après la virgule.

Dans le tableau "Export paie", la colonne "HoraireMensuel", il n'y a pas les chiffres après la virgule.

J'ai changé le format dans les tableaux, mais rien n'y fait, les chiffres après la virgule grouillent la formule !!!!


Avez-vous une astuce pour y remédier ?

En vous remerciant par avance,
Messages postés
5469
Date d'inscription
lundi 16 avril 2012
Statut
Contributeur
Dernière intervention
4 avril 2020
414
Bonjour Evak23

Essayer la fonction ARRONDI

=ARRONDI(G2;2)
Messages postés
3
Date d'inscription
mercredi 25 mars 2020
Statut
Membre
Dernière intervention
26 mars 2020

Bonjour,

Oui c'est exact, j'ai oublié les fichiers !
Voici le lien pour trouver les exemples. :

https://drive.google.com/drive/folders/1qZlgAsc17JiWPaNUz2ad0bZn7fIGImB_?usp=sharing


J'ai bien modifié les données, tous les éléments indiqués sont factices (merci pour le rappel).


Merci d'avance et bonne journée