Si imbriqué [Résolu]

Signaler
Messages postés
5
Date d'inscription
mercredi 18 mars 2020
Statut
Membre
Dernière intervention
19 mars 2020
-
Emi1812
Messages postés
5
Date d'inscription
mercredi 18 mars 2020
Statut
Membre
Dernière intervention
19 mars 2020
-
Bonjour,

J'ai un problème concernant ma formule Si imbriqué. En effet, des fois elle marche et des fois elle ne fonctionne plus... je veux faire un tableau relatant l'état des factures que les clients doivent payer. Pour se faire j'ai des cellules dates qui servent de références. La cellule qui contient la formule est la G7 et pose la question de faire une 1ère relance ou non et si la cellule H7 est remplie alors il faut marquer "fait". C'est cette dernière partie qui coince... voici ce que j'ai comme formule :
=si(ET(B7="";E7="");"";Si($F$3>F7+15;"OUI";SI(H7<>"";"FAIT";"NON")))

J'espère que cela est clair pour vous et que vous pourrez m'aider à résoudre ce problème. Merci par avance et bonne journée !

4 réponses

Messages postés
2460
Date d'inscription
dimanche 3 mai 2009
Statut
Membre
Dernière intervention
28 mars 2020
567
Bonjour,

Désolé si je n'ai pas tout compris ; formule à tenter

=SI(ET(B7="";E7="");"";SI(H7<>"";"FAIT";SI($F$3>F7+15;"OUI";"NON")))

Cordialement
Emi1812
Messages postés
5
Date d'inscription
mercredi 18 mars 2020
Statut
Membre
Dernière intervention
19 mars 2020

Bonjour,

Désolée si je manque de clarté...

Enfaite il faudrait dire que si quelque chose est marqué dans la cellule H7 (en l'occurence pour ma part c'est une date) alors il faut marquer "fait" dans la cellule G7.
Merci pour votre réponse très rapide!
Messages postés
2460
Date d'inscription
dimanche 3 mai 2009
Statut
Membre
Dernière intervention
28 mars 2020
567
Re :

Vous n'avez pas dit si la formule convenait.

Ce que j'ai compris : H7 doit contenir une date pour marquer "FAIT" // Si la cellule est vide alors c'est F7 qui entre en jeu // si F7 est antérieur de + de 15 jours par rapport à la date inscrite en F3 alors ça marque "OUI" pour relancer le client, sinon ça marque "NON".

Si ma déduction est juste alors ma formule est bonne.

Cordialement
Emi1812
Messages postés
5
Date d'inscription
mercredi 18 mars 2020
Statut
Membre
Dernière intervention
19 mars 2020

Excusez moi. Non la formule ne correspond pas malheureusement. Non ca n'a rien à voir avec f7 ni l'antériorité moi je veux juste dire que si en H7 il y a une date alors la formule doit écrire FAIT dans G7.
Merci d'avance
Messages postés
11934
Date d'inscription
mercredi 16 janvier 2013
Statut
Membre
Dernière intervention
28 mars 2020
1 743
Bonjour à vous deux

Alors ce serait plutôt :
=SI(ET(B7="";E7="");"";SI(F$3>F7+15;SI(H7<>"";"FAIT";"OUI");"NON"))

Cdlmnt
Via
Emi1812
Messages postés
5
Date d'inscription
mercredi 18 mars 2020
Statut
Membre
Dernière intervention
19 mars 2020

Bonjour,

Non ce n'est pas cela, au lieu de dire H7="" qui équivaut à dire s'il n'ya rien dans H7 il faut marquer Fait, il faut que je trouve la formule pour dire "s'il y a quelque chose d'inscrit dans H7 alors il faut marquer FAIT dans G7". Votre formule fait l'inverse du coup.

Merci pour votre aide.
Messages postés
5
Date d'inscription
mercredi 18 mars 2020
Statut
Membre
Dernière intervention
19 mars 2020

Bonjour,

J'ai réussi ! J'ai juste changé l'ordre de ma formule et ça a marché... je ne vais pas chercher à comprendre pourquoi. Merci beaucoup pour votre aide bonne journée