OpenOffice Calc, compter des lettres selon une condition [Résolu]

Signaler
Messages postés
2
Date d'inscription
mercredi 4 mars 2020
Statut
Membre
Dernière intervention
5 mars 2020
-
chalilin
Messages postés
2
Date d'inscription
mercredi 4 mars 2020
Statut
Membre
Dernière intervention
5 mars 2020
-
Bonjour,


Voyez j'ai là un tableau (celui sur G2 à G11 et H2 à H11) qui m'indique le nombre de case qui contienne A ET qui sont sur une ligne comprenant 1 (puis combien de B sont proche de 1 ect...)
Pour que ça soit visuel j'ai remplie manuellement les première cases, mais n'y a-t-il pas une formule?
J'ai cherché sans que ça soit fructueux car bien mal à l'aise dans le fouillis de la documentation.

Quelqu'un à une solution?


Configuration: Windows / Firefox 73.0

2 réponses

Messages postés
2459
Date d'inscription
dimanche 3 mai 2009
Statut
Membre
Dernière intervention
27 mars 2020
567
Bonjour,

Pour G2

=SOMMEPROD(($C$2:$C$11=$G$1)*($B$2:$B$11=F2))

Pour H2

=SOMMEPROD(($C$2:$C$11=$H$1)*($B$2:$B$11=F2))

Attention à bien respecter l'emplacement des signes " $ " avant de glisser les formules vers le bas.

Cordialement
Messages postés
2
Date d'inscription
mercredi 4 mars 2020
Statut
Membre
Dernière intervention
5 mars 2020

Parfait merci!
Je me doutait bien qu'il fallait utiliser SOMMEPROD mais j'y comprenais rien.