Erreur formule index equiv [Résolu]

Signaler
Messages postés
1
Date d'inscription
mercredi 26 février 2020
Statut
Membre
Dernière intervention
26 février 2020
-
Vaucluse
Messages postés
24975
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
29 mars 2020
-
Bonjour,

ma formule ne fonctionne pas, pouvez-vous m'aider ?
Je souhaite que par rapport au numéro d'intérimaire (colonne en vert), le nombre d'heures (en bleu) s'affiche de façon automatique. Feuil1 correspond à un export et "en poste" à mon reporting.

Ma formule : =INDEX(Feuil1!$E$4:$E$150;EQUIV(CTXT($B$3:$B$150;0;1);Feuil1!$D$4:$D$150;0);0)

Cependant, cela fonctionne uniquement si je tape manuellement le numéro intérimaire sans le 0 devant sur mon export "Feuil 1" sauf que je ne peux pas le faire pour tous sur l'onglet. Initialement le numéro intérimaire est avec le 0 devant (colonne de couleur orange sur Feuil1). Donc si ma formule pouvait prendre en compte mon n° intérimaire avec le 0 devant se serait top.

Je dois ajouter le n° intérimaire pour toutes les personnes sur l'onglet "en poste" je voulais déjà tester sur une petite partie.

Les infos de Feuil1 sont celles à indiquer sur l'onglet "en poste".

Si quelqu'un peut m'aider je n'y arrive vraiment pas j'ai une erreur sur ma formule.

Ci-joint une image mon fichier avec les 2 onglets côte à côte

Merciii d'avance.

2 réponses

Messages postés
5467
Date d'inscription
lundi 16 avril 2012
Statut
Contributeur
Dernière intervention
26 mars 2020
407
Bonjour

Une image n'est pas utile, on peut rien faire avec
Envoyer un fichier de quelques lignes sans donnée confidfentielle
Messages postés
24975
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
29 mars 2020
5 116
Bonjour (et salut Philou)
effectivement, le fichier serait plus clair pour traiter le sujet!

ceci dit, à toutes fins utiles:
pour utiliser CTXT dans votre cas il faut spécifier l'option décimale; soit
CTXT($B3;0) à tirer sur la hauteur

mais si ça ne convient toujours pas,
essayez en U3:
=INDEX(Feuil1!$E$4:$E$150;EQUIV(STXT($B3;1NBCAR(B3));Feuil1!$D$4:$D$150;0);0)
et vous pouvez compléter pour éviter les:#NA quanb le code n'est pas trouvé
=SIERREUR(INDEX(Feuil1!$E$4:$E$150;EQUIV(STXT($B3;1NBCAR(B3));Feuil1!$D$4:$D$150;0);0);"")
Par ailleurs:
  • vérifiez que vos données , si elles viennent de fichier extérieurs, soient bien conformes dans les deux feuilles (sans blanc ou caractère parasite)
  • pour afficher un zéro, il suffit soit d'écrire les codes dans une cellule "texte", soit d'écrire en commençant part une apostrophe dans la barre de formule

en attendant le fichier
crdlmnt