Calcul délai de paiement fournisseur [Résolu]

Signaler
Messages postés
1
Date d'inscription
jeudi 13 février 2020
Statut
Membre
Dernière intervention
13 février 2020
-
PapyLuc51
Messages postés
2368
Date d'inscription
dimanche 3 mai 2009
Statut
Membre
Dernière intervention
20 février 2020
-
Bonjour,

A partir d'une date de transaction d'une commande, je souhaiterai calculer par Excel une date de règlement d'un fournisseur sachant que je dois ajouter 2 contraintes (délai de paiement + délai de versement automatisé)


Exemple:

Date de transaction enregistrée: 05/01/2020
Délai incompressible de la somme restant dans nos comptes: 18 jours
Virement automatisé tous les 15 du mois (soit le 01 ou le 15)

Dans cette exemple la date de règlement doit être le 01/02/2020.

Par quelle fonction puis je automatiser la date de règlement dans une cellule Excel contenant plusieurs milliers de lignes?

Merci pour votre aide par avance.

5 réponses

Messages postés
11766
Date d'inscription
mercredi 16 janvier 2013
Statut
Membre
Dernière intervention
20 février 2020
1 668
Bonjour Warmup

Avec par exemple la date de transaction en B3, dans la cellule où tu veux la date de réglement :
=SI(JOUR(B3+18)<14;DATE(ANNEE(B3+18);MOIS(B3+18);15);MOIS.DECALER(DATE(ANNEE(B3+18);MOIS(B3+18);1);1))
à étirer ensuite vers le bas

Cdlmnt
Via
Messages postés
2368
Date d'inscription
dimanche 3 mai 2009
Statut
Membre
Dernière intervention
20 février 2020
513
Bonjour,

Salutations Via Je n'avais pas poussé mon essai assez loin pour me rendre compte de mon erreur.
Dans ta formule tu mets =SI(JOUR(B3+18)<14.
Il me semble que si la date+le délai de 18 jours tombe le 14 du mois (voir peut-être le 15 ""à préciser par Warmup78""), c'est le 15 qu'il faut inscrire comme date de paiement.

Cordialement
Messages postés
11766
Date d'inscription
mercredi 16 janvier 2013
Statut
Membre
Dernière intervention
20 février 2020
1 668
Bonjour Papyluc☺

Oui tu as raison j'ai bafouillé sur les touches !, c'est <15 voire même <=15 qu'il faut mettre dans la formule
Merci d'avoir rectifié
On attend le retour de Warmup

Cdlmnt
Via


Messages postés
2368
Date d'inscription
dimanche 3 mai 2009
Statut
Membre
Dernière intervention
20 février 2020
513
Bonjour

un essai ; avec la date de départ en A1

=SI(A1<>"";SI(A1+18<DATE(ANNEE(A1);MOIS(A1)+1;1);DATE(ANNEE(A1);MOIS(A1)+1;1);DATE(ANNEE(A1);MOIS(A1)+1;15));"")

Cordialement
Je viens essayer votre formule et c'est bien <15. formidable ça fonctionne bien.

Merci Via55 et PapyLuc51 pour votre aide précieuse!


de vrais experts!

cdt


Warmup
PapyLuc51
Messages postés
2368
Date d'inscription
dimanche 3 mai 2009
Statut
Membre
Dernière intervention
20 février 2020
513
Un clic sur résolu pour confirmer si c'est le cas

Cordialement