Formule excel

Signaler
Messages postés
2
Date d'inscription
mercredi 12 février 2020
Statut
Membre
Dernière intervention
12 février 2020
-
via55
Messages postés
11761
Date d'inscription
mercredi 16 janvier 2013
Statut
Membre
Dernière intervention
18 février 2020
-
Bonjour,

Je cherche quel type de formule utiliser pour que lorsque les 2 premières lettres de colonne A sont par exemple PM le nom Patricia apparaisse dans la colonne B ou
colonne A "GR" = Colonne B "Gui"
colonne A "SR" = Colonne B "Stella"

Merci

3 réponses

Messages postés
11761
Date d'inscription
mercredi 16 janvier 2013
Statut
Membre
Dernière intervention
18 février 2020
1 664
Alors :
RECHERCHEV(GAUCHE(A2;2);Feuil2!A:B;2;0)
Messages postés
11761
Date d'inscription
mercredi 16 janvier 2013
Statut
Membre
Dernière intervention
18 février 2020
1 664
Bonjour

Il faut faire sur une autre feuille un tableau de correspondance
col A Col B
PM Patricia
GR Gui
etc

Puis dans la 1er feuille tu fait en B avec RECHERCHE rechercher le code en A dans ton tableau et renvoyer le nom de la 2eme colonne :
=RECHERCHEV(A2;Feuil2!A:B;2;0)

Cdlmnt
Via
Messages postés
2
Date d'inscription
mercredi 12 février 2020
Statut
Membre
Dernière intervention
12 février 2020

Bonjour,

Merci de votre réponse rapide.
Ça ne semble pas fonctionner parce que PM de la colonne A ou GR ou SR fait partie d'un plus gros code.

Colonne A Colonne B
PM200212 Formule pour que PM soit trouvé et apparaisse Patricia dans la cellule.
GR200115 Formule pour que GR soit trouvé et apparaisse Gui dans la cellule.

Je n'avais pas été précise dès le départ.
J'ai une formule de 10 Abréviation à interpréter, ceci est un exemple simplifié.

Merci beaucoup de votre aide.