Recherchev

Signaler
-
PHILOU10120
Messages postés
5423
Date d'inscription
lundi 16 avril 2012
Statut
Contributeur
Dernière intervention
11 février 2020
-
Bonjour,

J'ai une formule qui recherche une référence d'article dans la colonne B et trouve la description correspondante à l'article dans une autre colonne :

=SIERREUR(RECHERCHEV(B6;Feuil1!$A:$B;2;0);"###")


Certains articles ont des variantes, mais doivent avoir la même description, voilà un exemple :

un article possède la réf G565A et un autre la réf G565B

Comment faire pour que RECHERCHEV ne tienne pas compte de la dernière lettre si celle-ci est un A ou un B ?


Configuration: Windows / Firefox 72.0

2 réponses

Messages postés
5423
Date d'inscription
lundi 16 avril 2012
Statut
Contributeur
Dernière intervention
11 février 2020
385
Bonjour

Essayer cette formule

=RECHERCHEV((GAUCHE(B6;4)&"*");Feuil1!$A:$B;2;0)

Si il y a 4 caractères de base identiques

PHILOU10120
Messages postés
5423
Date d'inscription
lundi 16 avril 2012
Statut
Contributeur
Dernière intervention
11 février 2020
385 > barnabe0057
Il faut modifier la formule comme ceci

=RECHERCHEV((GAUCHE(B6;NBCAR(B6)-1)&"*");Feuil1!$A:$B;2;0)

La formule fonctionne si c'est seulement le dernier caractère qui change
> PHILOU10120
Messages postés
5423
Date d'inscription
lundi 16 avril 2012
Statut
Contributeur
Dernière intervention
11 février 2020

Merci pour tes efforts, j'ai une dernière inquiétude : certaines références ne se terminent ni par A ni par B

Ta solution ne risque-t-elle pas de fausser la recherche ?
PHILOU10120
Messages postés
5423
Date d'inscription
lundi 16 avril 2012
Statut
Contributeur
Dernière intervention
11 février 2020
385 > barnabe0057
attention aux doublons, la recherche donne la première occurrence trouvé
F0021A
F0021B
F0021C
la rechercheV donnera la ligne F0021A comme réponse
> PHILOU10120
Messages postés
5423
Date d'inscription
lundi 16 avril 2012
Statut
Contributeur
Dernière intervention
11 février 2020

Que se passera-t-il si la référence est par exemple S960 ?
La fonction RECHERCHEV va chercher la valeur S96, valeur qu'elle ne trouvera pas.
PHILOU10120
Messages postés
5423
Date d'inscription
lundi 16 avril 2012
Statut
Contributeur
Dernière intervention
11 février 2020
385 > barnabe0057
Il trouvera S96
Il vaut mieux utiliser

=RECHERCHEV(D2;Feuil1!$A1:$B100;2;1)

rechercher le plus approchant au lieu de exact mettre 1 au lieu de zéro
Messages postés
11760
Date d'inscription
mercredi 16 janvier 2013
Statut
Membre
Dernière intervention
17 février 2020
1 663
Bonjour

Avec G56 en B6 :
=RECHERCHEV(B6&"*";Feuil1!$A:$B;2;0)
retournera la description de la 1ère occurrence commençant par G56

Cdlmnt
Via