Calcul

Signaler
-
DjiDji59430
Messages postés
2564
Date d'inscription
samedi 19 avril 2008
Statut
Membre
Dernière intervention
13 février 2020
-
Bonjour,

J'emplois la formule pour calculer les années, les mois et les jours restant entre deux date et dans le domaine que je travail les restants devient un mois supplémentaire : exemple 2011-08-01 à 2012-08-01 Donc 1 an(s), 0 mois et 1 jour(s) mais j'aimerais que s'il y a des jours restant qu'il soit calculer comme un mois suplémentaire Exemple : 1 ans et 1mois ou 13 mois

Voici la formule que j'utilise :
=DATEDIF(B7;C7;"y")&" an(s), "&DATEDIF(B7;C7+1;"ym")&" mois et "&DATEDIF(B7;C7+1;"md")&" jour(s)"

J'attends de voir la solution

Nico





Configuration: Windows / Chrome 79.0.3945.130

4 réponses

Messages postés
2564
Date d'inscription
samedi 19 avril 2008
Statut
Membre
Dernière intervention
13 février 2020
307
Bonjour à tous,

un essai :

=SI(JOUR(C7)>=JOUR(B7);DATEDIF(B7;C7;"y")&" an(s), "&DATEDIF(B7;C7;"ym")+1&" mois";DATEDIF(B7;C7;"y")&" an(s), "&DATEDIF(B7;C7;"ym")*1&" mois")


Crdlmt
Cette formule ne fonctionne pas

Merci beaucoup de m'aider à trouver une solution

Nico
Messages postés
50948
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
17 février 2020
12 104
Tu envoies ton fichier en ajoutant dans une ligne ta formule, dans une autre celle de DjiDji.
Nous essayerons de trouver ce qui bloque (probablement le format des dates).
 1) Tu vas dans http://cjoint.com/ 
2) Tu cliques sur [Parcourir] pour sélectionner ton fichier (15 Mo maxi)
3) Tu défiles vers le bas pour cliquer sur le bouton bleu [Créer le lien Cjoint]
4) Au bout de quelques secondes la deuxième page s'affiche, avec le lien en gras ; tu fais un clic-droit dessus et tu choisis "Copier le lien"
5) Tu reviens dans ta discussion sur CCM, et dans ton message tu fais "Coller".
=>Voir la fiche http://www.commentcamarche.net/faq/29493-utiliser-cjoint
Il existe aussi :
1) https://mon-partage.fr/
2) https://www.transfernow.net/

Messages postés
9202
Date d'inscription
lundi 18 octobre 2010
Statut
Membre
Dernière intervention
12 février 2020
1 708
Bonjour à tous

Essaies ceci
=DATEDIF($A$2;$B$2;"y")&" ans "&DATEDIF($A$2;$B$2;"ym") +SI(DATEDIF($A$2;$B$2;"md")>0;1;0) &" mois "
https://mon-partage.fr/f/Jus2TGJ4/

CDlmnt
Messages postés
2564
Date d'inscription
samedi 19 avril 2008
Statut
Membre
Dernière intervention
13 février 2020
307
Re

Correction:
=SI(MOIS.DECALER(C7;12*(ANNEE(B7)-ANNEE(C7)))<B7;DATEDIF(B7;C7;"y")&" an(s), "&DATEDIF(B7;C7;"ym")&" mois";DATEDIF(B7;C7;"y")&" an(s), "&DATEDIF(B7;C7;"ym")+1&" mois")

CCM81
entré le 20/5/2011 sorti le 19/5/2012 ==>12 mois.....oui
entré le 20/5/2011 sorti le 20/5/2012 ==>1 an+1jour ==>1an et 1 mois
pas 1 an+0 jour
entré le 20/5/2011 sorti le 21/5/2012 ==>1 an+1 mois.....oui

https://www.cjoint.com/c/JBijYhd3WSU

Nico :
Quand on dit, "cette formule ne fonctionne pas", on explique pourquoi. Certains cas peuvent nous avoir échapper !


Crdlmt