Reporter la valeur d'une autre cellule si identique

Signaler
Messages postés
42
Date d'inscription
mardi 29 juillet 2008
Statut
Membre
Dernière intervention
6 février 2020
-
bacflippe
Messages postés
42
Date d'inscription
mardi 29 juillet 2008
Statut
Membre
Dernière intervention
6 février 2020
-
Bonjour,
Je reviens voir si une âme charitable voudrait bien voler à mon secours ?
J'aimerais pouvoir récupérer en cellule B1 de la feuille attestation le contenu de la cellule D3 de la feuille clients si et seulement si A2 !Attestation = A3 !Clients

Je souhaiterais également récupérer en cellule C1 de la feuille Attestation le chemin d'un fichier se trouvant sur mon PC de ce type file:\\C:\Users\.... sachant que le fichier est nommé comme le nom/prénom clients, peut-être une macro ...
Ci-joint le fichier https://www.cjoint.com/c/JBephYnzFE8

Merci d'avance !

6 réponses

Messages postés
690
Date d'inscription
lundi 22 septembre 2008
Statut
Membre
Dernière intervention
15 février 2020
120
Messages postés
16081
Date d'inscription
lundi 12 septembre 2005
Statut
Contributeur
Dernière intervention
14 février 2020
2 876
Bonjour

en B2 de attestation
=SI(NB.SI(Clients!A$2:A$4;A2)>0;DECALER(Clients!A$1;EQUIV(A2;Clients!A$2:A$4;0);3); " inconnu") 


à copier vers le bas

Pas compris la 2° question
Messages postés
42
Date d'inscription
mardi 29 juillet 2008
Statut
Membre
Dernière intervention
6 février 2020

La formule fonctionne parfaitement, à moi de l'adapter maintenant !
Milles merci !

Edit: Je reviens vers vous car en modifiant la formule cela ne fonctionne plus pour ce qui est de l'adresse mail , pour le chemin vers le fichier c'est parfait !

Voici ce qui change dans la formule :
=SIERREUR(INDEX(Clients!E:E;EQUIV(Publi!A2;Clients!A:A;0));"")

Sachant que les noms de clients sont toujours en Clients!A, les mails en Clients!E , la cellule référence en Publi!A2 au lieu de Attestation!A2 ...
Re merci d'avance !
Messages postés
42
Date d'inscription
mardi 29 juillet 2008
Statut
Membre
Dernière intervention
6 février 2020

Merci pour votre formule, elle fonctionne également, je me trompais de lettre dans mon tableau voilà pourquoi j'avais une erreur sur la 1ère formule !
Pour la deuxième question la formule proposée par M-12 répond à mes besoins merci !
michel_m
Messages postés
16081
Date d'inscription
lundi 12 septembre 2005
Statut
Contributeur
Dernière intervention
14 février 2020
2 876
Le problème avec SIERREUR est qu'il n'indique pas la cause de l'erreur...
tu avais demandé qu'il fallait que "A2 !Attestation = A3 !Clients" <==> le nom indiqué dans attestation est bien dans la liste des identités colonne A
Le test "NB.SI(Clients!A$2:A$4;A2)>0" répond à cette question et indique, lui, l'origine de l'erreur

ici, le problème est simple mais il faut toujours avoir en t^te de simplifier au maximum le travail du futur intervenant ( la maintenance et la modification du process représente 80% de la durée de vie du process)

au passage: dans tes messages indique à qui tu t'adresses ici M12 que je salue ou Michel
Messages postés
42
Date d'inscription
mardi 29 juillet 2008
Statut
Membre
Dernière intervention
6 février 2020

@michel_m
Merci pour ces explications et cette formule qui fonctionne à merveille !
@M-12
Merci également pour la deuxième formule qui répond parfaitement à mes besoins !
Sujet résolu merci de votre aide !
Messages postés
42
Date d'inscription
mardi 29 juillet 2008
Statut
Membre
Dernière intervention
6 février 2020

Je reviens finalement vers vous car je souhaiterais si possible , ajouter une condition à la formule : si le nom clients attestation "et l'adresse postale" sont identiques aux champs de la feuille clients alors ......
Encore merci d'avance pour votre aide !
Cordialement

https://www.cjoint.com/c/JBgaXWFKuR8