Matching via excel

Signaler
-
 eugene -
Bonjour à toutes et tous :)

Je remercie par avance celles et ceux qui auront la patience de me lire et d'essayer d'y apporter une réponse.

Mon thème est l'immobilier, et le Matching entre acquéreur et biens. J'ai crée deux feuilles:

- Dans la première: Les acquéreurs avec leurs critères (feuille acquéreurs)
- Dans la seconde : Les biens avec leurs caractéristiques (feuille biens)

Dans la feuille acquéreur, ces derniers sont affichés en ligne et leurs critères en colonne.
Dans cette même feuille, j'ai ajouté en colonne tous les biens (bien 1; bien 2 ; bien 3 etc...) soit à peu près 1000 colonnes.

Ainsi grâce à la formule suivante tirée sur chaque colonne: =SI(ET($G3>=Biens!$B$2;$H3=Biens!$E$2;$I3=Biens!$A$2;$J3<=Biens!$D$2;$K3<=Biens!$C$2);"MATCH";"")

J'arrive à obtenir le mot "MATCH", au croisement de ma ligne acquéreur et ma colonne bien lorsque les données demandées sont concordantes.

Enfin dans une dernière feuille (résultat concaténé), je reprends le nom de mes acquéreurs en lignes et en colonne mon nombre de biens, grâce à la formule suivante
(=SI(acquéreurs!X3="MATCH";CONCATENER(Tableau2[#En-têtes;[Bien 1]]&" "; acquéreurs!$C3&" ";acquéreurs!$D3);""), j'obtiens le résultat de ma concaténation ex: (Bien 263 Tintin DUPONT) dans chaque cellule à l'intersection des lignes et colonnes.

MON PROBLÈME EST LE SUIVANT:

j'aimerais pouvoir obtenir dans une lecture simple tous mes résultats concaténés type: tous à gauche dans un tableau! ou encore toutes les cellules vides se masquent automatiquement.

Vous allez certainement me dire que je me suis fracturé le crâne pour rien dans toutes mes formules ou que j'ai fait trop de chemins pour aller à l'essentiel, mais je vous pris de me juger avec indulgence car je suis novice dans le domaine et je pense être arrivé au bout de mes compétences.

je m'en remets totalement à vous, et par avance merci encore!


Configuration: Windows / Chrome 79.0.3945.130

4 réponses

Bonsoir,
S'agit-il de faire la liaison entre des biens en vente et des acheteurs potentiels, genre M. X cherche un appart de 4 pièces, surface min 70 m2, prix max 200.000 euros ? Avons nous ça dans notre base ?
Ou s'agit-il d'autre chose, je n'ai rien compris à votre demande et je ne suis probablement pas le seul.
Cordialement.
Bonjour oui il s'agit bien de différents critères qui ont été identifiés : prix max, surface, nb de pièces, etc ...

Je vais joindre un fichier afin de rendre la chose plus concrète. Je me doute que vous n'avez rien compris car rentrer dans les méandres de mon cerveau est un exercice difficile mdrrr
Messages postés
16082
Date d'inscription
lundi 12 septembre 2005
Statut
Contributeur
Dernière intervention
14 février 2020
2 875
Bonjour

Eugène a écrit
je n'ai rien compris à votre demande et je ne suis probablement pas le seul.
Effectivement, Eugène, tu n'es pas tout seul!

déjà, pour tenter quelque chose:
Mettre le classeur sans données confidentielles en pièce jointe sur 
https://mon-partage.fr
Dans lien de téléchargement
faire un clic droit- copier l’adresse du lien et le coller dans votre message en cours sur ccm





le voici, merci
https://mon-partage.fr/f/2LgIcHJ7/
Bonjour,
S'il s'agit d'extraire à partir des demandes d'un client potentiel un ou plusieurs biens en vente possédant les caractéristiques souhaitées, j'essaierais un tableur comme le modèle réduit ci joint.
Voyez si vous pouvez y puiser quelques idées.
Cordialement.
https://cjoint.com/c/JBig2rfQqHN
merci beaucoup effectivement il y a un petit quelque chose dont je dois m'inspirer
Comme je continue à faire travailler mes derniers neurones sur ce tableur, pourriez vous me préciser ce qui correspond à votre problème et ce qui ne correspond pas ?
Je suppose que votre problème est résolu.