Décimales impossibles à enlever [Résolu]

Signaler
-
Mike-31
Messages postés
17015
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
16 février 2020
-
Bonjour,



Configuration: Macintosh / Safari 13.0.4


Je suis en train de galèrer sur un tableur calc Openoffice...
À la suite de formules rentrées dans certaines cellules,
(Des formules de conditions du style : =SI((..... = ......);C15) etc, etc...
le résultat s'affiche avec des décimales !!!!!! J'ai tout essayer dans format de cellule pour les supprimer, mais rien à faire. Please HELP ME !!!!!!

4 réponses

Messages postés
7954
Date d'inscription
dimanche 13 juin 2010
Statut
Membre
Dernière intervention
21 février 2020
1 295
Bonjour,

Si le format de cellule n'agit pas sur le nombre de décimales, c'est que la cellule ne contient pas un nombre mais un chiffre, c'est à dire la représentation textuelle d'un nombre et donc, dans ce cas, le format nombre n'agit pas sur le texte.
Il faut donc s'assurer que le résultat de la formule est bien un nombre, lorsque l'alignement horizontal est « Par défaut » :


EDIT
: si la cellule contient un nombre, s'assurer qu'il n'y pas une MFC qui force les décimales

Cordialement
Patrice

Personne ne peut détenir tout le savoir, c'est pour ça qu'on le partage.
Tu les retrouve où c'est paramètres??
Bonjour tout le monde,

Je réouvre ce post (mon plus grand désarroi) car seulement une partie du problème est résolu... je pense qu'il y a en effet un problème de cellule (entre chiffre / nombre / etc) mais je suis toujours bloqué...
Please help me :(
Patrice33740
Messages postés
7954
Date d'inscription
dimanche 13 juin 2010
Statut
Membre
Dernière intervention
21 février 2020
1 295 > Bastos
« mais je suis toujours bloqué... »
Nos boules de cristal sont en quarantaine pour un certain temps !!!
Quel est le nouveau problème, quelles sont les formules exactes de la cellule et des cellules antécédantes ?
Mike-31
Messages postés
17015
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
16 février 2020
3 822 > Patrice33740
Messages postés
7954
Date d'inscription
dimanche 13 juin 2010
Statut
Membre
Dernière intervention
21 février 2020

Re,

Ça fait une semaine je te demandais le fichier qui nous aurait permis de cerner facilement tes problèmes tu as sur mon post 4 la démarche détaillée pour cela.

Salut Patrice, je pense que tu n'as pas vu mon MP que je t'ai adressé.

A+
Messages postés
17015
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
16 février 2020
3 822
Bonjour,
Pour ma part je crois que l'on va chercher longtemps sans voir ton fichier.
S'il n'est pas confidentiel ou efface ce qui l'est et poste ton fichier que l'on voit

Pour joindre ton fichier
1) Tu vas dans http://cjoint.com/
2) Tu cliques sur [Parcourir] pour sélectionner ton fichier (15 Mo maxi)
3) Tu défiles vers le bas pour cliquer sur le bouton bleu [Créer le lien Cjoint]
4) Au bout de quelques secondes la deuxième page s'affiche, avec le lien en gras ; tu fais un clic-droit dessus et tu choisis "Copier le lien"
5) Tu reviens dans ta discussion sur CCM, et dans ton message tu fais "Coller".
=>Voir la fiche http://www.commentcamarche.net/faq/29493-utiliser-cjoint

dans le même style tu as https://mon-partage.fr/
Oulaaa !!! Ça commence à devenir trop technique pour moi ...
Possibilité d'échanger en MP ? Tel ?
Je suis vraiment bloqué depuis 2 jours.
Merci pour vos précieuses réponses qui m'ont bien aiguillé. J'ai fais un renvoi de cellule et ai inscrit la formule : =CNUM(cellule)
Ça marche impeccable !!!!