Formule si [Résolu]

Signaler
Messages postés
8
Date d'inscription
lundi 27 janvier 2020
Statut
Membre
Dernière intervention
30 janvier 2020
-
saaydo
Messages postés
8
Date d'inscription
lundi 27 janvier 2020
Statut
Membre
Dernière intervention
30 janvier 2020
-
salut tout le monde
depuis quelques temps j'ai essayé de faire un tableau pour mes débits et mes crédits (dépenses et gains) mais j'ai un petit souci c'est que lorsque je mets sur le cellule du total =SI(G8<>"";G8+I7;I7-H8) çàd si G8 est pleine alors G8+I7 sinon (elle est vide alors I7-H8 la formule fonctionne sauf que les autres cellules sous I7 (I8,I9....) affichent le même montant que sur I7 , même si les autres cellules gains ou dépenses ne sont pas encore remplies !!!
je voudrais que cet affichage n’apparaît pas
aidez moi svp merci

4 réponses

Messages postés
11784
Date d'inscription
mercredi 16 janvier 2013
Statut
Membre
Dernière intervention
22 février 2020
1 672
Bonjour

Peux tu fournir un exemple de ton fichier en le postant sur mon-partage.fr, en copiant le lien créé et en revenant le coller ici

Cdlmnt
Via
saaydo
Messages postés
8
Date d'inscription
lundi 27 janvier 2020
Statut
Membre
Dernière intervention
30 janvier 2020

salut encore une fois
j'ai essayé de trouver comment vous envoyer le fichier mais en vain!!!
merci de m'indiquer comment créer le lier et vous envoyer le fichier
merci
via55
Messages postés
11784
Date d'inscription
mercredi 16 janvier 2013
Statut
Membre
Dernière intervention
22 février 2020
1 672 > saaydo
Messages postés
8
Date d'inscription
lundi 27 janvier 2020
Statut
Membre
Dernière intervention
30 janvier 2020

Bonjour

Comme je l'indiquais précédemment tu vas sur ce site https://mon-partage.fr/
Tu suis les 3 étapes (tu peux peux sauter la 2), une nouvelle page s'affiche avec le lien créé en bleu, clic droit sur ce lien et Copier puis tu reviens ici le coller
saaydo
Messages postés
8
Date d'inscription
lundi 27 janvier 2020
Statut
Membre
Dernière intervention
30 janvier 2020
> via55
Messages postés
11784
Date d'inscription
mercredi 16 janvier 2013
Statut
Membre
Dernière intervention
22 février 2020

via55
Messages postés
11784
Date d'inscription
mercredi 16 janvier 2013
Statut
Membre
Dernière intervention
22 février 2020
1 672 > saaydo
Messages postés
8
Date d'inscription
lundi 27 janvier 2020
Statut
Membre
Dernière intervention
30 janvier 2020

Re,

Remplace ta formule en J6 par
=SI(SOMME(G6:H6)=0;"";SI(G6>0;G6+I5;I5-H6))
puis étire la vers le bas

Cdlmnt
Via
saaydo
Messages postés
8
Date d'inscription
lundi 27 janvier 2020
Statut
Membre
Dernière intervention
30 janvier 2020
> via55
Messages postés
11784
Date d'inscription
mercredi 16 janvier 2013
Statut
Membre
Dernière intervention
22 février 2020

c'est génial ça marche !!
un très grand merci
saaydo
Messages postés
51002
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
23 février 2020
12 168
Bonjour.

Il suffit d'ajouter cette condition, ce qui donne :
= SI(ET(G8="";H8="");""; SI(G8<>"";G8+I7;I7-H8) )
qu'on peut également écrire :
= SI(G8+H8=0;""; SI(G8<>"";G8+I7;I7-H8) )
saaydo
Messages postés
8
Date d'inscription
lundi 27 janvier 2020
Statut
Membre
Dernière intervention
30 janvier 2020

merci beaucoup Raymond Pentier
je vais essayer la formule ...
Messages postés
8
Date d'inscription
lundi 27 janvier 2020
Statut
Membre
Dernière intervention
30 janvier 2020

salut Mr Raymond
après deux essais pour chaque formule rien ne marche malheureusement les cellules indiquent erreur!!!
Raymond PENTIER
Messages postés
51002
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
23 février 2020
12 168
C'est très curieux :
J'ai mis ma formule dans ton fichier, et tout marche parfaitement !
D'ailleurs ma formule est semblable à celle de mon ami Via ...
saaydo
Messages postés
8
Date d'inscription
lundi 27 janvier 2020
Statut
Membre
Dernière intervention
30 janvier 2020
> Raymond PENTIER
Messages postés
51002
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
23 février 2020

salut Mr Raymond
oui c'est bizarre mais ....
merci encore une fois d'avoir donné beaucoup d’intérêts à ma requête ...
merci
Bonjour,
Une suggestion :
https://cjoint.com/c/JADmr2FZQYN
Cordialement.