Clé Wifi TP-link AC1300

Signaler
-
 Seb -
Bonjour,

Après avoir fait presque tout les sites sur raspbian qui expliquait comment connecter une clé wifi, je ne comprends toujours pas comment faire. J'ai compris qu'il fallait installé un certain package pour que raspbian reconnaisse notre clé mais le quel ?.

Quelques infos supplémentaires :
-quand je fais un lsusb il reconnait ma clé tp-link
-dans les réseaux il m'affiche "no wireless interfaces found"

merci d'avance pour votre aide et merci d'avoir pris du temps à lire ;)

5 réponses

Messages postés
38467
Date d'inscription
dimanche 7 novembre 2010
Statut
Contributeur
Dernière intervention
28 février 2020
4 705
Salut,
quand je fais un lsusb il reconnait ma clé tp-link
On peut voir la sortie de cette commande ?

Alors pour ma TP-link c'est :

Bus 001 Device 003: ID 2357:0115 TP-Link

J'imagine que c'est l'ID qui vous intéresse mais je mets tout au cas ou :)
zipe31
Messages postés
38467
Date d'inscription
dimanche 7 novembre 2010
Statut
Contributeur
Dernière intervention
28 février 2020
4 705
Bonjour,
Essaie ceci dans le terminal :
sudo apt install git dkms build-essential
git clone https://github.com/jeremyb31/rtl8822bu.git
sudo dkms add ./rtl8822bu
sudo dkms install 8822bu/1.1

N'oublie pas de redémarrer.

Source : https://forums.linuxmint.com/viewtopic.php?t=283990
petit problème je n'arrive pas à faire la dernière commande car
"Your kernel headers for kernel 4.19.75-v7l+ cannot be found at /lib/modules/4.19.75-v7l+/build or /lib/modules/4.19.75-v7l+/source"

J'ai le dossier 4.19.75.... j'ai un dossier "kernel" et plusieurs fichiers "modules...." avec pleins d'extention ou nom différent ex : modules.alias, modules.quelquechose etc...

Du coup j'ai test de créer un dossier build et de mettre le dossier kernel dedans mais ça n'a pas marché (j'ai du tout faire en ligne de commande car il ne me laisse pas déplacer des dossiers dans 4.19.75......)
zipe31
Messages postés
38467
Date d'inscription
dimanche 7 novembre 2010
Statut
Contributeur
Dernière intervention
28 février 2020
4 705
Re-

Il semblerait qu'il te faille installer ce paquet :
raspberrypi-kernel-headers
qui fourni le fameux répertoire "build".

Voilà ce qu'on y trouve en fonction de son noyau :
$ sudo apt-file show raspberrypi-kernel-headers
raspberrypi-kernel-headers: /lib/modules/4.19.66+/build
raspberrypi-kernel-headers: /lib/modules/4.19.66-v7+/build
ça ne marche pas :/ la commande en soit m'envoie une erreur mais j'ai installé comme ceci :

sudo apt-get install raspberrypi-kernel-headers

ce qui marche mais je n'arrive toujours pas a installé 8822bu/1.1