Formule pour mise en forme conditionnelle [Résolu]

Signaler
Messages postés
205
Date d'inscription
dimanche 3 février 2019
Statut
Membre
Dernière intervention
17 janvier 2020
-
Thorriak
Messages postés
205
Date d'inscription
dimanche 3 février 2019
Statut
Membre
Dernière intervention
17 janvier 2020
-
Bonjour à tous,

Je suis sur Excel 2016.

Je suis en train de créer un excel pour une liste de nos serveurs. Cette liste est donc dynamique et voué à changer régulièrement. Je cherche les meilleurs options pour que moi et mon équipe ne perdons pas de temps avec la mise en forme. Aussi je souhaite mettre une règle en place avec une formule.

Voilà mon souhait :
Mon tableau s'arrête à la colonne J (J compris), je voudrais que lorsqu'une cellule d'une ligne n'est pas vide, alors appliqué le format aux cellules de la ligne jusqu'à la colonne J.

Est-ce possible ? Et bien entendu si oui, comment faire ?

Cordialement.

2 réponses

Messages postés
24769
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
17 janvier 2020
4964
effectivement j'avais mal lu et la MFC s'appliquait uniquement si J contenait une valeur
voyez ici:
https://mon-partage.fr/f/5g4F9rrS/
crdlmnt

Thorriak
Messages postés
205
Date d'inscription
dimanche 3 février 2019
Statut
Membre
Dernière intervention
17 janvier 2020
20
Merci @Vaucluse c'est exactement ça.

Je met la solution directement ici pour éviter aux prochaines personnes qui en aurait besoin d'avoir à télécharger le fichier ou si celui ci n'est plus disponible.

formule si le tableau ne contient pas de formule renvoyant "":; --> =NB.SI($A2:$J2;"<>")>0
formule si le tableau contient des formules renvoyant "" à ne pas prendre en compte --> =NB.SI($A2:$J2;"><")>0

Encore merci.

Cordialement.
Messages postés
24769
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
17 janvier 2020
4964
Bonjour
sélectionnez la plage à traiter
mise en forme conditionnelle / utiliser une formule
si on commence en ligne 2
la formule:
=$J2<>""
formatez
le reste va s'ajuster tout seul. Respecter bien le $ devant le J pour formater toutes les cellules de la ligne
crdlmnt
Thorriak
Messages postés
205
Date d'inscription
dimanche 3 février 2019
Statut
Membre
Dernière intervention
17 janvier 2020
20
Bonjour,

Merci de ton aide mais visiblement ta solution ne semble pas fonctionné.

Cordialement.