Combinaison formule SI et OU

Signaler
Messages postés
7
Date d'inscription
jeudi 16 janvier 2020
Statut
Membre
Dernière intervention
16 janvier 2020
-
T3chN0g3n
Messages postés
1267
Date d'inscription
samedi 16 février 2019
Statut
Membre
Dernière intervention
16 janvier 2020
-
Bonjour,

J'ai fait une formule utilisant SI(valeur;vrai;faux)
Sauf que la valeur est composée de plusieurs critères.
J'ai utilisé OU(A1="trente";A1="dix")
J'aimerai rajouté ou remplacé que A1 contient "trente" ou A1 contient "dix".
Mais A1="*trente*" ne fonctionne pas. Il ne se passe rien.



Avez-vous une solution ?

Configuration: Windows / Edge 18.18362

2 réponses

Messages postés
11547
Date d'inscription
mercredi 16 janvier 2013
Statut
Membre
Dernière intervention
16 janvier 2020
1588
Bonjour

Essaie plutôt
=SI(NB.SI(D1;"*trente*")=1;E1 &",,,"&F1;E1)

Cdlmnt
Via
Laura_0803
Messages postés
7
Date d'inscription
jeudi 16 janvier 2020
Statut
Membre
Dernière intervention
16 janvier 2020

J'ai remplacé D1 par E1

Ma formule finale est :
=SI(OU(NB.SI(E1;"*dix*")=1;NB.SI(E1;"*trente*")=1);CONCATENER(E1;",,,";F1);E1)

Merci beaucoup ! C'est parfait !
T3chN0g3n
Messages postés
1267
Date d'inscription
samedi 16 février 2019
Statut
Membre
Dernière intervention
16 janvier 2020
117 > Laura_0803
Messages postés
7
Date d'inscription
jeudi 16 janvier 2020
Statut
Membre
Dernière intervention
16 janvier 2020

Effectivement toutes les formules ne prennent pas en charge les "caractères de remplacements", petite liste ici ;)
Messages postés
1267
Date d'inscription
samedi 16 février 2019
Statut
Membre
Dernière intervention
16 janvier 2020
117
Bonjour,

Navré mais je ne comprend pas la demande :/
"J'aimerai rajouté ou remplacé que A1 contient "trente" ou A1 contient "dix"."
C'est à dire ? ^^

Cdlt.
Laura_0803
Messages postés
7
Date d'inscription
jeudi 16 janvier 2020
Statut
Membre
Dernière intervention
16 janvier 2020

Voyez-vous mon image ?

J'arrive à dire avec ma formule (je simplifie en utilisant que trente):

G1 =SI(E1="trente";CONCATENER(E1;",,,";F1);E1)
si la case E1 a la valeur trente
alors la valeur écrite dans G1 sera égale à E1,,,F1 (soit trente,,,1)
sinon G1 sera égal à E1

Sauf que dans mon tableau en image, "trente" apparait également dans la case "trente un".
Comment puis-je dire que :
si la case E1 contient la valeur trente
alors la valeur écrite dans la case G1 sera égale à E1,,,F1 (soit trente un,,,1 ainsi que trente,,,1)
sinon G1 sera égal à E1

Est-ce plus compréhensible ?