Ne rien afficher dans la cellule si résultat de la formule = 0.0. [Résolu]

Signaler
Messages postés
3
Date d'inscription
mardi 14 janvier 2020
Statut
Membre
Dernière intervention
15 janvier 2020
-
Davegus
Messages postés
3
Date d'inscription
mardi 14 janvier 2020
Statut
Membre
Dernière intervention
15 janvier 2020
-
Bonjour à tous,

j'ai un résultat sous forme de date suite à l'affichage d'une formule (logique, car lié à 3 cellules qui représente la date lorsqu'elles sont remplies).
Par contre lorsque ces cellules sont vides, il s'affiche 0.0. comme résultat et j'aimerais que rien ne s'affiche dans la cellule.

J'ai essayé avec des fonctions, format de cellules, ... mais pas moyen...

Pourriez-vous m'aider?

Merci d'avance

5 réponses

Messages postés
50827
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
29 janvier 2020
11 897
Si tu enlevais les guillemets intempestifs, ça marcherait ...
=SI(OU(A2="";B2="";C2="");"";
 
CONCATENER(SI(NBCAR(A2)<2;CONCATENER(0;A2);A2);".";SI(NBCAR(B2)<2;CONCATENER(0;B2);B2);".";C2)
 
)
Davegus
Messages postés
3
Date d'inscription
mardi 14 janvier 2020
Statut
Membre
Dernière intervention
15 janvier 2020

Merci Raymond!

ça fonctionne parfaitement!
Messages postés
9197
Date d'inscription
lundi 18 octobre 2010
Statut
Membre
Dernière intervention
25 janvier 2020
1 690
Bonjour

Mets une condition dans ta formule
Par exemple
=SI(OU(A2="";B2="";C2="");"";"ta formule")

Cdlmnt
Messages postés
3
Date d'inscription
mardi 14 janvier 2020
Statut
Membre
Dernière intervention
15 janvier 2020

Bonjour,

merci pour ta réponse rapide.

Cela non fonctionne pas, voici ma formule :

=SI(OU(A2="";B2="";C2="");"";"CONCATENER(SI(NBCAR(A2)<2;CONCATENER(0;A2);A2);".";SI(NBCAR(B2)<2;CONCATENER(0;B2);B2);".";C2)")

Il y a un message d'erreur...

Merci pour ton aide
Messages postés
16053
Date d'inscription
lundi 12 septembre 2005
Statut
Contributeur
Dernière intervention
28 janvier 2020
2 860
Bonjour

En décochant l'affichage des zéros



accès par le bouton Excel en haut et à droite
Messages postés
9197
Date d'inscription
lundi 18 octobre 2010
Statut
Membre
Dernière intervention
25 janvier 2020
1 690
Peut être en plus simple
=SI(OU(A2="";B2="";C2="");"";TEXTE(A2;"00") & "." & TEXTE(B2;"00") & "." & TEXTE(C2;"00"))

Cdlmnt