Fonction nb.si

Signaler
Messages postés
2
Date d'inscription
lundi 13 janvier 2020
Statut
Membre
Dernière intervention
13 janvier 2020
-
PapyLuc51
Messages postés
2330
Date d'inscription
dimanche 3 mai 2009
Statut
Membre
Dernière intervention
29 janvier 2020
-
Bonjour,

J'ai besoin de la formule pour résoudre le problème suivant:

En C2 j'ai 7 critères : allant de 1 à 7 en gros je veux compter = 1 les critères de 3 à 6 et à 0 les critères 1,2 et 7

J'ai essayé cela mais cela ne marche pas :(

Merci pour votre aide

=SI(C2="1";0;SI(C2="2";0;SI(C2="3";1;SI(C2="4";1;SI(C2="5";1;SI(C2="6";1;""))))))


Configuration: Macintosh / Chrome 79.0.3945.88

4 réponses

Bonsoir,
Les guillemets autour de 1, 2, 3, 4, 5, 6 sont superflus et mettre un zéro à la fin de la formule à la place des deux guillemets.
=SI(C2=1;0;SI(C2=2;0;SI(C2=3;1;SI(C2=4;1;SI(C2=5;1;SI(C2=6;1;0))))))
Cordialement.
Messages postés
270
Date d'inscription
samedi 2 février 2019
Statut
Membre
Dernière intervention
13 janvier 2020
19
Bonsoir, pour du chiffre, les "" sont inutiles, comme le dit plus haut eugene.

Les guillemets sont par contre utile quand il s'agit d'une valeur texte contrairement à une valeur numérique ;)
Messages postés
2
Date d'inscription
lundi 13 janvier 2020
Statut
Membre
Dernière intervention
13 janvier 2020

Ok très bien merci, avez vous une idée sur ma problèmatique ou pas du tout car si je rajouter C2=7;0;"") 100% des cellules passes en vide
Pourquoi rajouter C2=7.0."") ? Il semble bien que la formule rectifiée fonctionne correctement, à moins qu'il y ait autre chose...
Messages postés
2330
Date d'inscription
dimanche 3 mai 2009
Statut
Membre
Dernière intervention
29 janvier 2020
492
Bonsoir,

Formule qu'on peut réduire à :

=SI(OU(C2=1;C2=2;C2=7);0;1)

Cordialement