Fonction SI OU??, SI ET?? [Résolu]

Signaler
Messages postés
12
Date d'inscription
samedi 28 décembre 2019
Statut
Membre
Dernière intervention
12 janvier 2020
-
Nonno48
Messages postés
12
Date d'inscription
samedi 28 décembre 2019
Statut
Membre
Dernière intervention
12 janvier 2020
-
BONJOUR
Comment formuler: ( SI a1<a2 alors a3=a4, OU SI a1>a2 alors a3=a5)
Merci
Cordialement

2 réponses

Messages postés
24792
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
25 janvier 2020
4 990
Bonjour

en A3
=SI(A1="";"";SI(A1<A2;A4;A5))

modifiez < en >= si vous voulez que A3=A4 si A1=A2, sauf si vous voulez que A3 n'affiche rien si >A2 est égal à A1
Dans ce cas
=SI(OU(A1="";A2=A1);"";SI(A1<A2;A4;A5))
crdlmnt
--
La qualité de la réponse dépend surtout de la clarté de la question, merci!
Nonno48
Messages postés
12
Date d'inscription
samedi 28 décembre 2019
Statut
Membre
Dernière intervention
12 janvier 2020

Bonjour
Merci pour votre aide (exactement ce que je voulais)
Cordialement
Messages postés
37
Date d'inscription
mercredi 23 avril 2008
Statut
Membre
Dernière intervention
24 janvier 2020
3
Bonjour,
Sub test()
If Range("a1").Value < Range("a2").Value Then
Range("A3").Value = Range("A4").Value
ElseIf Range("a1").Value > Range("a2").Value Then
Range("A3").Value = Range("A5").Value
End If
End Sub

A+ François
Nonno48
Messages postés
12
Date d'inscription
samedi 28 décembre 2019
Statut
Membre
Dernière intervention
12 janvier 2020

Bonjour
Merci pour votre aide
Cordialement