Rechercher une valeur dans une matrice et pas dans une simple colonne [Résolu]

Signaler
-
 Calimerator -
Bonjour,

Je connais la fonction "recherchev" qui permet de rechercher une valeur dans la 1ère colonne d'un tableau, et de récupérer éventuellement une valeur provenant d'une autre colonne de ce même tableau.

Mais je n'ai pas trouvé de formule toute faite permettant de chercher une valeur dans l'ensemble des cellules d'un tableau.

Exemple simple, un tableau composé de 3 lignes et 2 colonnes :
Lundi Jeudi
Mardi Vendredi
Mercredi Samedi

Je veux savoir si la valeur "vendredi" existe dans mon tableau…

Je pourrais bidouiller en utilisant des "si" imbriqués, des "equiv" ou autres, mais sachant que le vrai tableau pourrait faire plusieurs dizaines de lignes et de colonnes, ça va être une usine à gaz et je vais vite atteindre les limites des niveaux d'imbrication des fonctions !

Quelqu'un aurait-il une idée simple en attendant que Microsoft se décide à implémenter cette fonction ?
Merci d'avance.

Configuration: Windows / Edge 18.18362

1 réponse

Messages postés
652
Date d'inscription
lundi 22 septembre 2008
Statut
Membre
Dernière intervention
15 janvier 2020
106
Bonjour,

En supposant que la plage soit de A1 à B3 (Lundi en A1 et Samedi en B3) comme sur ton exemple
dans une cellule, la formule
=NB.SI(A1:B3;"Vendredi")

te donnera le résultat 1 donc que le Vendredi existe

Sinon pose ta question autrement avec un classeur exemple
Quel crétin je suis ! :)

Tellement obnubilé par les fonctions de recherche que je n'ai même pas pensé à un truc aussi simple et efficace…
Shame on me :)

Merci bien et bonne journée.