Nb de valeur unique dont somme qtés des différentes occurrences supérieure à 0

Signaler
-
M-12
Messages postés
652
Date d'inscription
lundi 22 septembre 2008
Statut
Membre
Dernière intervention
15 janvier 2020
-
Bonjour,

malgré moult recherches, je n'ai pas trouvé comment répondre à mon interrogation :
je cherche à trouver en une seule formule, le nombre de références uniques d'une base de donnée. Le hic, c'est que dans la fameuse BDD, une même référence peut avoir plusieurs occurrences avec une quantité en face. Et je ne veux que les valeurs uniques pour lesquelles la somme des quantités de toutes les occurrences est supérieur à 0.

Un exemple pour ceux qui voudront bien m'éclairer :


résultat attendu 8

J'ai essayé avec sommeprod, mais je n'ai pas su trouver mon résultat.

Merci de votre aide.

Configuration: Windows / Chrome 79.0.3945.88

3 réponses

Messages postés
652
Date d'inscription
lundi 22 septembre 2008
Statut
Membre
Dernière intervention
15 janvier 2020
106
Re,

Teste ceci avec les plages nommées dynamiques
https://mon-partage.fr/f/rJvff7KG/
temesias
Messages postés
8
Date d'inscription
samedi 9 mars 2019
Statut
Membre
Dernière intervention
9 janvier 2020

Je ne peux pas accéder au fichier mais je vais creuser la piste de la plage nommée dynamique en attendant. Merci.
temesias
Messages postés
8
Date d'inscription
samedi 9 mars 2019
Statut
Membre
Dernière intervention
9 janvier 2020

J'ai créée mes plages dynamiques, et les ai testées avec une recherche de valeur unique :
=SOMMEPROD(1/NB.SI(article;article))
Ça fonctionne très bien. Merci pour la découverte de cette possibilité.

Par contre, je n'arrive pas à trouver la formule pour ma recherche.
temesias
Messages postés
8
Date d'inscription
samedi 9 mars 2019
Statut
Membre
Dernière intervention
9 janvier 2020

Ça marche parfaitement, merci.
Messages postés
652
Date d'inscription
lundi 22 septembre 2008
Statut
Membre
Dernière intervention
15 janvier 2020
106
Bonjour,
Si ta plage comme précisée dans ton poste va de A1 à B12 (avec la ligne 1 contenant les entêtes)
Teste cette formule à valider par CTRL MAJ et ENTREE (Formule matricielle)

=NB(1/FREQUENCE(SI((B2:B12<>0);EQUIV(A2:A12;A2:A12;0));LIGNE(A2:A12)-1))
temesias
Messages postés
8
Date d'inscription
samedi 9 mars 2019
Statut
Membre
Dernière intervention
9 janvier 2020

Bonjour M-12,

effectivement, j'ai oublié de préciser ce détail important ! Le problème, c'est que la plage ne contient jamais le même nombre de ligne. Pour calculer le nombre de références unique, j'utilise donc la fonction DECALER(), mais je n'ai pas réussi à l'intégrer pour avoir ce que je recherche.
Messages postés
652
Date d'inscription
lundi 22 septembre 2008
Statut
Membre
Dernière intervention
15 janvier 2020
106
Re,

As-tu regardé le classeur poste en #3