Extraire texte d'une cellule pour insérer dans une formule [Résolu]

Signaler
-
via55
Messages postés
11605
Date d'inscription
mercredi 16 janvier 2013
Statut
Membre
Dernière intervention
26 janvier 2020
-
Bonjour,

J'ai une formule qui fait recheche des valeurs associé à des noms d'employé. Exemple, Jonh Doe est attirer au projet x qui dure 3 jours, 3 jours sont ajouter à son nom dans une autre feuile de calcul.

Voici la formule

=SOMME.SI.ENS(Feuil1!C3:C40; Feuil1!D3:D40; "Jonh Doe") + SOMME.SI.ENS(Feuil1!E3:E40; Feuil1!F3:F40; "Jonh Doe ")

Cette formule est inséré dans une case à droite d'une contenant son nom. Ex:

A1 B1
Jonh Doe 30 (résultat de la forumule)

J'aimerais pouvoir extraire le texte de la case A1 pour l'insérer directement dans la formule. Pour l'instant, je dois l'écrire manuellement.

Vous avez des solutions pour moi?

Configuration: Macintosh / Chrome 79.0.3945.88

6 réponses

Messages postés
3544
Date d'inscription
jeudi 6 août 2009
Statut
Membre
Dernière intervention
11 janvier 2020
1 184
Bonjour, que contient la cellule A1? Sinon, tu peux fournir un exemple sans données personnelles en déposant un fichier sur le site cjoint.
A1 contient le nom de la personne (ex Jonh Doe) A2 contient la formule qui donne le nombre de jour travaillé Et je veux insérer son nom dans la formule, sans l'écrire manuellement. Je pourrais ensuite glisser la formule en A2, 43, A4, .. et ainsi de suite avec tous les employé.

Merci pour votre temps
Messages postés
11605
Date d'inscription
mercredi 16 janvier 2013
Statut
Membre
Dernière intervention
26 janvier 2020
1 613
Bonsoir

Tout simplement
=SOMME.SI.ENS(Feuil1!C$3:C$40; Feuil1!D$3:D$40; A1) + SOMME.SI.ENS(Feuil1!E$3:E$40; Feuil1!F$3:F$40; A1)

En mettant bien les $ aux bons endroits pour pouvoir étire la formule sans que les plages ne changent

Cdlmnt
Via
Merci, mais cette solution de fonctionne pas.. Excel ne fait pas le lien entre la postion de la cellule et son contenu. La formule ne fait donc pas la bonne recherche et donne toujours 0.

Il faudrait que je puisse extraire et transférer chaque caractère pour vraiment obtenir une recherche sur "Jonh Doe"

Merci tout de même
Messages postés
11605
Date d'inscription
mercredi 16 janvier 2013
Statut
Membre
Dernière intervention
26 janvier 2020
1 613
Re

Si la formule est parfaitement correcte et fonctionne, il est inutile d'extraire les caractères un par un !!!
Si elle ne trouve rien c'est que le nom en A1 n'est pas écrit de la même manière que dans la Feuille 1, souvent il y a un espace à la fin du mot qu'on ne voit pas et qui fait toute la différence

Retape correctement le nom en A1 pour voir

Si cela ne fonctionne toujours pas poste un exemple de ton fichier sur mon-partage.fr, copies le lien créé et reviens le coller ici, j'essayerai de regarder ce qui cloche


J'ai déposé le document ici,

https://mon-partage.fr/f/0cdoNF4D/

J'ai vérifier l'orthographe et c'est toujours non fonctionnel..

Merci pour votre temps
Messages postés
11605
Date d'inscription
mercredi 16 janvier 2013
Statut
Membre
Dernière intervention
26 janvier 2020
1 613
Je ne sais pas ce que tu mettais dans la formule puisque dans ton fichier tu as laissé "Jonh Doe" dans le fichier envoyé

En le remplaçant par A2 cela fonctionne bien :
https://mon-partage.fr/f/QFe0UMoc/

Cdlmnt
Via
En effet,

Mon erreur était sur l'utilisation des guillemets...

Merci beaucoup,
Messages postés
11605
Date d'inscription
mercredi 16 janvier 2013
Statut
Membre
Dernière intervention
26 janvier 2020
1 613
Bonne suite
On passe en résolu