Impossible de modifier php.ini [Résolu]

Signaler
Messages postés
12
Date d'inscription
samedi 28 septembre 2013
Statut
Membre
Dernière intervention
27 décembre 2019
-
ThNuts
Messages postés
12
Date d'inscription
samedi 28 septembre 2013
Statut
Membre
Dernière intervention
27 décembre 2019
-
Bonjour,

J'ai besoin de modifier mon fichier php.ini pour utiliser PHPWORD mais quand je relance apache après avoir rajouter les lignes dont j'ai besoin, celles ci sont supprimée du fichier. Y a t'il une manip spéciale à faire ? Je n'ai rien trouvé sur le sujet.

(Voici ce que j'essaye de rajouter : http://itadminguide.com/php-class-com-not-found/)

Merci

edit : j'utilise uWamp avec la dernière version de php
Configuration: Windows / Firefox 60.0

7 réponses

Messages postés
38102
Date d'inscription
dimanche 7 novembre 2010
Statut
Contributeur
Dernière intervention
27 janvier 2020
4 538
Salut,

Si on lit la doc de uWamp, on trouve ceci :
Fichier de configuration PHP : bin/php/php_[*]/php_uwamp.ini
;-\

Es-tu sûr d'éditer le bon fichier ?

Messages postés
27364
Date d'inscription
mercredi 22 octobre 2003
Statut
Modérateur
Dernière intervention
27 janvier 2020
2 047
Bonjour,

Il n'y a aucune raison pour que ton php.ini se modifie tout seul.
Donc, soit tu n'édites pas le bon fichier... soit tu as un autre souci.

Pour trouver le fichier ini utilisé, créé un fichier https://www.php.net/manual/fr/function.phpinfo.php
dedans, places-y le code :
<?php
phpinfo();
?>

Lance la page et cherches y l'emplacement du fichier php.ini utilisé

Une fois le fichier identifié,
Arrête uwamp
Fais un clic droit sur le fichier php.ini et choisi modifier en tant qu'administrateur
Effectues tes modifications;
Sauvegarde
Relance ton uWamp


Tu peux ensuite relancer la page phpinfo.php pour voir si les modifications désirées sont prises en compte.


Messages postés
12
Date d'inscription
samedi 28 septembre 2013
Statut
Membre
Dernière intervention
27 décembre 2019

Merci pour votre réponse,

J'ai donc re-vérifié que je modifie le bon fichier php.ini et c'est le cas (phpinfo me donne : Loaded Configuration File C:\UwAmp\bin\apache\php.ini )
Et pour la suite j'ai suivi vos conseils mais ça n'a rien changé ...

Quand vous dites "modifier en tant qu'administrateur", si je lance vscode en tant qu'administrateur et ensuite dedans j'ouvre php.ini, c'est bon ? Car clique droit sur php.ini me propose pas l'option
Messages postés
27364
Date d'inscription
mercredi 22 octobre 2003
Statut
Modérateur
Dernière intervention
27 janvier 2020
2 047

Quand vous dites "modifier en tant qu'administrateur", si je lance vscode en tant qu'administrateur et ensuite dedans j'ouvre php.ini, c'est bon ? Car clique droit sur php.ini me propose pas l'option

Oui c'est bien ça.
VSCode ou n'importe quel autre éditeur de texte.

tu le modifies puis tu le sauvegardes
Tu fermes le fichier
Tu le réouvres
Tes modifications doivent toujours y être..
Et donc, si oui, tu relances ton uwamp.

Messages postés
12
Date d'inscription
samedi 28 septembre 2013
Statut
Membre
Dernière intervention
27 décembre 2019

C'est exactement ce que je fais mais au moment où je relance uWamp la modification est supprimée..
jordane45
Messages postés
27364
Date d'inscription
mercredi 22 octobre 2003
Statut
Modérateur
Dernière intervention
27 janvier 2020
2 047
regarde si tu n'as pas un autre fichier php.ini dans ton dossier uWamp.
Si oui, fais y les modifications pour voir..
ThNuts
Messages postés
12
Date d'inscription
samedi 28 septembre 2013
Statut
Membre
Dernière intervention
27 décembre 2019

Les seuls autres fichiers sont des php.ini-production, php.ini-development ou php_initial.

J'ai déjà essayé de modifier php.ini-production et php.ini-development pour voir, ça n'a rien fait
Messages postés
12
Date d'inscription
samedi 28 septembre 2013
Statut
Membre
Dernière intervention
27 décembre 2019

Alors je n'avais encore pas modifié ce fichier (merci pour la trouvaille) mais bizarrement il comportait quand même la modification que je souhaite faire mais du coup ça ne fonctionne pas (même si cette fois en redémarrant apache la modif reste)
zipe31
Messages postés
38102
Date d'inscription
dimanche 7 novembre 2010
Statut
Contributeur
Dernière intervention
27 janvier 2020
4 538
Pourtant… Extrait :
6. Edit "php.ini" and add at the very end (could be
anywhere I suppose):


For super newbies: click the edit button in the UwAmp UI,
"php_uwamp.ini" will open and edit it. It will be copied to
the correct php.ini when UwAmp is restarted.
I had
trouble at first since there are several php*.ini scattered
all over.
Messages postés
12
Date d'inscription
samedi 28 septembre 2013
Statut
Membre
Dernière intervention
27 décembre 2019

J'ai trouvé mon erreur, je suis vraiment désolé c'était vraiment bête ...
En regardant pour modifier le php_uwamp.ini je me suis rendu compte que uwamp utilisé la mauvaise version de php (5.6.18 au lieu de 7.0.3)

Merci beaucoup pour votre aide, désolé que l'erreur ai été si bête :/