Condition de calcul [Résolu]

Signaler
Messages postés
107
Date d'inscription
jeudi 5 septembre 2019
Statut
Membre
Dernière intervention
25 janvier 2020
-
PapyLuc51
Messages postés
2325
Date d'inscription
dimanche 3 mai 2009
Statut
Membre
Dernière intervention
26 janvier 2020
-
bonjour à tous
une cellule de choix déroulante en AU9
le choix est 1 ou 2
X22 ma cellule de résultats
AF2 un tarif (exemple 2.50)
AF3 un tarif (exemple 3.00)
je voudrais que
-si j'active 1 en AU9 je voudrais que X22 soit égal à AF2*W22
-si j'active 2 en AU9 je voudrais que X22 soit égal à AF3*W22

3 réponses

Messages postés
2325
Date d'inscription
dimanche 3 mai 2009
Statut
Membre
Dernière intervention
26 janvier 2020
489
Bonjour,

Puisqu'il n'y a que deux possibilités en AU9

=SI(AU9<>"";SI(AU9=1;AF2*W22;AF3*W22);"")

Cordialement
Messages postés
107
Date d'inscription
jeudi 5 septembre 2019
Statut
Membre
Dernière intervention
25 janvier 2020

merci ça fonctionne super 1 heure de gagner!
et si je veux rajouter une troisième ligne dans la liste déroulante?
un grand merci
très cordialement
jacques
Messages postés
2325
Date d'inscription
dimanche 3 mai 2009
Statut
Membre
Dernière intervention
26 janvier 2020
489
Re,

pour 1, 2 ou 3 dans la liste déroulante et un nouveau tarif en AF4 ;une imbrication supplémentaire dans la formule

=SI(AU9<>"";SI(AU9=1;AF2*W22;SI(AU9=2;AF3*W22;AF4*W22));"")

Et si la liste risque de s'allonger il faudra peut-être partir sur une autre approche mais il sera alors utile d'avoir une copie du fichier via https://www.cjoint.com/ et mettre le lien obtenu sur la réponse.

Cordialement