Problème Recherchev [Résolu]

Signaler
Messages postés
95
Date d'inscription
jeudi 5 juin 2008
Statut
Membre
Dernière intervention
14 décembre 2019
-
M-12
Messages postés
666
Date d'inscription
lundi 22 septembre 2008
Statut
Membre
Dernière intervention
28 janvier 2020
-
Bonjour,

J'ai un petit soucis avec la formule recherchev.

Dans mon tableur sur la page Factures, je change le nom du destinataire ... ça fonctionne ;-)

Par contre en fonction du destinataire l'adresse etc... doit se modifier.

Ca fonctionne pour Fabien et Fabien 1 ensuite ... c'est un renvoi direct à Fabien 14 ;-(

La formule utilisée est la suivante : =RECHERCHEV(H8;Contacts!A$2:E$100;2)


H8 étant le nom du contact en liste déroulante
2 étant la colonne à sortir en fonction du contact

D'avance merci pour vos avis

https://www.cjoint.com/c/ILokLaNXyus


Configuration: Windows / Chrome 79.0.3945.79

2 réponses

Messages postés
666
Date d'inscription
lundi 22 septembre 2008
Statut
Membre
Dernière intervention
28 janvier 2020
108
Bonjour,
Dans les formules de recherche, il faut indiquer FAUX pour un résultat juste

=RECHERCHEV(H8;Contacts!A$2:E$100;2;FAUX)
Messages postés
95
Date d'inscription
jeudi 5 juin 2008
Statut
Membre
Dernière intervention
14 décembre 2019
1
Bonjour,

Impec, ça fonctionne ;-) Merci

Tu peux peut-être me dire pourquoi ça fonctionnait sur les 2 premiers destinataires ?

C'est sans doute de là qu'est partie mon erreur
M-12
Messages postés
666
Date d'inscription
lundi 22 septembre 2008
Statut
Membre
Dernière intervention
28 janvier 2020
108
Une simple réponse avec la touche F1 sur la fonction
Quatre types d’informations sont nécessaires pour définir la syntaxe de la fonction RECHERCHEV :

La valeur que vous voulez rechercher (également appelée valeur de recherche).

La plage dans laquelle se trouve la valeur recherchée. N’oubliez pas que la valeur recherchée doit toujours apparaître dans la première colonne de la plage pour que RECHERCHEV fonctionne correctement. Par exemple, si la valeur recherchée est dans la cellule C2, votre plage doit commencer par C.

Le numéro de colonne dans la plage qui contient la valeur de retour. Par exemple, si vous spécifiez B2 : D11 comme plage, vous devez compter B comme première colonne, C comme second, et ainsi de suite.

Vous pouvez aussi spécifier VRAI pour obtenir une correspondance approximative ou FAUX pour obtenir une correspondance exacte de la valeur de retour. Si vous n’indiquez rien, la valeur par défaut sera toujours VRAI ou une correspondance approximative.


= RECHERCHEV (valeur recherchée ; plage contenant la valeur recherchée, le numéro de la colonne dans la plage contenant la valeur de retour, une correspondance approximative (vrai) ou une correspondance exacte (faux)).