Formule Excel

Signaler
-
 Jess -
Bonjour tout le monde,

Je suis une alternante dans le domaine de la logistique et transport et je suis en train de créer un fichier qui nous permettra de suivre les véhicules présents dans la cour, mais j'ai un souci car je veux savoir quels sont les numéros des véhicules présents entre 9:00/10:00, 10:00/11:00 etc.… j'ai beau essayé mais je n'arrive pas à trouver la bonne formule, j'ai essayé les RECHERCHE V, RECHERCHE H, INDEX, EQUIV, NB.SI.ENS etc.…. pourriez vous m'aider s'il vous plait?

J'ai 2 tableaux, un où je mets les info et le 2eme où je serai combien de véhicules j'ai entre 9:00/10:00 ainsi que leurs numéros.

Merci d'avance.
Bonne journée à vous tous.

8 réponses

Messages postés
5382
Date d'inscription
lundi 16 avril 2012
Statut
Contributeur
Dernière intervention
14 décembre 2019
360
Bonjour Jess

Pouvez vous mettre un fichier sans donnée personnel
Allez sur CJOINT.COM
chercher votre fichier
Mettre une durée
créer un lien
Copier le lien
Coller le lien ICI sur CCM dans votre réponse


Bonjour,

je vous remercie pour votre réponse, je fais ça tout de suite.
Voici le lien, https://www.cjoint.com/c/ILdlkekDtqZ
Messages postés
5382
Date d'inscription
lundi 16 avril 2012
Statut
Contributeur
Dernière intervention
14 décembre 2019
360
Bonjour Jess

Une idée dans le fichier

https://www.cjoint.com/c/ILdmjbmkyFe

Il y a certainement plus simple ?
Merci beaucoup,

C'est exactement ce que je voulais.
Mille merci. Je suis trop contente.
Messages postés
16994
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
12 décembre 2019
3717
Bonjour,

avec une formule matricielle
=SIERREUR(INDEX($A$3:$A$31;PETITE.VALEUR(SI(B$3:B$31="x";LIGNE(INDIRECT("1:"&LIGNES(B$3:B$31))));LIGNES($1:1)));"")

https://www.cjoint.com/c/ILdne5Q8MvT

pourquoi as tu saisi les heures entre crochet
] 9:00 - 10:00 ] tu peux simplifier comme cela 9:00 - 10:00


A+
Mike-31

Je suis responsable de ce que je dis, pas de ce que tu comprends...
Merci beaucoup Mike,
En fait j'ai mis les heures comme ça pour dire que 9:00 n'était pas inclus alors que 10:00 était, mais je pense que je vais les enlever, ils comprendront la logique.

Mille merci :)