Formule avec plusieurs conditions dans une cellule. [Résolu]

Messages postés
3
Date d'inscription
dimanche 1 décembre 2019
Statut
Membre
Dernière intervention
1 décembre 2019
- - Dernière réponse : ZACKDIVER
Messages postés
3
Date d'inscription
dimanche 1 décembre 2019
Statut
Membre
Dernière intervention
1 décembre 2019
- 1 déc. 2019 à 13:29
Une cellule par exemple C8 a le chiffre 49.
Je désire que la cellule C11 m'indique :
- si C8 est inférieur à 36; alors 0
- si C8 est supérieur à 35 et inférieur ou égal à 43; alors 43-35
- si C8 supérieur à 43; alors 8
J'ai essayé plusieurs formules et je n'arrive pas au résultat escompté.
Pouvez-vous m'aider à trouver la bonne formule ?
Cordialement
ZACKDIVER
Afficher la suite 

2 réponses

Messages postés
27448
Date d'inscription
mercredi 2 mai 2007
Statut
Modérateur
Dernière intervention
5 décembre 2019
5716
0
Merci
Bonjour,

voir :
=SI(C8="";"";SI(C8<36;0;SI(C8<=43;"43-35";8))) 
, je ne suis pas sur d'avoir compris le "43-35", faut-il ce texte, ou le résultat de 43 moins la valeur de C8 ? il faudrait alors mettre
43-C8
à la place.

Cdlt
Commenter la réponse de jee pee
Messages postés
2236
Date d'inscription
dimanche 3 mai 2009
Statut
Membre
Dernière intervention
6 décembre 2019
453
0
Merci
Bonjour,

Formule x fois données dans le forum.
https://www.commentcamarche.net/forum/s/bureautique-25/heures+suppl%C3%A9mentaires

=SI(C8<=35;0;SI(C8>43;8;C8-35))

ou pour ne rien inscrire si pas d'heure sup

=SI(C8<=35;"";SI(C8>43;8;C8-35))

Cordialement
ZACKDIVER
Messages postés
3
Date d'inscription
dimanche 1 décembre 2019
Statut
Membre
Dernière intervention
1 décembre 2019
-
Je vous remercie pour la réponse, qui est exactement ce que je recherchais.
Cordialement
ZACKDIVER
PapyLuc51
Messages postés
2236
Date d'inscription
dimanche 3 mai 2009
Statut
Membre
Dernière intervention
6 décembre 2019
453 -
Re,

Alors un clic sur la roue dentée à droite du titre pour mettre en résolu

Cordialement
ZACKDIVER
Messages postés
3
Date d'inscription
dimanche 1 décembre 2019
Statut
Membre
Dernière intervention
1 décembre 2019
-
Re,

c'est fait. Encore merci pour la formule, je l'applique pour d'autres cellules et d'autres conditions.

Cordialement
Commenter la réponse de PapyLuc51