Formule SI avec critères complexes [Résolu]

Messages postés
11
Date d'inscription
samedi 11 mai 2013
Statut
Membre
Dernière intervention
28 novembre 2019
- - Dernière réponse : Adirien
Messages postés
11
Date d'inscription
samedi 11 mai 2013
Statut
Membre
Dernière intervention
28 novembre 2019
- 28 nov. 2019 à 22:54
Bonjour,

J'ai actuellement une BDD de relevés d’événements qui contiennent la date et l'heure de l’événement
Je dois trié les données de ce relevé d’événement en les regroupant selon des critères un peu complexe.
Le tri se fait sur 3 groupes :

EQUIPE 1 : Données comprises entre 5h et 13h les semaines impaires et 13h et 21h les semaines paires
EQUIPE 2 : Données comprises entre 5h et 13h les semaines paires et 13h et 21h les semaines impaires
EQUIPE 3 : Données comprises entre 21h et 5h (toutes semaines confondues)

Actuellement j'ai ajouté une colonne tranche horaire où j'extrais juste l'heure de la date qui est en format (dd/mm/aaaa hh:ss)
Ensuite j'ai ajouté une autre colonne "SEMAINE" avec la formule suivante : =SI(EST.PAIR(NO.SEMAINE(I2;2));"PAIRE";"IMPAIRE")

C'est la suite où je cherche une simplification qui doit pouvoir se faire sous forme de formule car actuellement je procède comme ci-dessous faute de mieux :

Je réalise un filtre avancé avec un petit tableau à l'écart comme suit:

TRANCHE HORAIRE |TRANCHE HORAIRE | SEMAINE
>=5 | <13 | IMPAIRE
>=13 | <21 | PAIRE

Ce qui me filtre les données de l'EQUIPE 1, donc j'ajoute une colonne EQUIPE et je saisi pour toute la colonne le nom de l'EQUIPE.
J'annule mon filtre et inverse les semaines impaires/paires et réalise à nouveau un filtre avancé et je recommence la même opération, en renseignant le nom de l'EQUIPE 2,etc...

Mon but est donc de trouver une formule capable de mettre directement le nom de l'équipe dans la ligne correspondante en fonction de ces critères ou alors si c'est trop compliqué le faire en 2 fois en ayant une une colonne de critère pour chaque équipe avec un "X" dans la colonne correspondante à l'équipe et extraire le nom de l'équipe dans la même colonne en fonction de si le "X" se trouve dans la colonne J K L par exemple.

Voici le lien avec le fichier correspondant pour mieux comprendre :

https://mon-partage.fr/f/ZxwUeVvS/


Merci à vous !


Configuration: Windows / Chrome 78.0.3904.108
Afficher la suite 

1 réponse

Messages postés
11447
Date d'inscription
mercredi 16 janvier 2013
Statut
Membre
Dernière intervention
7 décembre 2019
1541
0
Merci
Bonjour Adirien

Si j'ai bien compris, en L mettre la formule :
=SI(OU([@[TRANCHE HORAIRE]]>=21;[@[TRANCHE HORAIRE]]<5);"SYLVAIN";SI(J2<13;SI(K2="IMPAIRE";"ADRIEN";"EMMANUELLE");SI(K2="PAIRE";"ADRIEN";"EMMANUELLE")))

Cdlmnt
Via
Adirien
Messages postés
11
Date d'inscription
samedi 11 mai 2013
Statut
Membre
Dernière intervention
28 novembre 2019
-
Merci à toi ça marche ! J'ai eu un peu de mal à saisir comment elle était construite mais au final j'ai fini par comprendre, tu m'épate en tout cas car ma formatrice Excel n'avait que des choses beaucoup plus complexe à me proposer.
Commenter la réponse de via55