Comment calculer l'âge au 01/01 excel [Résolu]

Messages postés
158
Date d'inscription
jeudi 23 août 2012
Statut
Membre
Dernière intervention
28 novembre 2019
-
Bonjour,

Je souhaite attribuer une donnée aux personnes ayant 29 ans et moins au 01/01 de l'année en cours. Je n'ai pas trouvé de formule pour cela.

En A1 =Aujourdhui()
En A2 = Date de naissance

En b1 = 10 (donnée à attribuer de 29 ans et moins au 01/01)
En B2 = 20 (donnée à attribuer de 30 ans à 49 ans au 01/01)
En B3 = 30 (donnée à attribuer de 50 ans à 59 ans au 01/01)

Exemple : une personne ayant 29 ans et moins au 01/01/2019, aura 10......etc

Merci d'avance,

Configuration: Windows / Internet Explorer 11.0
Afficher la suite 

3 réponses

Meilleure réponse
Messages postés
24734
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
7 décembre 2019
4913
1
Merci
Bonjour
=SI(A2="";"";SI(DATEDIF(A2;DATE(ANNEE(A1);1;1);"y")<30;10;SI(DATEDIF(A2;DATE(ANNEE(A1);1;1);"y")<50;20;30)))
crdlmnt

Dire « Merci » 1

Heureux de vous avoir aidé ! Vous nous appréciez ? Donnez votre avis sur nous ! Evaluez CommentCaMarche

CCM 62800 internautes nous ont dit merci ce mois-ci

Commenter la réponse de Vaucluse
Messages postés
5375
Date d'inscription
lundi 16 avril 2012
Statut
Contributeur
Dernière intervention
5 décembre 2019
358
1
Merci
Bonjour

A1 = CNUM("01/01/"&ANNEE(AUJOURDHUI()))
B2 =ANNEE(A1)-ANNEE(A2)
C2= RECHERCHEV($B$2;$E$1:$F$4;2;VRAI)

En colonne E et F mettre les âges et les valeurs correspondantes
E1 =1 E2 = 29 E3 =30 E4= 50
F1=rien F2= 10 F3= 20 F4= 30

Dire « Merci » 1

Heureux de vous avoir aidé ! Vous nous appréciez ? Donnez votre avis sur nous ! Evaluez CommentCaMarche

CCM 62800 internautes nous ont dit merci ce mois-ci

Commenter la réponse de PHILOU10120
Messages postés
158
Date d'inscription
jeudi 23 août 2012
Statut
Membre
Dernière intervention
28 novembre 2019
2
0
Merci
Bonjour à tous les deux,

Un grand Merci, pour votre contribution rapide et efficace !

Les 2 solutions fonctionnent ????

Bonne journée !
Commenter la réponse de PYGOS69