Excel, comment faire [...] ? [Fermé]

Signaler
Messages postés
423
Date d'inscription
lundi 3 novembre 2014
Statut
Membre
Dernière intervention
27 novembre 2019
-
PapyLuc51
Messages postés
2246
Date d'inscription
dimanche 3 mai 2009
Statut
Membre
Dernière intervention
12 décembre 2019
-
Bonjour, Bonsoir,

Une image vaut milles mots


Je voudrai que ma colonne Niveau contiennent une formule qui retourne automatiquement : 6eme ou 5eme ou 4eme etc. en fonction de la colonne Classe. Pareil pour la colonne Etablissement, il faudrait qu'elle contienne Lycée ou Collège en fonction toujours de cette colonne Classe.

Est-ce possible ?
Si oui, avez vous des indications pour m'y aider ?

Cordialement,
Ndx
Messages postés
9092
Date d'inscription
lundi 9 juin 2008
Statut
Contributeur
Dernière intervention
12 décembre 2019
467
bonjour, une image n’empêche pas d’être précis.
peux-tu, soit par des exemples, soit par une description précise, expliquer les réponses attendues?
Messages postés
2246
Date d'inscription
dimanche 3 mai 2009
Statut
Membre
Dernière intervention
12 décembre 2019
455
Salutations à tous,

@ needix59

Ce que je comprends :

Pour D2 et à condition que la fin ne comprenne qu'un seul chiffre

=SI(C2<>"";GAUCHE(C2;NBCAR(C2)-1);"")

Pour E2 et toujours avec la même condition

=SI(C2<>"";SI(OU(GAUCHE(C2;NBCAR(C2)-1)="2nde";GAUCHE(C2;NBCAR(C2)-1)="1ere";GAUCHE(C2;NBCAR(C2)-1)="tle");"Lycée";"Collège");"")


PS: pour contrebalancer la pointe d'énervement de la réponse #2 revoir la règle orthographique de "mille" inscrit avec un "s" dans la question initiale, et là ça s'apprend en primaire. ;))

Cordialement