SOMME.SI deux textes identiques [Résolu]

- - Dernière réponse :  Serocelot - 26 nov. 2019 à 17:35
Bonjour !
Je cherche désespérément une solution mais chou blanc...

Je voudrais additionner des valeurs de ma colonne B si les valeurs de ma colonne A sont identiques sachant que je ne connais pas par avance mes données en A.
Je pensais utiliser la formule SOMME.SI mais je ne sais pas comment exprimer cette condition....
Cela donne pour l'instant =SOMME.SI(A:A; texte identique ; B:B)

Pourriez vous m'aider à écrire cette formule ?

Merciiiiiiii
Afficher la suite 

2 réponses

Messages postés
11444
Date d'inscription
mercredi 16 janvier 2013
Statut
Membre
Dernière intervention
6 décembre 2019
1540
0
Merci
Bonjour

A condition que les valeurs identiques soient bien sur la même ligne et en limitant la plage de recherche à la plage contenant les données tu peux utiliser SOMMEPROD :
=SOMMEPROD((A2:A100=B2:B100)*(B2:B100))

Cdlùny
Via
Non elles sont sur la même colonne !

Colonne A Colonne B Colonne C
Nom Vente Total
Poire 1
Banane 1
Kiwi 1
Poire 0.5
Clémentine 1
Orange 1

Je voudrais trouver la formule qui me permette de dire directement en colonne C que le total de "Poire" est 1.5 :/
Commenter la réponse de via55
Messages postés
2236
Date d'inscription
dimanche 3 mai 2009
Statut
Membre
Dernière intervention
6 décembre 2019
453
0
Merci
Salutations à tous

Peut-être cette formule, pour aller dans le même sens que Via

=SOMMEPROD((A2:A100=A2)*(B2:B100))

Incrémenter vers le bas

Cordialement
Super merci beaucoup ça fonctionne parfaitement !
Et dernière question : est ce que cette formule est possible à l'inverse, pour faire une soustraction sur le même principe ?
PapyLuc51
Messages postés
2236
Date d'inscription
dimanche 3 mai 2009
Statut
Membre
Dernière intervention
6 décembre 2019
453 -
C'est à dire ?
Si c'est pour soustraire le nombre inscrit en B2 du total inscrit en C2 il suffit de mettre -B2 au bout de la formule,

Sinon explique un peu mieux ce que tu désires.

Pour la formule ci-dessus, j'ai oublié de bloquer les zones de recherche

=SOMMEPROD(($B$1:$B$100=B1)*($C$1:$C$100))

Cordialement
C'est ce que je voulais, merci encore !!!
Commenter la réponse de PapyLuc51