Comment (via un tableau excel) on peut, toutes les 8 valeurs créer une somme

Signaler
-
pilas31
Messages postés
1859
Date d'inscription
vendredi 5 septembre 2008
Statut
Contributeur
Dernière intervention
27 novembre 2019
-
Bonjour,

voici ma question j'ai des données sur un tableur et j'aimerai que pour toutes les 8 valeurs (par exemple), je puisse faire aparaitre la somme de celles-ci et ainsi de suite avec les autres valeurs et ce en incrémantant un tableau de données ... si quelqu'un pouvais m'aider ?

merci d'avance.



Configuration: Windows / Chrome 78.0.3904.70

2 réponses

Messages postés
1859
Date d'inscription
vendredi 5 septembre 2008
Statut
Contributeur
Dernière intervention
27 novembre 2019
536
Bonjour,

Une idée :

Imaginons que vos données à sommer se trouvent en colonne A et commencent à la ligne 2 car je suppose qu'il y a un titre
Prendre une colonne vide à droite de votre tableau dans mon exemple la colonne B.
En cellule B1 mettre le pas que l'on souhaite par exemple 8

Taper la formule suivante en cellule B2 :

=SI(MOD(LIGNE()-1;B$1)=0;SOMME(INDIRECT("A"&LIGNE()-B$1+1&":A"&LIGNE()));"")

"tirer" la formule vers le bas sur la colonne B.

La somme tous les pas se calcule automatiquement dans la colonne B

Si ce n'est pas la colonne B remplacer "B" par la lettre de votre colonne. Idem pour A
Si ce n'est pas la ligne 2 le début alors remplacer le -1 par - (numéro de ligne-1)